none
Upgrade to PS2013 - Content Database Restore Failing RRS feed

  • Question

  • Slugging thorough this 2010 to 2013 upgrade in our test environment I have run into a problem with restoring the content database. IT copied the backups of our 2010 environment draft, published, Reporting, Archive, and Content databases and copied them to a directory on our 2013 DEV SQL server. I proceeded run restores using SQL Server Management Studio. The draft, published, reporting, and archive DBs recovered no problem, but the content db keeps failing with this error:

    TITLE:
    Microsoft SQL Server Management Studio
    ------------------------------<o:p></o:p>

    Restore of
    database 'ProjectServer_Content' failed. (Microsoft.SqlServer.Management.RelationalEngineTasks)<o:p></o:p>

    ------------------------------
    ADDITIONAL INFORMATION:<o:p></o:p>

    System.Data.SqlClient.SqlError: Exclusive access could not be obtained because the database is in use. (Microsoft.SqlServer.SmoExtended)<o:p></o:p>

    I"m not sure why this is because this is a copied database from a totally different enviroment on a different server and it is not yet restored into the current environment, so how could it be in use? I'm trying to restoring it with a different destination database name and have no other query windows open. I've also tried copying to a different directory and renaming the copied file, but none of there work and restore still fails. I"m not a SQL person, so am a bit at a loss as to why SSMS can restore the other four dbs, but can't restore this one. Has anyone else run into this and if so, how did you resolve? Any help is greatly appreciated. Thanks

    . 


    Rick Frisby

    Tuesday, June 30, 2015 12:45 PM

Answers

  • SSMS -> Right click Databases-> Restore Files and FileGroups

    To Database: Wss_DevContent
    From Device: <file>

    Can you tell me what that gets you?

    Mark as answer if this helps?
    • Edited by kbwrecker Tuesday, June 30, 2015 1:40 PM
    • Marked as answer by Rick VF Tuesday, June 30, 2015 2:33 PM
    Tuesday, June 30, 2015 1:39 PM

All replies

  • SSMS -> Right click Databases-> Restore Files and FileGroups

    To Database: Wss_DevContent
    From Device: <file>

    Can you tell me what that gets you?

    Mark as answer if this helps?
    • Edited by kbwrecker Tuesday, June 30, 2015 1:40 PM
    • Marked as answer by Rick VF Tuesday, June 30, 2015 2:33 PM
    Tuesday, June 30, 2015 1:39 PM
  • Thank you kbwrecker, this worked. Not sure why Restore Files and FileGroups worked, but Restore Database per instructions did not, but the restore was successful using your method. Thanks again, much appreciated :)

    Rick Frisby

    Tuesday, June 30, 2015 2:32 PM