none
Restoring from imported 2012 SP1 tape RRS feed

  • Question

  • I am running DPM 2012 R2 and are trying to recover from a 2012 SP1 tape. The tape data is still current (not expired).

    The tape shows as Imported, and after a Recatalog, I can see the contents.

    When kicking off a recovery job, I see the tape listed as an available tape, but there is also a 2nd offline tape listed with the same name. I am thinking this is because DPM see's the imported tape as different, maybe because it has prepended "(imported)" to the tape name.

    I get a "Paused. Waiting for tape..." recovery status when trying to run recover from this tape.

    Can/should I change the tape label? Would that help?

    Tuesday, September 23, 2014 2:58 AM

Answers

  • Hi,

    This condition can only occur if the barcode label was changed.  Under that condition, the tape will show suspect, and if that is cleared, the tape will show imported.  The problem is we now have two records for the same tape, and the problem is the order the tape is shown in the recovery.  If the first tape listed shows offline, then we cannot recover.   This is being fixed in a future rollup, however, you can still recover the whole data set by right-clicking the tape, view tape contents - then select a dataset and click on the copy button.  That will restore that whole dataset and you can then manually copy the data you need back to original location. 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, September 23, 2014 9:36 PM
    Moderator

All replies

  • Hi,

    This condition can only occur if the barcode label was changed.  Under that condition, the tape will show suspect, and if that is cleared, the tape will show imported.  The problem is we now have two records for the same tape, and the problem is the order the tape is shown in the recovery.  If the first tape listed shows offline, then we cannot recover.   This is being fixed in a future rollup, however, you can still recover the whole data set by right-clicking the tape, view tape contents - then select a dataset and click on the copy button.  That will restore that whole dataset and you can then manually copy the data you need back to original location. 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, September 23, 2014 9:36 PM
    Moderator
  • Thanks Mike

    I have copied the database off tape and saved in a network location. I now have to mount it and extract a mailbox.

    I can see I will have this problem with all the 2012 SP1 tapes. Hopefully MS can put out an update to fix this before I have to restore a whole FileServer Drive to get back one file.

    Wednesday, September 24, 2014 11:19 AM
  • Hi,

    Can you confirm that you are running DPM 2012 R2 UR3 and you physically changed barcode labels which lead up to this problem ?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, September 24, 2014 1:22 PM
    Moderator
  • I am running RTM. I will update and see if any different.

    I have not changed any Barcode labels. DPM automatically prepended "(imported)" to the label. I was wondering if that is why DPM then saw it as a different tape and wanted to know if I renamed (removing the "(imported)" would help)

    Thursday, September 25, 2014 12:24 AM
  • Now running 2012 R2 UR3 (4.2.1254.0)

    I can report DPM still shows tape as "(Imported) Group3-LT-1Months-00000052" and when trying to recover DPM shows 2 tapes under "Tape set details":

    Tape Label                              Barcode                       Library

    Group3-LT-1Months-00000052                                    Offline

    Group3-LT-1Months-00000052                                    GROUP3

    Please note our tapes do not have barcodes, just Tape Labels.

    Thursday, September 25, 2014 1:17 AM