locked
IIS Admin Service won't start RRS feed

  • Question

  • Server 2012 R2 Datacenter, dedicated SCCM (1710) server. As of this morning the IIS Admin Service will not start and now I cannot use SCCM to build machines (it worked yesterday). Most of the applications are missing when you go to Start\Programs......almost as if the GUI is messed up. It is the same for anyone who logs in. No updates have been applied. The error is "Windows could not start the IIS Admin Service on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code -2146893818".

    The System Event Log says "The IIS Admin Service service terminated with the following service-specific error:
    Invalid Signature"

    I've read the following post http://findnerd.com/list/view/How-to-resolve-error-Could-not-start-the-IIS-Admin-Service---error-code--2146893818/4269/ but am not sure how to do options 1 or 3. With option 1 I can't tell if it suggesting I just restore the single key from the last day this worked or if I also need to so a System State restore. With option 3 that is for IIS 6 and I am running IIS 8.

    Is uninstalling\re-installing IIS (and WSUS, etc. because this is a WDS server) my only option?

    I've read that you can restore the contents of the Machine Key (C:\ProgramData\Application Data\Microsoft\Crypto\RSA\MachineKeys), but do I just delete what is in there and restore from a backup of 2 days ago? Or do I need to "regenerate" them? I've read different things and am not clear.

    https://social.technet.microsoft.com/Forums/en-US/64252410-2f8c-49bc-9847-76a67ce03460/machine-keys?forum=winserversecurity

    Tuesday, May 29, 2018 3:21 PM

Answers

All replies