Windows vista home premium WPD problem on USB-stick with exlamation mark & error code 10 RRS feed

  • Question

  • I have ASUS notebook with vista home premium, but everytime I inserted usbstick i could not find it back on explorer. that means that I could read any data on this usb stick. when i look at device manager i see an exlamation mark on WPD volume something and when i click on it itsays error code 10.

    please help if any body knows about this.

    thank you.

    Tuesday, March 17, 2009 3:08 PM





    Thank you for posting.


    Before going any further, let’s ensure the device is O.K.:


    1.    Do you have any other USB storage device? Does it work well on the computer?


    2.    Try to plug the device to another USB port without using any USB Hub device.


    3.    Does the USB device work well on other computers?


    At this time, please try the following to narrow down the issue:


    1.  Remove the related registry values


    Note: Please perform a complete system backup first. If any unexpected issue occurs, we can quickly restore the system to the current status.


    1)  Click Start, type regedit in the Start Search box, and then click regedit in the Programs list.

    If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.

    2)  In the navigation pane, locate and then click the following registry subkey:


    3)  In the details pane, right-click LowerFilters, and then click Delete.

    4)  Right-click UpperFilters, and delete it as well.

    5)  Click Yes when you are prompted.

    6)  Exit Registry Editor and restart the computer.


    2. Check the device driver


    1) Click Start, right click Computer and choose Properties.

    2) Click Device Manager.

    3) Navigate to the problematic USB device.

    4) Right click on it and choose “Uninstall”, click OK and reboot the computer.

    5) After the computer started, please check if it works. If not, please go to Device Manager and right-click on the device and choose “Update the driver software”.


    Hope this helps. Thanks.

    Nicholas Li - MSFT
    Thursday, March 19, 2009 9:51 AM