locked
Subscriber problem RRS feed

  • Question

  • Dear All,

    I have created the Replication both on the Publication Server and the Subscriber Server without any problem, but after the Subscriber is created, I'm not able to see the Subscriber. I've checked in the Replication Monitor-> All Subscriptions->Then right clicked on the Subscriber-> View Details, in the "Actions in the selected session window" the massage states that the "The process could not connect to Subscriber 'servername'".

    In the Error details window, it gives the following error message:

    <dir>

    The process could not connect to Subscriber 'Servername'. (Source: MSSQL_REPL, Error number: MSSQL_REPL0)

    Get help: http://help/MSSQL_REPL0

    Named Pipes Provider: Could not open a connection to SQL Server [53].  (Source: MSSQLServer, Error number: 53)

    Get help: http://help/53

    A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online. (Source: MSSQLServer, Error number: 53)

    Get help: http://help/53

    </dir>

    Login timeout expired (Source: MSSQLServer, Error number: HYT00)

    Would anyone let me know what might be causing the issue because I'm able to connect to the Server

    Thank you in Advance!

    Thursday, April 26, 2012 11:11 AM

Answers

  • This is saying that the distribution agent or merge agent cannot find the subscriber and that you are using named pipes as the transport mechanism. It further says that it is having a problem logging on.

    You might want to try to issue a net view on the publisher to the subscriber to see if you can see the subscriber from the publisher. The way around this problem is normally to create an alias that uses tcpip.

    It is also possible that by increasing logintimeout to 60 or 300 on the agent might solve this problem.


    looking for a book on SQL Server 2008 Administration? http://www.amazon.com/Microsoft-Server-2008-Management-Administration/dp/067233044X looking for a book on SQL Server 2008 Full-Text Search? http://www.amazon.com/Pro-Full-Text-Search-Server-2008/dp/1430215941

    • Proposed as answer by amber zhang Friday, April 27, 2012 1:29 AM
    • Marked as answer by amber zhang Friday, May 4, 2012 4:18 AM
    Thursday, April 26, 2012 7:42 PM
    Answerer

All replies

  • Hi,

    It seems publisher not connecting to subscriber check authentication and remote connections.


    Thanks&Regards Siva G

    Thursday, April 26, 2012 11:14 AM
  • Hi,

    Seems like your Browser agent is shutdown or you might have not enabled your Named-pipes , you can check this settings in connection manager.


    Regards JakDBA Please Mark this as Answered if this solves your issue or satisfied with the response.

    Thursday, April 26, 2012 7:09 PM
  • This is saying that the distribution agent or merge agent cannot find the subscriber and that you are using named pipes as the transport mechanism. It further says that it is having a problem logging on.

    You might want to try to issue a net view on the publisher to the subscriber to see if you can see the subscriber from the publisher. The way around this problem is normally to create an alias that uses tcpip.

    It is also possible that by increasing logintimeout to 60 or 300 on the agent might solve this problem.


    looking for a book on SQL Server 2008 Administration? http://www.amazon.com/Microsoft-Server-2008-Management-Administration/dp/067233044X looking for a book on SQL Server 2008 Full-Text Search? http://www.amazon.com/Pro-Full-Text-Search-Server-2008/dp/1430215941

    • Proposed as answer by amber zhang Friday, April 27, 2012 1:29 AM
    • Marked as answer by amber zhang Friday, May 4, 2012 4:18 AM
    Thursday, April 26, 2012 7:42 PM
    Answerer
  • Thank you all for your Reply!

    The "Named Pipes" was Disabled, it was as easy as that!

    Thank you!

    Monday, April 30, 2012 11:58 AM