none
DPM 2010 and Hyper-V cluster backup using Equallogic VSS writer RRS feed

  • Question

  • We have a scenario with a 3 node Hyper-V cluster using CSV volumes on a Dell Equallogic PS 6000 array. The 3 hosts are talking to the storage using iSCSI on a separate iSCSI network that is not accessible outside of the hosts (separate VLAN).

    When I attempt to configure backup of the Hyper-V virtual machines on the cluster (VHD) I can see the eqlvss writer starting and a snapshot being created on the PS6000. After 30 seconds the snapshot disappears and an event error logs indicating incorrect iSCSI CHAP authentication. This happens a number of times until the DPM sync fails. I've used the guide here https://skydrive.live.com/view.aspx?cid=525D35B4254479E8&resid=525D35B4254479E8%21161 to configure protection.

    If I disable the Equallogic vss writer, DPM uses the software Hyper-V VSS writer and backs up successfully.

    What I'd like to know is how the DPM server interacts with the snapshots on the storage device - in this case the PS6000. When the snapshot is created on the storage using the Equallogic VSS writer, does this require the DPM server to be able to communicate using CHAP auth to the snapshot on the storage (in this case it would be over the iSCSI network)?
    Or does the DPM server communicate with the agents installed on the Hyper-V hosts where the Equallogic VSS writer is running, the Hyper-V host then accesses the snapshot volume and then pass this information back to the DPM server?

    Thursday, August 2, 2012 11:43 PM

All replies

  • Hey Danny,

    In the PS Group Manager > Group Configuration > iSCSI tab, look at the iSCSI discovery filter. Is the "prevent unauthorized hosts from discovery targets" box checked? If it is, then go to one of your Hyper-V hosts, launch the EQL Remote Setup Wizard. Modify the group. Is the box "Use CHAP credentials for iSCSI discovery" checked?

    If one of these boxes is checked, and the other is not, snapshot creation will fail. When using the EQL hardware VSS provider, the DPM agent triggers the provider to create the snapshot on the EQL SAN. Once the snapshot is created, the DPM agent sends this to the DPM server. Thus, on any Hyper-V host that is to be backed up by DPM, you need the DPM agent, HIT/ME, and RSW installed.

    Friday, August 3, 2012 8:39 PM
  • I've checked in the "prevent unauthorized hosts from discovery targets" and the check box is not selected. In the RSW configuration for the group the "use CHAP credentials for iSCSI discovery" is not selected. With this configuration the backup has been failing. Do both options need to be enabled?

    Each host has the HIT, RSW and DPM agent installed.

    Monday, August 6, 2012 1:39 AM
  • Along with adding the CHAP account to the Access tab of the volume, try adding the machine to the iSCSI Initiator list. While our environment is not using Hyper-V clustering, each of our Hyper-V hosts has an assigned volume on the SAN. We didn't add the CHAP user to this tab, but used the Hyper-V host as the iSCSI Initiator. Try adding your Hyper-V hosts to the Access tab of the volume as the iSCSI initiator.
    Monday, August 6, 2012 5:48 PM
  • No joy adding the server name to the iSCSI initiator list either.

    When I use the Dell RSW tool if there is no path to the iSCSI network then the tool will tell me if has failed to authenticate - I am not getting that from the host when I enter my CHAP credentials.

    I see the snapshot being created on the EQL SAN, I see the iSCSI initiator adding the target for the snapshot to the discovery list but at that point auth is failing. From my error in the event viewer this is due to incorrect iSCSI CHAP credentials which I can confirm are being accepted from the Dell RSW tool on the Hyper-V host.

    Tuesday, August 7, 2012 2:01 AM
  • Hi Danv

    I tried the same with DPM 2012

    I can backup the Cluster with Veritas 2012  and Veeam but not with DPM 2012 (SAN Backup)

    San Backup will not working ;-(

    I am looking with MS and Dell

    If i heart news i will send you this information.

    Kind Regards

    Röndi


    Roendi

    Friday, August 10, 2012 1:40 PM