locked
VAS Upgrade from 4.1.2.20 to 4.1.3.16 fails RRS feed

  • Question

  • Hello,

    our VAS Upgrade from 4.1.2.20 to 4.1.3.16 fails with error message "The installation program was unable to read the SQL. upgrade files for the configuration database".

    Does anyone outside have any idea how to get rid of this problem?

    Best regards

    Andi


    Tuesday, May 20, 2008 11:00 AM

Answers

  • I have seen this problem and should really blog about it! The installation program was unable to read the SQL. upgrade files for the configuration database, if you review your sft-server.log you should see an entry similar to ;

     

    Couldn't open search handle for path ``C:\Program Files\Softricity\SoftGrid Server\schema\upgrade\*''.

    Generally i have seen this where the customer had installed the SoftGrid VAS to an alternate location. for example E:\Softricity\SoftGrid Server rather than the above. Reviewing the SoftGrid-server-setup.txt to spot the error and the installation rollback.

     

    We copied the data from the 'E: Softricity\SoftGrid Server\schema\upgrade' to the path 'C:\Program Files\Softricity\SoftGrid Server\schema\upgrade\*'' after we manually created the directory structure on C:. The installation then completed successfully.


    There are several folders under the 'upgrade' folder and the number is based on how many upgrade the customer has done. The names there represent each version installed. (3.1, 3.2 4.0 ect...) The data under the 'upgrade' folder is the data that needs to be moved\copied.

    Also check the following keys and ensure the path is pointed to the correct installation. Editing may allow the application to install correctly. (But this has not been tested in full)

    HCLM\Software\Microsoft\Windows\CurrentVersion\App Paths\SFTCore.exe
    HCLM\Software\Microsoft\Windows\CurrentVersion\App Paths\SFTDispatcher.exe

     

    bar that just make sure you have all the correct perms to the DB!!!

     

    Good luck!

     

    HTH

    JZ

    http://blogs.technet.com/virtualworld

    Tuesday, May 20, 2008 10:59 PM

All replies

  • I have seen this problem and should really blog about it! The installation program was unable to read the SQL. upgrade files for the configuration database, if you review your sft-server.log you should see an entry similar to ;

     

    Couldn't open search handle for path ``C:\Program Files\Softricity\SoftGrid Server\schema\upgrade\*''.

    Generally i have seen this where the customer had installed the SoftGrid VAS to an alternate location. for example E:\Softricity\SoftGrid Server rather than the above. Reviewing the SoftGrid-server-setup.txt to spot the error and the installation rollback.

     

    We copied the data from the 'E: Softricity\SoftGrid Server\schema\upgrade' to the path 'C:\Program Files\Softricity\SoftGrid Server\schema\upgrade\*'' after we manually created the directory structure on C:. The installation then completed successfully.


    There are several folders under the 'upgrade' folder and the number is based on how many upgrade the customer has done. The names there represent each version installed. (3.1, 3.2 4.0 ect...) The data under the 'upgrade' folder is the data that needs to be moved\copied.

    Also check the following keys and ensure the path is pointed to the correct installation. Editing may allow the application to install correctly. (But this has not been tested in full)

    HCLM\Software\Microsoft\Windows\CurrentVersion\App Paths\SFTCore.exe
    HCLM\Software\Microsoft\Windows\CurrentVersion\App Paths\SFTDispatcher.exe

     

    bar that just make sure you have all the correct perms to the DB!!!

     

    Good luck!

     

    HTH

    JZ

    http://blogs.technet.com/virtualworld

    Tuesday, May 20, 2008 10:59 PM
  • Hello Justin,

    that's it :-)


    Manually providing the upgrade directory structure solved the problem.

    Thank you very much.
    Best regards

    Andi
    Wednesday, May 21, 2008 9:16 AM