locked
Internet works half the time with Windows 8 RRS feed

  • Question

  • My PC worked fine with the internet until I updated to Win 8. I can only get about half of the websites to connect now. I have 7 on a different drive, and it still works fine , so it is not a hardware problem.

     I tried NETSH, to no avail. I reset my browser settings, emptied the cache, and tried disabling the firewall, renewed the ipconfig, reset the router(system is hard-wired), etc., as well as shut down any anti-virus software......and still half of my websites do not load.

     I am trying to update to 8.1, and  the download center opens,  then does not connect to the store! I have a full copy of 8.1 on disc, but I do not want to lose all my settings that I transferred over from 7 to 8. I do not understand why 8.1 does not allow one to keep one's settings ...... but 8 does.......

    Wednesday, April 2, 2014 5:09 PM

Answers

  • did you update your LAN and Wifi driver after upgrade to Windows 8. Those driver need to be updated in order to work with newer Windows

    Since you can use same hardware with Windows 7, so there is no issue with Hardware LAN/Wifi or your router. This is driver or setting issue only

    You should check your PC hardware and driver compatibility before you upgrade to newer OS

    You can use this tools

    http://windows.microsoft.com/en-us/windows-8/upgrade-assistant-download-online-faq

    Thursday, April 3, 2014 3:41 AM

All replies

  • did you update your LAN and Wifi driver after upgrade to Windows 8. Those driver need to be updated in order to work with newer Windows

    Since you can use same hardware with Windows 7, so there is no issue with Hardware LAN/Wifi or your router. This is driver or setting issue only

    You should check your PC hardware and driver compatibility before you upgrade to newer OS

    You can use this tools

    http://windows.microsoft.com/en-us/windows-8/upgrade-assistant-download-online-faq

    Thursday, April 3, 2014 3:41 AM
  • I used the upgrade assistant when I first upgraded to 8 (only way it would upgrade). My router is brand new,(with firmware updated today) and supposedly win 8 compatible. I have attempted every sort of way to reset everything.

    I cannot connect to windows download store, I cannot get my location to come up in weather, as well as multiple websites....most others work fine. IE does not run at all, Firefox is slow as death, and Chrome runs half  the websites!

    I had windows 8.1 running with no internet issues, but I wanted to keep all my 7 settings/apps...and the only way to do that is go to 8, then 8.1....which cannot be done without access to the download store. 

    Luckily, I have multiple hard drives to play with! And, luckily, I still have 7 running on a drive. I have 3 other PCs running off this modem and router with no problems (all are running 7). 

    What am I missing....or is the upgrade corrupt somehow?


    • Edited by OlBlindMan Thursday, April 3, 2014 9:41 PM
    Thursday, April 3, 2014 9:40 PM
  • For some users who have reported similar issues to what you have described, updating to the latest wireless drivers helped them to resolve their issues. For others, they had to roll back to previous versions to resolve their issues. If the latest update does not resolve the problem, you may want to try rolling back until you find a stable driver.

    Brandon
    Windows Outreach Team- IT Pro
    The Springboard Series on TechNet

    Tuesday, May 6, 2014 3:33 PM