locked
Outlook subfolders not counts in qouta RRS feed

  • Question

  • Hi,

    I use Exchange 2010 sp2 and Outlook 2k3 clients. The problem is that I have several mailboxes WAY over the mailbox quota. (the quota is 130MB, and one of them 1.4GB, several 4-500MB) The users using subfolders and it seems that the subfolder doesn't count for the qouta.

    The users are not VIP, the quota has been set up as it should be, and they get the warning and the sending/receiving restrictions if the root folders (inbox, sent, etc) reaches the limit. But they can put in the subfolder whatever they want. I want to find a solution from the server side, to "gently" push them back under the limit.

    Thanks in advance, Tib

    Thursday, October 2, 2014 5:03 AM

All replies

  • Subfolders DO count against quotas, so I'm interested in knowing why you believe they don't.  Placing things into subfolders just clears the Inbox or Sent items - it still is in the mailbox.  If you give them an archive mailbox (requires an Enterprise CAL, I believe) and have them move the items there, then they don't count to the mailbox limit - they count against the archive limit.
    Thursday, October 2, 2014 12:47 PM
  • Let me clarify the situation.

    I belive in normal case the subfolders DO count against the quota. But I have realized suprisedly that I have several mailboxes WAY over the quota. If I look at the mailbox properties on the Exchange server I see a "proper" size under the quota. But if I export the mailbox to .PST, I realize that its 4-600MB and one of them is 1.4GB. And I can count all the data inside the folders, its fit for the huge mailbox size.

    I have tried to create subfolders for a test user and it was the same. I could place houndreds of MB-s into the subfolder in the INBOX folder and I was still able to send and receive with that user.

    I believe that the quota settings are easy and clear, there is not such a setting for subfolders. For all the databases I use the 130MB quota, and all those users using the default quota. And I can not find out how can it happen at all.

    Please let me know if something is wrong with my way of thinking

    Thursday, October 2, 2014 7:26 PM
  • How have you configured the mailbox size limits?  It appears that something is missing in your configuration.  A mailbox size limit applies to the entire mailbox - all subfolders included, regardless of how they were created.  Do you have your size limit set on the mailbox or the database?  is the mailbox set to use the database size limit?  For one of the mailboxes with the limit, please run the following commands so we can see if we can find the issue:

    Get-Mailbox <affected mailbox alias> | % { Get-MailboxDatabase $_.Database } | Fl *quota
    Get-Mailbox <affected mailbox alias> | Fl *quota, Used*

    Once we see this, we should be able to figure out where things are breaking down for you.

    Thursday, October 2, 2014 7:57 PM
  • Hi,

    Agree with Willard Martin. Please make sure you configure quota settings correctly.

    Best regards,


    Belinda Ma
    TechNet Community Support

    Monday, October 6, 2014 5:23 AM
    Moderator
  • Sorry for the late reply.

    Thanks

    for the advice I have checked the mailboxes. If I run the power shell commands,  I get the answer that all my mailboxes are unlimited.  But if I check the databases as mentioned , I can see the limitations has been set up properly for every single database.  It seems now that the mailboxes not inherit the settings from the database. 

    Tuesday, October 7, 2014 1:04 PM
  • One more thing: my exchange server is 2007, not 2010. 

    Best regards,  Tibor 

    Tuesday, October 7, 2014 1:06 PM
  • Have you checked the UseDatabaseQuotaDefaults setting on the mailboxes?  If they are all set to False, the mailbox setting is used - and as you said, it's unlimited.

    If this is the case, you can reset all the mailboxes to use the database setting with the following command:

    Get-Mailbox -ResultSize Unlimited | Sort Name | Set-Mailbox -UseDatabaseQuotaDefaults:$True

    If you don't include the sort command there, you may get a pipeline error.

    Tuesday, October 7, 2014 5:41 PM
  • Thanksfor the nice tips I made some research. 

    UseDatabaseQuotaDefaultsis TRUE, Just to be sure I have gone through the SET process,  and I get  warning message for all users that the command was successful,  but it has no affect for the mailbox.

    Ihave checked the database quotas, and theq has the proper sizes,  130MB for warning,  140MB prohibit send and 150MB prohibit send-receive.  But if I ask for the mailboxes, the quotas are unlimited,  but the UseDatabaseQuotaDefaults is TRUE. 

    I know its strange,  but unfortunately I can not send screen shots. 

    Do you know about any policy,   what can affect this inheritation?

    I have tried to create a new database with a test user, but its all  the same.

    Thanks for the help,  regards: Tibor

    Wednesday, October 8, 2014 1:47 PM
  • So in brief: database quota is OK,  mailbox using database quota: TRUE,  but mailbox quota is unlimited.  Its impossible,  for the first sight. 
    Wednesday, October 8, 2014 1:50 PM
  • What are all three of your database quota settings?  "Get-MailboxDatabase | Fl Name, Iss*ta, Pro*ta" should return them all. Also, on one of your affected mailboxes, run the following and tell us what it returns:  "Get-MailboxStatistics <alias> | Fl StorageLimitStatus"
    Wednesday, October 8, 2014 2:16 PM
  • My quota settings are the same on all databases: IssueWarningQuota 130.000kb, ProhibitSendRecieveQuota: 150.000kb, ProhibitSendQuota: 140.000kb.

    For the Storage limit status I get the answer: BelowLimit.

    Thursday, October 9, 2014 1:45 PM
  • Are all of your Exchange services running properly, and are you seeing any events in your application event log?
    Thursday, October 9, 2014 2:10 PM
  • Yes, all the services are up and running, and there are no special events in the eventlog.

    The strangest thing, that the mailboxes shows that the quota is unlimited, but the users get the warning messages, if the sum of the mails reaches the quota in the root folders (inbox, deleted, sent, etc.).

    But they can send and receive if they just create a subfolder and throw everything inside the folder. I'm afraid, its not the proper way of working for the Exchange.

    Monday, October 13, 2014 7:13 AM
  • I just now noticed that you changed your Exchange version from 2010 to 2007.  My experience with Exchange 2007 is nearly forgotten - I'd almost say you are running into a bug, but can't be sure.  You might check this out to see if it's what you are seeing:  http://technet.microsoft.com/en-us/library/bb684892(v=EXCHG.80).aspx

    Monday, October 13, 2014 12:37 PM
  • Dear Martin and Belinda,

    Thanks for all the support and the good ideas. I am afraid, its really some kind of bug.

    As I researched and visited several users, it seems that subfolders DO count in the quota, the main problem was the quota inheritation between the Mail Database and the single mailboxes.

    At the end I have found a not-so-elegant but working solution in the MS Exchange 2007 SP1 book, where the author solved a similar problem by scheduling a PS script setting the mailbox quotas one by one, and make it run once a week or once in two weeks.

    I followed this way, I made the quotas set up properly one by one by a script, and if I create a new mailbox I dont have to care about the quota, the script will do it for me next time running.

    I think we can close this thread. 

    Tuesday, October 21, 2014 12:38 PM