none
How to Configure Detailed Error Pages for the FIM Portal - FIM 2010 R2 RRS feed

  • Question

  • I am trying to configure detailed error pages for Fim Portal using this article:

    How to Configure Detailed Error Pages for the FIM Portal

    The problem is that I am using Fim 2010 R2 and I think that the article above is for Fim 2010.

    There is (at least) one difference in web.config file. The article says "Enable the ILMError HTTP module" but in my web.config file there is not ILMEerror in httpModules section. Anyway ILMEerror is in modules section and I edited it as the article says.

    Unfortunately now when I am connecting to the portal, I get this error message anytime:

    Server Error in '/' Application.
    --------------------------------------------------------------------------------
    
    Object reference not set to an instance of an object. 
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 
    
    Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.
    
    Source Error: 
    
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.  
    
    Stack Trace: 
    
    
    [NullReferenceException: Object reference not set to an instance of an object.]
       Microsoft.IdentityManagement.WebUI.Controls.UICacheUtils.GetCacheKey(CacheKey key) +274
       Microsoft.IdentityManagement.WebUI.Controls.NavigationBarConfigurationModel.RetrieveSiteNodeFromCache() +118
       Microsoft.IdentityManagement.WebUI.Controls.NavigationBarProvider.BuildSiteMap() +63
       Microsoft.SharePoint.WebControls.AspMenu.AdjustForProviderMaximumDepth() +90
       Microsoft.SharePoint.WebControls.AspMenu.OnPreRender(EventArgs e) +49
       System.Web.UI.Control.PreRenderRecursiveInternal() +154
       System.Web.UI.Control.PreRenderRecursiveInternal() +239
       System.Web.UI.Control.PreRenderRecursiveInternal() +239
       System.Web.UI.Control.PreRenderRecursiveInternal() +239
       System.Web.UI.Control.PreRenderRecursiveInternal() +239
       System.Web.UI.Control.PreRenderRecursiveInternal() +239
       System.Web.UI.Control.PreRenderRecursiveInternal() +239
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +4105
     
    
    
    --------------------------------------------------------------------------------
    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.33440 

    So the case is I get that error message above straight after enabling detailed error pages. I think I shouldn't get that error mesage when the portal is working and now the error message is saying that my modifications broke something.

    Any comments or ideas or something? Has the configuration changed for Fim 2010 R2?

    Friday, May 22, 2015 7:23 AM

All replies

  • To enable detailed errors , it says you should "Comment the ILMError HTTP module", can you confirm this is what you have done? You say above that the article says "Enable the ILMError HTTP module" but as far as I can tell, this is if you are disabling detailed error pages, if you are enabling detailed error pages you should comment out this line.

    I have followed the guide in R2 and can confirm it works, substituting the ILMError httpModule with the one in modules as you described. 

    Monday, June 8, 2015 4:42 PM
  • To enable detailed errors , it says you should "Comment the ILMError HTTP module", can you confirm this is what you have done? You say above that the article says "Enable the ILMError HTTP module" but as far as I can tell, this is if you are disabling detailed error pages, if you are enabling detailed error pages you should comment out this line.

    I have followed the guide in R2 and can confirm it works, substituting the ILMError httpModule with the one in modules as you described. 

    Yes, I have commented it out.

    But what you have substituted. Can you give your configuration example?

    Tuesday, June 9, 2015 11:23 AM
  • I didn't substitute it with anything. You could just remove the line temporarily, it would have the same effect as commenting it out:

        <modules runAllManagedModulesForAllRequests="true">
          <remove name="AnonymousIdentification" />
          <remove name="FileAuthorization" />
          <remove name="Profile" />
          <remove name="Session" />
          <remove name="WebDAVModule" />
          <!--<add name="ILMError" preCondition="integratedMode" type="Microsoft.IdentityManagement.WebUI.Controls.ErrorHandlingModule, Microsoft.IdentityManagement.WebUI.Controls, Version=4.1.3479.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />-->
          <add name="ScriptModule" preCondition="integratedMode" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          <add name="SharePoint14Module" preCondition="integratedMode" />
          <add name="SPRequestModule" preCondition="integratedMode" type="Microsoft.SharePoint.ApplicationRuntime.SPRequestModule, Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
        </modules>


    • Edited by FIM-EN Tuesday, June 9, 2015 11:31 AM
    Tuesday, June 9, 2015 11:31 AM
  • I didn't substitute it with anything. You could just remove the line temporarily, it would have the same effect as commenting it out:

        <modules runAllManagedModulesForAllRequests="true">
          <remove name="AnonymousIdentification" />
          <remove name="FileAuthorization" />
          <remove name="Profile" />
          <remove name="Session" />
          <remove name="WebDAVModule" />
          <!--<add name="ILMError" preCondition="integratedMode" type="Microsoft.IdentityManagement.WebUI.Controls.ErrorHandlingModule, Microsoft.IdentityManagement.WebUI.Controls, Version=4.1.3479.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />-->
          <add name="ScriptModule" preCondition="integratedMode" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          <add name="SharePoint14Module" preCondition="integratedMode" />
          <add name="SPRequestModule" preCondition="integratedMode" type="Microsoft.SharePoint.ApplicationRuntime.SPRequestModule, Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
        </modules>


    Here is mine. As you can see it is slightly different. Also the version numbers are not the same.

    <modules runAllManagedModulesForAllRequests="true">
          <add name="ILMError" preCondition="integratedMode" type="Microsoft.IdentityManagement.WebUI.Controls.ErrorHandlingModule, Microsoft.IdentityManagement.WebUI.Controls, Version=4.1.3419.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          <add name="SPNativeRequestModule" preCondition="integratedMode" />
          <add name="StateServiceModule" type="Microsoft.Office.Server.Administration.StateModule, Microsoft.Office.Server, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
          <remove name="AnonymousIdentification" />
          <remove name="FileAuthorization" />
          <remove name="Profile" />
          <remove name="Session" />
          <remove name="WebDAVModule" />
          <add name="ScriptModule" preCondition="integratedMode" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          <add name="SharePoint14Module" preCondition="integratedMode" />
          <add name="SPRequestModule" preCondition="integratedMode" type="Microsoft.SharePoint.ApplicationRuntime.SPRequestModule, Microsoft.SharePoint, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
        </modules>

    Tuesday, June 9, 2015 12:01 PM
  • I rolled my VM back to the same version as yours and my web.config still looks the same as my previous clip except for version numbers - not sure what the differences are from in yours.
    Tuesday, June 9, 2015 7:46 PM
  • I think I will take a little break with this thing. I have tried this now for three different environments and allways the same. The portal breaks down.

    One more question for you FIM-EN. What Sharepoint version you are using, Foundation?

    Thursday, June 11, 2015 7:11 AM
  • 2010 Foundation in that environment
    Friday, June 12, 2015 6:38 PM
  • 2010 Foundation in that environment

    Ok, I think that is the problem. We are using 2013 Foundation.

    Monday, June 15, 2015 5:45 AM
  • Hi, did you find how to solve this issue?

    I have exactly the same behaviour when I try to enable detailed error pages with MIM2016 on SharePoint Foundation 2013.

    My web.config looks exactly the same as yours 2xTsei, and same error message...

    Thursday, March 22, 2018 8:45 AM