locked
Upgrade SCCM 2012 SP2 to R2_SP1 fails with permissions issue RRS feed

  • Question

  • We upgraded our SCCM 2012 SP1 install to SP2 a couple of days ago, and are attempting to enable the R2 features without success.

    I have downloaded the SC2012_R2_SP1_Configmgr folder and when running the splash.hta or ./SMSSETUP/BIN/X64/Configmgr2012R2SP1.msi, i immediately receive a popup stating that: "You must have local Administrator permissions to install this software.

    I have tried multiple local Administrator accounts with out success.  Any thoughts on how to resolve this?

    Thursday, June 4, 2015 2:12 PM

Answers

  • Did you try running it elevated?

    Jason | http://blog.configmgrftw.com | @jasonsandys

    • Marked as answer by trdavis55 Thursday, June 4, 2015 5:35 PM
    Thursday, June 4, 2015 3:10 PM

All replies

  • Did you try running it elevated?

    Jason | http://blog.configmgrftw.com | @jasonsandys

    • Marked as answer by trdavis55 Thursday, June 4, 2015 5:35 PM
    Thursday, June 4, 2015 3:10 PM
  • Yes.
    Thursday, June 4, 2015 5:27 PM
  • OK, this is truly strange.

    I had a sysadmin helping me two days ago trying to work past this weird issue and I remember him key combination clicking on the executable in Explorer and running the splash.hta as Administrator and it did not work.  But on a whim after reading you question regarding elevation, I opened Command Prompt as Administrator and ran the executable.  It ran flawlessly and my system is now recognized as R2_SP1.

    Thanks for the hint, but I am not sure why it did not run the other way...

    :-)

    • Proposed as answer by mhakeem Thursday, December 31, 2015 4:42 AM
    Thursday, June 4, 2015 5:35 PM
  • If you run CMD by choosing: "Run as Administrator" from right click menu, then locate the MSI file, it will run normally without getting this error ....... I tried it myself :) 

    Hossam Wael Elmosallamy (IT Support Engineer-ECC Solutions) MCSE - CCNA hossam.wael@eccsolutions.net Mobile:(011)-49464671 www.eccsolutions.net "Experience Reliability"

    • Proposed as answer by Nick_damas Wednesday, February 17, 2016 8:34 PM
    Wednesday, July 1, 2015 12:19 AM
  • Hmmm this is interesting, 

    OK so encountered the same problem as you just double clicking on the splash.hta.  After running from the command promt as administration I now get a message. 

    To run this software, this computer must run system center configuration manager 2012 with service pack 2. 

    Mad thing is, I  have system center configuration manager 2012 r2 installed. so in essence in upgrading from 2012r2 to 2012r2 sp1.  

    Hunting for a solution..

    Recgards

    Jeff  

    Friday, August 21, 2015 12:37 PM
  • What exactly are you trying to do? You most likely do not have the correct media.

    Please review http://blog.configmgrftw.com/service-pack-madness/


    Jason | http://blog.configmgrftw.com | @jasonsandys

    Friday, August 21, 2015 4:19 PM
  • I'm trying to upgrade from 2012r2 to 2012r2 sp1 

    I would seem in need to install SC2012_SP2_Configmgr_SCEP.exe first and then install SC2012_R2_SP1_Configmgr.exe 

    Thanks for the link

    • Proposed as answer by Nick_damas Wednesday, February 17, 2016 8:37 PM
    Monday, August 24, 2015 7:21 AM
  • Almost. You only need to run the second one if you don't have R2 already (and are entitled to it). The first one as shown in the table in the post is for installing SP1 on an R2 system and is all you need.

    Jason | http://blog.configmgrftw.com | @jasonsandys

    Monday, August 24, 2015 1:17 PM
  • It work for me. I installed SCCM 2012 SP1 and then ran the 2012 R2 SP1 update (SC2012_R2_SP1_Configmgr.exe) using your solution and it worked as a charm.

    Thank you. Much appreciated.

    Nick Basic


    _nick_damas


    • Edited by Nick_damas Wednesday, February 17, 2016 8:37 PM
    Wednesday, February 17, 2016 8:36 PM
  • hold shift and Right click "Configmgr2012R2SP1"from SC2012_R2_SP1_Configmgr\SMSSETUP\BIN\X64 ,then chose Copy as path.

    then open CMD with Administrative privileges  >paste>enter

    that's it  .it should work for you 

    Wednesday, July 20, 2016 11:33 AM