locked
Can ASP 4.0 be installed on Windows 10? RRS feed

  • Question

  • By default, ASP 4.5 is installed on Windows 10. Is it possible to use ASP 4.0 on Windows 10 instead? This thread seems to indicate that it's at least not straightforward: https://social.technet.microsoft.com/Forums/office/en-US/69797291-cd3f-4b49-837d-7c7a1d1a03a8/install-dot-net-40-on-windows-10?forum=winserversecurity

    Does anyone know a way to get it to work? Using a virtual machine with another operating system is unfortunately not an option for me.

    • Edited by MarcusSvend Tuesday, September 6, 2016 10:50 AM
    Tuesday, September 6, 2016 9:29 AM

Answers

  • Hi,

    From the download page for the "Microsoft .NET Framework 4.6",

    The Microsoft .NET Framework 4.6 is a highly compatible, in-place update to the Microsoft .NET Framework 4, Microsoft .NET Framework 4.5, Microsoft .NET Framework 4.5.1 and Microsoft .NET Framework 4.5.2.

    On other words, having .NET 4.6 installed (it's part of Windows 10 so you need not manually install it) means you have .NET 4.0, 4.5, 4.5.1, 4.5.2 and 4.6 installed and can run code targeting any of those framework versions without making any modifications to your Windows installation.

    You cannot install .NET 4.0 when you have a later version installed as each version is an in-place update to the last.

    Either you could install Visual Studio 2015 as the Integrated Development Environment.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by MarcusSvend Wednesday, September 7, 2016 7:19 AM
    Wednesday, September 7, 2016 6:26 AM