locked
WSS3 with office 2010 - All documents open up in read only RRS feed

  • Question

  • Hi guys

    I am using WSS3 and have upgraded my computers to Office 2010. Any document i have opened up in sharepoint, is read only. It does ask me to open up in "edit" or "read only". When i click on 'edit", the document is in read only mode

    When i downgrade to office 2007 , everything is fine

    Please help

     

     

     

    • Moved by Mike Walsh FIN Thursday, June 2, 2011 6:50 AM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Thursday, June 2, 2011 6:31 AM

All replies

  • Hi Elia,

    Below could be some reasons

    You cannot create a new document or check out an existing document in a Windows SharePoint Services 3.0 document library when you have multiple versions of Office installed http://support.microsoft.com/kb/929360

    Office 2003 and 2007 Office documents open read-only in Internet Explorer http://support.microsoft.com/kb/870853

    Thanks,

    Raj

    Thursday, June 2, 2011 11:34 AM
  • Hi Veera

    Thanks for the response, but this is not the problem

    With a complete new installation of windows 7 and office 2010, All documents opened up on WSS 3 in "edit mode" are read only. I also tried a fresh install of WIndows 7 with office 2007 and it works 100 %

    All 30 computers at work are doing the same thing.... When i downgrade any pc back to 2007, everything is 100 %

    I am able to upload/ add stuff to shareporint but once added, i cant edit it again. Keeps telling me its in "read only" mode

     

    PLease help

     

     

     

     

     

    Thursday, June 2, 2011 12:46 PM
  • Any luck on this?  I'm struggling with this myself...

    tried:

    the OpenDocumentsReadWriteWhileBrowsing Registy key, the BasicAuthLevel 2 registry key, reseting IE to defaults, adding the site to trusted sites, set to auto login in IE, tried firefox, and re-registered owssupp.dll....

    Single version of office 2010 installed...on office 2007 works fine...

    Alot of posts out there about this issue...noone seems to have a definative answer.

     

    R$$$

    Thursday, June 2, 2011 8:46 PM
  • Hey R-money

    Iver tried all that aswel.

    Veera... have you had this problem before?

     

    Friday, June 3, 2011 6:01 AM
  • HI Elia,

    PLease check with this as well and let us know the outcome

    http://support.microsoft.com/kb/870853/en-us

    Thanks,

    Raj

    Monday, June 13, 2011 10:56 AM
  • Hey Raj

    I tired it even thou it has not much to do with my problem. Not working.. :(

    Ive tried all configurations in office 2010 and not assume it has to do with IIS/Shareporint configuration..... Remember, With office 2007 it works 100%

    any more ideas.. :(

     

    Tuesday, June 14, 2011 9:48 AM
  • Disable the WebDAV publishing on the Web Front End Server of the Farm - Server Manager | Remove Role Services | Follow the Wizard to remove the check Mark next to WebDAV Publishing Role
    This behaviour is governed by an IE add-on called SharePoint OpenDocuments Class
    Instead, this class /add-on (which comes with Office) determine the dialog box looks like. Different version of Office (XP, 2007) display differently. Debugging this problem can be tricky. Sometimes you might find that two machines with the same version of Office to have two different dialogs, When this happens, it is most likely because one of them has Office upgraded in place. When the upgrade happens, sometimes it fails to update the overlying DLL correctly (OWSSUPP.dll)

    Since this is a client side issue, you need to look into what version of Office is installed. If you really wanna drill down, you can browse to Office program folder and find the DLL. If you find a older version of the DLL, renaming them would make IE add-on to use the latest one, hence the correct dialog box.
    Also try the below
    1. Go to the command prompt and locate the c:\program files\microsoft
    office\office14 directory
    2. Unregister the dll owssupp.dll using the following command regsvr32 -u
    owssupp.dll
    3. Re-register the dll using the following command regsvr32 owssupp.dll and then attempt to edit the document again.
    • Proposed as answer by Simon Sheldon Tuesday, March 20, 2012 2:08 PM
    Tuesday, June 14, 2011 10:42 AM
  • I am having this same problem on a SharePoint 2010 Server. All document, spreadsheets, etc. open fine with Office 2007 but they all open as read-only in Office 2010.
    Tim Vander Kooi
    Friday, June 17, 2011 4:54 PM
  • Hi veera

    I disabled the Webdav publishing on my sharepoint but sharepoint stop working.. :(

    Re-register the owssupp.dll is not the problem. This also happens on a complete new installation of operating system and office 

    Anything else?

    Thanks

     

    Monday, June 20, 2011 8:29 AM
  • Hi Elia,

    Have you tried uploading a new office 2010 document to the library and tried to edit it? if so what happens in this case?

    is it specific to existing doc libs or try creating new doc lib n check and let us know.

    Thanks,

    Raj

    Tuesday, June 21, 2011 11:12 AM
  • Hi Veera

    I have tired loading a new document to the librar,y and still the same problem.At the top of the document, it says "read only"

    All documents in sharepoint are read only.

    One of our sister casinos has the same configuration (WWS3 with office 2010) and they are working 100%. One of the diffrences is that we run windows 2008, and they run windows 2003. I havnt compaired the IIS configuration as yet.

    any ideas?

     

     

    Wednesday, June 22, 2011 7:23 AM
  • He verra

    The server with WSS3 is windows 2008 and the clients are windows 7 or xp. Do you think this hotfix will work? Im just worried it will break the server.  

    http://support.microsoft.com/kb/971736

    What do you think?

    In regards to the second web link, it has nothing to do with the problem.

     

    Wednesday, June 22, 2011 2:10 PM
  • HI Elia,

     Ideally http://support.microsoft.com/kb/971736 should not break your server ...on a safer side always take the whole farm back up and also content databases backups before installing any CU or hotfix or service pack.

    Even i have not installed this fix  on my server as this was rtealease on june2nd 2011 ..but plannig to installed it in my next downtime schedule.

    Thanks,

    Raj

    Thursday, June 23, 2011 6:06 AM
  • Thanks Veera

    will plan some downtime and install the hotfix

    There was another article regarding this problem.

    PLease have a look

    http://social.technet.microsoft.com/Forums/sk-SK/sharepointgeneral/thread/77cdfd98-318f-48a5-921f-fc9a593695ad

    Read the last statement he wrote

    Wayne,

    I appreciate the effort, but that is really not what is happening in our environment and they never found a solution to their problem.  I get the prompt for "Read Only" or "Edit", what I don't get is prompted for my credentials when using computers with Office 2010.  I did get prompted for my credentials if I have Office 2007.  We are moving from a WSS 3.0 hosted server to Sharepoint 2010 server.  We have tested on the new Sharepoint server and the propblem is gone.  So, it is clearly a problem between Office 2010 and WSS 3.0.  There is something that isn't triggering the need to provide credentials in the old environment that keeps this from working.

    It would be nice to know what fixes the problem, however, since deployment of the new Sharepoint server is eminent, we will most likely just run away from the problem.  It is hard for me to believe that no one else has encountered this problem.  I have tried searching every way I know, but no luck.

    I also beleive its a WSS 3 issue.....Other than the hotfix, what else can i look at?


     

     

    Wednesday, June 29, 2011 10:16 AM
  • We are having the same problem - driving us all crazy!

    Sharepoint 2010 on Windows 2008 server

    Office 2010 on Windows 7 PC

    All fresh installs.

    Every document from all libraries (onld and even newly created to test the problem) are opened in read only and can not be saved back to the library.

    If you check the item out, It has "Ckeck out?" above the docuemnt, and on clicking that, you get "xx.docx is locked for ediitng by 'another user'"

    New documents can be added, and if you save the document to a local drive then use the "Add Document" link and upload it the file is overwritten during that process.

    This is a change that has appeared in the last few weeks only - has been working perfectly before that.

    It's killing us across the whole organization now - the heat is on!!!!

    Nathan

    Tuesday, July 5, 2011 10:59 PM
  • Hi,

    I remember seeing the probelm, it was while back now. Adding the sharepoint site to the trusted sites or the local intranet zone (didn't make much difference) and in the custom level settings there is an option "Automatic logon wiith current user name and password" in which after this was enabled the problem disappeared.

    I also have created a registry entry (not needed but can help)

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WebClient\Parameters

    create a multi string value "AuthForwardServerList" and then give it the value of your sharepoint address (include http:// or https://)

     

    The registry option doesnt usuallly make much difference, just found an article when we were having the problem.

    This may not help much, but it is worth checking

     

     

    Wednesday, July 6, 2011 3:51 AM
  • bRaD86

    Thanks, but site is already added to local intranet zone. Also tried enabling "Automatic logon wiith current user name and password" and it made no difference.

    Wednesday, July 6, 2011 5:41 AM
  •  

    Same problem and haven't found any solution yet!

     

    SP 2010 with Office 2010.

    • Proposed as answer by Ryan Manongdo Wednesday, July 13, 2011 3:35 AM
    • Unproposed as answer by Ryan Manongdo Wednesday, July 13, 2011 3:35 AM
    Monday, July 11, 2011 12:22 PM
  • I've just come across a similar issue with one of my clients network - whenever I click on a Word document on the Sharepoint Services 3.0 site it will open Word but not load the document. After searching around and finding no solution I thought I'd try install the recently released Office 2010 Service Pack 1. It still did not work but this time now I am given an error message saying something along the lines of

    "Access to this webserver is disabled by default because it is controlled by basic authenticaion and does not use SLL"

    A bit of research on that error brought me to this KB article - http://support.microsoft.com/kb/2123563 - which I am happy to say has resolved my issue.

    The registry edit method did not seem to work so I used the Fix it for me link which installed and worked after a reboot.

    I don't believe Office 2010 SP1 is necessary to load beforehand (probably not) but it no doubt helped in finding the right solution!

    Wednesday, July 13, 2011 3:35 AM
  • Hi

    We had this issue and this fixed it for us - as well as the issue with mapping drives mentioned directly in the article.

    This only became an issue for us once Windows 7 (Ent x64) and Office 2010 were rolled out to our users.

    http://netindonesia.net/blogs/andriyadi/archive/2010/01/04/wss-3-0-sp2-on-windows-server-2008-r2-open-with-windows-explorer-failed.aspx

    Rgds 

    Simon

    Tuesday, March 20, 2012 2:08 PM
  • Hi Elia,

    Maybe you need to desable protected view in office 2010

    http://www.addictivetips.com/windows-tips/disable-protected-view-in-office-2010/

    Regards

    NAGA Attef


    dev01


    • Edited by NAGA Attef Sunday, May 27, 2012 2:04 PM
    Sunday, May 27, 2012 2:02 PM
  • Was this ever resolved? I have the same problem on my network and it's driving me nuts! I've tried just about everything mentioned in this thread.
    Monday, October 22, 2012 12:48 AM
  • http://nikcharlebois.sharepointspace.com/Blog/Lists/Posts/Post.aspx?List=12dd66b5%2D8904%2D4234%2Dbb9c%2D28760c5460ca&ID=22&Web=3ace3513%2Df713%2D47a3%2Dad5a%2D7d0ab95015a5

    http://lindachapman.blogspot.com/2010/05/on-vista-office-2007-and-ie7-you-get.html

    http://docs.alfresco.com/4.0/index.jsp?topic=%2Fcom.alfresco.enterprise.doc%2Ftasks%2FSharePoint-config-office2010.html

    Setting up SharePoint Protocol Support to work with Office 2010

    This section describes how to configure the SharePoint Protocol Support to work with Office 2010 on Windows 7.

    Alfresco supports the use of Office 2010 clients and Office 2007/2010 on Windows 7 with Alfresco Enterprise 3.4.0 or later. Some installations of Windows 7 restrict access to Basic HTTP authentication on non-SSL connections.
    1. Set the following registry keys.
      Each regkey takes the following values:
      Option Description
      0 Basic authentication disabled
      1 Basic authentication enabled for SSL shares only
      2 or greater Basic authentication enabled for SSL shares and for non-SSL shares
      1. Change or create the following registry key and set its value to 2.
        "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters\BasicAuthLevel" (REG_DWORD)
      2. Change or create the following registry key and set its value to 2:
        “HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet\BasicAuthLevel” (REG_DWORD)
      3. Restart the web client Windows service for the changes to take effect.
    2. Ensure that the Microsoft patch for the Web Folders component (KB907306) is installed on your Windows Vista/Windows 7 client. This patch contains a fix for a bug in Web Folders for Windows Server 2003, Windows Vista, and Windows 7. To install this patch, use the following instructions:
      1. Download the patch KB907306 from the following location: http://www.microsoft.com/downloads/details.aspx?familyid=17C36612-632E-4C04-9382-987622ED1D64&displaylang=en
      2. Double-click the Webfldrs-KB907306-ENU.exe file on your hard disk.
        The default installation location is \Program Files\Common Files\Microsoft Shared\Web Folders.
      3. Follow the instructions in the setup wizard to complete the installation.
    3. If the Office client requests credentials for each operation, it may be related to domain policy and the client settings. Fixes are available using the instructions in the following articles:
      If you experience problems with the prompts for your credentials, clicking small down arrow on the right side of the Open button (instead of clicking the Open button itself). When you have clicked this arrow, the client will prompt you for your credentials and you can start working with documents from the Alfresco sites. 
    • Edited by Veera Raj Friday, November 2, 2012 5:26 AM new links added
    • Proposed as answer by HMote Friday, January 18, 2013 4:18 PM
    • Unproposed as answer by HMote Friday, January 18, 2013 4:19 PM
    • Proposed as answer by HMote Friday, January 18, 2013 4:20 PM
    Friday, November 2, 2012 5:24 AM
  • Adding the "HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet\BasicAuthLevel" DWORD (regedit), setting it to 2, and restarting the WebClient service (services.msc) worked for me!!!  THANKS FOR THE TIP!  I've worked on this for days.........
    Friday, January 18, 2013 4:21 PM