none
BUG - Indexing Options keep pointing to D drive rather than the C drive - search charm won't work

    Question

  • So I noticed that the search in my Windows 8.1 simply won't work to find files and settings. Then I went to Indexing Options in the Control Panel and I noticed that one of the locations Indexing was trying to point to is:

    D:\ProgramData\Microsoft\Windows\Start Menu\ (Unavailable)

    This is odd since this is not the location of the Start Menu (which is in the C drive, not the D drive).

    So I went on to remove this location and manually add the location of the Start Menu in the C drive (i.e. C:\ProgramData\Microsoft\Windows\Start Menu\).

    To my surprise, adding the location in the C drive is actually listed as the D drive -- not the C drive. In Fact any directory I try to add to the Index located in the C drive is in fact listed as being in the D drive!

    I'm at a loss here, and in fairness I reckon this is a bug.

    Have anyone here ever experienced this? Is there any workaround?

    EDIT: While the search does not work. It seems like the Windows Explorer search works without any issues.

    Also I reckon it is worth mentioning that I change the location of my search index to the D drive. This is because my C drive is a Solid State Drive, while my D drive is a traditional Hard Drive.

    Thanks in advance for the help.

    Regards,

    P.

    • Edited by pmdci Monday, August 11, 2014 9:13 PM
    Monday, August 11, 2014 8:06 PM

Answers

  • Hello Roger,

    I have to say that I am disappointingly surprised with this answer.

    If you read my initial post carefully, the issue is that if I add a location on the 'C' drive it gets market as being on the 'D' drive instead. Therefore, your test of adding a folder to the indexing and delete it afterwards is moot.

    Anyway I found out the issue to be that the SID of the D partition was the same as the SID assigned to the C partition and that was causing conflicts.

    I looked all around for a way to change the partition SID but I couldn't find anything. So in the end what I had to do is backup (copy) the contents of the D partition, delete that partition (not format), then create it again. Now when adding the disk to the index, I noticed it works fine. I don't consider this necessarily a solution, but a workaround.

    Regards,
    P.


    • Marked as answer by pmdci Monday, August 18, 2014 7:55 AM
    • Edited by pmdci Monday, August 18, 2014 8:06 AM
    Monday, August 18, 2014 7:55 AM

All replies

  • Hi,

    According to your description, this problem should be caused by your changing the location of my search index to the D drive.

    Please try to revert it back to C drive for test.

    If no use, try to rebuild Search Index in its settings for test.

    If problem persists, it would be better to using system restore to revert your system to a former normal timepoint to fix this problem.


    Roger Lu
    TechNet Community Support

    Tuesday, August 12, 2014 7:51 AM
    Moderator
  • Hi,

    I'm afraid that does not help, and it is not the sort of answer I have been looking for.

    I have moved the index to different locations before. This is a supported feature by Windows and I would expect it to work this time like it worked in other PCs where I did the same.

    I also tried moving the index back to the C: drive and rebuilding the index, but that did not resolve the issue.

    This is clearly a bug as I am not experiencing this on other PCs and I would expect Microsoft to take note of it.

    As for system restore, I can't do it because I experienced this issue as soon as Windows 8.1 was installed.

    Regards,
    P.

    Tuesday, August 12, 2014 8:24 AM
  • Hi,

    I made a test in my fresh building Windows 8.1. Create a new drive and a new folder in it. After that, add the folder into Windows Index Location. When I delete the folder, its shows up as the screenshot below:

    As you can see, it's same with yours, If I choose uncheck the Index folder and reopen Windows Index Location, it would be dispare from this panel.

    While for your problem, actually, move the index location is no difference to your Windows search, it just change search file location.

    To identify if this is a disk drive problem, you can opt to use Diskpart command to check your drive letter if it was correct.

    Open Command Prompt with admin, then type diskpart.

    Afer that, type list volume, check current disk label.


    Roger Lu
    TechNet Community Support


    Monday, August 18, 2014 6:21 AM
    Moderator
  • Hello Roger,

    I have to say that I am disappointingly surprised with this answer.

    If you read my initial post carefully, the issue is that if I add a location on the 'C' drive it gets market as being on the 'D' drive instead. Therefore, your test of adding a folder to the indexing and delete it afterwards is moot.

    Anyway I found out the issue to be that the SID of the D partition was the same as the SID assigned to the C partition and that was causing conflicts.

    I looked all around for a way to change the partition SID but I couldn't find anything. So in the end what I had to do is backup (copy) the contents of the D partition, delete that partition (not format), then create it again. Now when adding the disk to the index, I noticed it works fine. I don't consider this necessarily a solution, but a workaround.

    Regards,
    P.


    • Marked as answer by pmdci Monday, August 18, 2014 7:55 AM
    • Edited by pmdci Monday, August 18, 2014 8:06 AM
    Monday, August 18, 2014 7:55 AM
  • Hi

    How to find the SID of the C and D drives partitions. I'm having similar kind of issue where i can set the index to C drive only not to the D drive.


    Subhash

    Monday, November 16, 2015 2:03 PM