locked
MS Project Sequencing Problem RRS feed

  • Question

  • Hello,

     

    I have sequenced MS Project and published it. Every thing looks to be working fine. Until  I click on "Report" Menu and "Visual Reports". When I ask to generate a report it shows me a error says

     

    "This Operation requires you have Excel 2003 or later Installed on your Computer"

     

    However I have Office 2007 installed on Physical machine and Office 2003 Published separately on SoftGrid. I am able to use Office 2003 which is published to this machine with out any problems.

     

    I don’t think this is the problem with package dependency. IS it? Do I have to package Excel and Project Together?

     

    I haven’t started troubleshooting yet. I am assuming some of you already have solved this problem. Any idea who to fix this please?

     

    Thanks.

     

    Friday, July 25, 2008 2:01 PM

Answers

  • Hello,

    Recommendation usually is to include Excel as part of the package (installed into a single asset directory).

    DSC isn't supported into this scenario.
    /Znack
    • Proposed as answer by znack Tuesday, February 22, 2011 6:19 AM
    • Marked as answer by Aaron.ParkerModerator Monday, January 9, 2012 10:20 PM
    Tuesday, February 22, 2011 6:19 AM

All replies

  •  

    Hello,

     

    As the error message states that it specifically requires Excel 2003 thats the version that needs to be available.

    If this is sequenced in a seperate package, Project and Excel are then virtualized in two different worlds. As the concept of softgrid is to isolate, neither one of them can access the other and thats why Project can not see or utilize Excel.

     

    Its a depency issue and in 4.5 you could use DSC to avoid making the suite...

    Friday, July 25, 2008 7:32 PM
  • Thanks Znack,

     

    You have clarified about one scinario.

     

    However, I have office 2007 on Physical machine. The virtualized app should have detected the localy INSTALL office 2007 and opened it? Am I wrong? Please clarify.

     

    Thanks,

    Pavan.

    Friday, July 25, 2008 11:16 PM
  • I've come across something like this with another application. One is installed locally and one is virtualized with SoftGrid. What I would do is delete the Office 2003 package from your computer.

    You may need to physically remove it from your cache in the %app_data% directory (Make sure you know the GUID before so you don't delete the wrong package from your local cache). If you have access to the SAV, disable (or remove your user ID from the appropriate group) from the package and refresh your applications on your client. Try your MS Project now and see if it works.

    Having two different versions of Office on one computer (virtualized or not) never seems to play nicely together. By removing one of them you can hopfully determine whether it's a package problem or a pinter problem on your machine.

    Hope this helps...



    Monday, August 4, 2008 9:30 PM
  • Thanks dwpeter,

     

    However, this did not solve the problem.

     

    Now I have office 2007 installed on my machine and Project 2007 is sequenced. I have mentioned LOCAL Interaction = TRUE. Still no luck.

     

    Please help. I have check File mon and regmon...it does not show any thing strange....

    Tuesday, August 5, 2008 9:17 AM
  • weblearn,

     

    Try to include Office 2007 locally on the sequencer machine before doing the Project -package and then launching that action during the sequencing. This might include some bits of Office/Excel 2007 to the package, possibly enabling Project to see it also on the client.

     

    br,

    Kalle

     

    Tuesday, August 5, 2008 6:48 PM
    Moderator
  • Thanks Kalle. Infact I did Sequence Project 2007, after Installing Both 2007 and 2003 office on capturing machine. (Ofcourse one at a time). But, that did not help me.

     

    However, I am able to save the Project file (MPP) as Excel. That's working fine. The project is only with Visual Reports Menu.

     

    Lately I have read that this visual reports article on MS Site and found this

     

    "Visual Reports works by first creating a local database (.mdb file) that contains data from your project.  From there we build a local cube (.cub file) and then hook the cube up to a PivotChart in Excel or a PivotDiagram in Visio.  These cubes are completely separate from the server cubes."

     

    Could this be the cause of the problem. Should I include any of MDAC components into my Application? If yes, any idea, what would they be?

     

    Just curious, Am I only THE Freek on this earth to get this error? Every once else project is working fine. If you dont know please go to Report >  Visual Report and try generating a report. If it works teach me....If it doesnt work...WELCOME TO THE PARTY .

     

    Thanks

    Wednesday, August 6, 2008 9:32 AM
  • So, I think I'm getting confused as to what you have installed and what you have sequenced. Let's take this from the beginning again.

    What relavent applications do you have installed on your local machine?
    What relavent applications have you sequenced and cached on your local machine?

    Just out of curiousity, is your login ID a local administrator on the client machine?
    Wednesday, August 6, 2008 5:04 PM
  • Trust me, you are NOT the only who sees this. In fact, we've had Project Standard and Project Professional in SoftGrid 4.2 for about a year before anyone (a.k.a. me) noticed this.

     

    Does anyone have a solution for this? Sort of sequencing Office together with Project and Visio, there has to be a solution. BTW... we are NOT going to sequence Office until 4.5 comes out.

    Thursday, August 14, 2008 4:55 PM
  • Hi, I am facing the same problem. When we sequenced Microsoft_Office_Project_Professional_2007_ENG APP-V package with OFFICE 2007 as dependency, we found that it has an option to create Visual Reports. Now when we click on Visual Reports Menu Item, It displays following window which gives user an option to Generate Report Template created in Microsoft Office Visio. When we tried to create new template and selected application Visio as shown above; it throws an error message saying that it needs Visio Professional 2007 installed locally.   To resolve this issue we sequenced Office Project Pro and Office Visio Pro together with MS Office as dependency; and then tested the same functionality, and found the below error message: The error is thrown when we launch MS Project: Visio is busy. This may be because Visio is currently waiting for user input (for example, a dialog may be open). Switch to Visio to correct the problem, then try again. And if checked there is no such visio dialog opened. Please Advice.
    Friday, July 2, 2010 10:02 AM
  • Hello,

    Recommendation usually is to include Excel as part of the package (installed into a single asset directory).

    DSC isn't supported into this scenario.
    /Znack
    • Proposed as answer by znack Tuesday, February 22, 2011 6:19 AM
    • Marked as answer by Aaron.ParkerModerator Monday, January 9, 2012 10:20 PM
    Tuesday, February 22, 2011 6:19 AM