locked
Exchange 2010 MP CAS connectivity scripts RRS feed

  • Question

  • Hi opsmgr guys,

    I'm having troubles with the Exchange 2010 MP, I'm using a DAG with 2 members and 2 CAS/HT servers.

    The client access test script monitors (e.g. KHI: An Outlook Web App connectivity (External) transaction failure occurred. The test credentials can't be used to test Outlook Web App.) always show warnings like this:

    Date and Time: 25.07.2012 11:35:04
    Log Name: Script-generated data
    Source: MSExchange Monitoring OWAConnectivity External
    Event Number: 1008
    Level: 2
    Logging Computer: VIESV074.einstein.local
    User:
    Description:
    The test mailbox was not initialized. Run new-TestCasConnectivityUser.ps1 to ensure that the test mailbox is created. Detailed information: Local Site:MySite [Microsoft.Exchange.Monitoring.CasHealthCouldNotLogUserException]: The task couldn't sign in with user mydomain\extest_7f3e517a90e62. Run Scripts\new-TestCasConnectivityUser.ps1 to verify that the user exists on the Mailbox server myserver.mydomain.local To run this task without credentials, sign in as a Domain Administrator. Detailed error information: 1326 Diagnostic command: "Test-OwaConnectivity -TestType:External -MonitoringContext:$true -TrustAnySSLCertificate:$true -LightMode:$true"

    The funny thing is that the mailbox exists and the user is not blocked. When I try running the New-TestCasConnectivityUser.ps1 script, the output is:

    WARNING: The command completed successfully but no settings of 'mydomain.local/Users/extest_7f3e517a90e62' have been
    modified.

    Any hints?

    Cheers


    Sebastian Bammer

    Wednesday, July 25, 2012 9:54 AM

Answers

  • Hi Sebastian:

    There is this clue: "The task couldn't sign in with user mydomain\extest_7f3e517a90e62". Could be security/access issue with the rule that checks if the mailbox is initialized.

    How you tried deleting the mailbox in AD/Exchange, wait a bit, then run the new-TestCasConnectivityUser.ps1 again? A mailbox by the same name will be created but might have correct security...


    John Joyner MVP-SC-CDM

    • Marked as answer by Yog Li Thursday, August 2, 2012 9:01 AM
    Wednesday, July 25, 2012 2:20 PM

All replies

  • Hi Sebastian:

    There is this clue: "The task couldn't sign in with user mydomain\extest_7f3e517a90e62". Could be security/access issue with the rule that checks if the mailbox is initialized.

    How you tried deleting the mailbox in AD/Exchange, wait a bit, then run the new-TestCasConnectivityUser.ps1 again? A mailbox by the same name will be created but might have correct security...


    John Joyner MVP-SC-CDM

    • Marked as answer by Yog Li Thursday, August 2, 2012 9:01 AM
    Wednesday, July 25, 2012 2:20 PM
  • Hi Sebastian,

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as "Answered" as the previous steps should be helpful for many similar scenarios.

    In addition, we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems.

    Thanks,


    Yog Li

    TechNet Community Support

    Thursday, August 2, 2012 9:01 AM