locked
No Phone Option in Skype for Business Client RRS feed

  • Question

  • Hi@all

    I installed a Skype Business Server 2015 on premise in a hybrid deployement (with office 365).

    All works, expect that i have no Phone Option in the Skype Business Client. I dont have Skype Phone call Either. The whole Option is missing.

    Else everyrhing is working: Edge, Mediation, Frontend etc.

    The LIcense is ok also (O365 E3)

    WHat do i miss?


    Friday, July 22, 2016 10:18 AM

Answers

  • Hi, I found the issue. sip.<Domain> and lyncdiscover.<Domain> still pointed to Office365 instead to my edge-Server. Thanks for the Help

    • Marked as answer by FR-Technology Friday, July 22, 2016 4:14 PM
    Friday, July 22, 2016 4:14 PM

All replies

  • Did you enable the client with Enterprise voice feature, unless you enable the enterprise voice feature your client will not display DialPad.

    http://windowspbx.blogspot.com/2012/08/step-by-step-enabling-lync-server-2013.html

    https://support.office.com/en-us/article/Skype-for-Business-add-on-licensing-3ed752b1-5983-43f9-bcfd-760619ab40a7?ui=en-US&rs=en-US&ad=US&fromAR=1

    https://technet.microsoft.com/en-us/library/mt455213.aspx

    Assign the policy to your user, whom you specify with the value of the Identity parameter:

    Set-CsUser -Identity "<User name>" -EnterpriseVoiceEnabled $true -HostedVoiceMail $true
    

    For example:

    Set-CsUser -Identity "Bob Kelly" -EnterpriseVoiceEnabled $true -HostedVoiceMail $true

    Hope this helps. 


    Regards, Rajukb | MCSE (Communication ), MCSA (o365) ,Certified "Lync server 2013 depth support engineer"| This posting is providedwith no warranties and confers no rights. If my reply answers your question please mark as answer/helpful if its helpful.

    Friday, July 22, 2016 11:44 AM
  • Thanks. I did this allready. No Success

    Friday, July 22, 2016 12:11 PM
  • Verify what is the registry status "HKEY_CURRENT_USER \Software\Microsoft\Communicator" 

    Key value of  "DialpadState" should be "1"  if its '0' dialpad will not show.

    this is something will be enabled during inband provisioning incase if your client is enabled with Enterprise voice.

    Open client UCCAPI log using snooper tool and check the enterprise voice status True or False, if its False probably your user setting might be not enabled correctly in CMS.

    in that case, you have to force replication to make sure your CMS is up to date.

    Hope this helps.


    Regards, Rajukb | MCSE (Communication ), MCSA (o365) ,Certified "Lync server 2013 depth support engineer"| This posting is providedwith no warranties and confers no rights. If my reply answers your question please mark as answer/helpful if its helpful.


    Friday, July 22, 2016 2:01 PM
  • Hi, I found the issue. sip.<Domain> and lyncdiscover.<Domain> still pointed to Office365 instead to my edge-Server. Thanks for the Help

    • Marked as answer by FR-Technology Friday, July 22, 2016 4:14 PM
    Friday, July 22, 2016 4:14 PM
  • Never heard anywhere that DNS pointers would change client behavior of disabling Dial-pad. However, Thank you for sharing the knowledge. 


    Regards, Rajukb | MCSE (Communication ), MCSA (o365) ,Certified "Lync server 2013 depth support engineer"| This posting is providedwith no warranties and confers no rights. If my reply answers your question please mark as answer/helpful if its helpful.

    Friday, July 22, 2016 4:36 PM
  • Thank you for sharing. This behaviour seems very interesting for Hybrid scenarios. 


    Linus || Please mark posts as answers/helpful if it answers your question.

    Saturday, July 23, 2016 8:20 AM