PortfolioStrategyDataToRDB Solution Starter issues RRS feed

  • Question

  • Hello,

    I'm attempting to install the PortfolioStrategyDataToRDB solution starter.  The first issue I'm running into is that the current release is missing the file: PortfolioStrategyDataToRDB.wsp. I've not gotten any answers on another thread regarding this, so I thought I'd start a new thread.

    I've found the file in a much older release version of the Solution starter package. I've moved it to the current release that I downloaded and it seems to allow it to install properly, but I do get some errors:


    --- Deactivating feature PortfolioStrategyDataToRDB_PortfolioStrategyDataToRDB..

    --- Done.

    --- Stopping Admin Service to retract existing solution...
    The SharePoint 2010 Administration service is stopping.
    The SharePoint 2010 Administration service was stopped successfully.

    --- Done.

    --- Attempting to deactivate/retract existing solution PortfolioStrategyDataToRD

    "PortfolioStrategyDataToRDB.wsp" does not exist in the solution store.

    --- Done.

    --- Deleting solution PortfolioStrategyDataToRDB.wsp...

    Executing job-application-server-admin-service.
    Executing job-password-management.
    Operation completed successfully.

    "PortfolioStrategyDataToRDB.wsp" does not exist in the solution store.

    --- Done.

    --- Adding solution PortfolioStrategyDataToRDB.wsp to solution store...

    Operation completed successfully.

    --- Done.

    --- Deploying solution PortfolioStrategyDataToRDB.wsp

    The timer job for this operation has been created, but it will fail because the
    administrative service for this server is not enabled. If the timer job is sched
    uled to run at a later time, you can run the jobs all at once using stsadm.exe -
    o execadmsvcjobs. To avoid this problem in the future, enable the Microsoft Shar
    ePoint Foundation administrative service, or run your operation through the STSA
    DM.exe command line utility.

    Executing job-application-server-admin-service.
    Executing job-password-management.
    Executing solution-deployment-portfoliostrategydatatordb.wsp-0.
    Operation completed successfully.

    --- Done.

    --- Starting Admin Service...
    The SharePoint 2010 Administration service is starting.
    The SharePoint 2010 Administration service was started successfully.

    --- Done.

    --- Activating feature PortfolioStrategyDataToRDB_PortfolioStrategyDataToRDB...

    Feature with Id 'e42ba832-765a-4019-9f29-20b4e42f4b81' is not installed in this
    farm, and cannot be added to this scope.

    --- Done.


    The first error about the timer job and admin service not being enabled, I'm not sure why I get that. The service is running, and the solution shows as Globaly deployed in my Central Admin:

    Also, it shows up as a feature in my PWA instance.

    However, when I click "Activate" I get this error:

    The second error I get: "Feature with Id 'e42ba832-765a-4019-9f29-20b4e42f4b81' is not installed in this
    farm, and cannot be added to this scope."

    I'm unable to find ANY information on that ID, so I have no idea what is missing.

    I'm not sure if the older .wsp file is causing my issues, or if I'm just missing something here. Any help with this will be MUCH appreciated!


    Monday, September 24, 2012 5:18 PM

All replies

  • Klint please leverage the solution starter forum for Q&A.

    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    Tuesday, September 25, 2012 9:01 AM
  • Hello Klint

    I have answered your query in solution starter forum as well, quoting same here, since the download contains the source file as well

    Just go ahead & open the solution in VS2010, followed by a  package build (Note: make sure you change the site URL property to point it to your
    PWA site) & that should build the package or you can use the visual studio to deploy your package as well

    Let us know if this helps

    Thanks | Sunil Kr Singh |

    Sunday, October 7, 2012 1:12 AM