locked
Offline .cub file problem in ProClarity Web Pro 6.3 RRS feed

  • Question

  • HELP!!!

    We're finishing up an SSAS 2008R2 solution for a client, and need to deliver some "offline cube browsing" functionality for users.  The short story is the generated .cub file works perfectly in Excel 2010, and not well at all in ProClarity Web Pro.  No errors in Web Pro, just unexpected results.  Two show-stopper issues in web pro:

    1. None of the calculated measures are available to select.  The "regular" mesaures listed in the CREATE GLOBAL CUBE statement below are present. (both "regular" and calculated measures are available when using the same .cub file in Excel 2010)
    2. Dimensions are visible and usable, and expand, drill-down hierarchies work...the correct member names are always displayd. But the measure cells are always blank (they are not blank in Excel 2010).

    So...why?  Have been searching here in the forum and found no similar discussion.  See nothing in the SP3 release notes either.  If there are "sorry, that's unsupported" issues affecting ProClarity 6.3 that don't affect Excel 2010, that would be helpful information...or if (I hope) something obvious has been missed it would be most appreciated!

    Here are some details of the environment:

    • The original cube is running on SSAS 2008R2 10.50.1765
    • It was saved as a .cub file using management studio, using the MDX command listed below
    • Excel 2010 (no SP1) running on Windows7 x64, accessing the .cub file using OLE DB Provider 10.0--works super great!
    • ProClarity Web Pro running on a Windows 2008R2 (x64) terminal session.  Tried using the 9.0 driver as default; also tried switching to the 10.0 driver--no help
    • Help/About from Web Pro states version 6.3.2222.144

    CREATE GLOBAL CUBE [Sales]

    Storage 'C:\Offline\Offline.cub'

    FROM [Sales]

    (

    MEASURE [Sales].[Net Revenue USD],

    MEASURE [Sales].[Invoice Qty],

    MEASURE [Sales].[Sales Quota],

    MEASURE [Sales].[Gross Profit USD],

    MEASURE [Sales].[Ext List Price USD],

    MEASURE [Sales].[Discount Amt USD],

    DIMENSION [Sales].[Customer Sales]

    (

    LEVEL [Sales Org],

    LEVEL [RVP Name],

    LEVEL [District Name],

    LEVEL [Rep Name],

    LEVEL [Customer Name]

    ),

    DIMENSION [Sales].[Dates],

    DIMENSION [Sales].[Products],

    DIMENSION [Sales].[Date Calculations]

    )

     


    --- Rob Kerr CTO, BlueGranite @robkerrbi http://blog.robkerr.com
    Tuesday, April 12, 2011 3:02 AM

Answers

  • I think we found the solution to this: the trick is that when connecting to the local cube, the "Local cube" selection si grayed out when using the OLE DB 10.0 driver.  So (rather unintuitively) you put the full path to the cube file int he "Server" field instead, and things work pretty well from there. 

    A very strange (to me) procedure, but the most important thing is that it works--and so far it is.

    Hope this helps others...


    --- Rob Kerr CTO, BlueGranite @robkerrbi http://blog.robkerr.com
    • Marked as answer by Rob Kerr Tuesday, April 12, 2011 2:15 PM
    Tuesday, April 12, 2011 2:15 PM