none
Windows 10 1903 SIM tool in ADK (10.1.18362.1) fails to generate catalogs correctly for x64 install.wim

    Question

  • Windows 10 1903 SIM tool in the Assessment and Deployment kit fails with x64 install.wim files (at least on the install.wim file in the Windows 10 1903 Business Editions x64 ISO image).  The failures do not seem to occur with the x86 images and kit.  The following 2 failures are noted by the bulleted items below:

    • If you try to generate a catalog on an x64 system, the following information is logged:

    11:59 AM : Windows SIM was unable to generate a catalog. For troubleshooting assistance, see the topic: 'Windows System Image Manager Technical Reference' in the Windows ADK User's Guide.
    11:59 AM :
    11:59 AM : System.BadImageFormatException: Could not load file or assembly 'Microsoft.ComponentStudio.ComponentPlatformImplementation, Version=10.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. An attempt was made to load a program with an incorrect format.
    File name: 'Microsoft.ComponentStudio.ComponentPlatformImplementation, Version=10.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'
    Server stack trace:
       at Microsoft.ComponentStudio.ComponentPlatformInterface.Cpi.CreateOfflineImageInstance(OfflineImageInfo imageInfo)
       at Microsoft.ComponentStudio.ComponentPlatformInterface.OfflineImageCatalog.Serialize(OfflineImageInfo imageInfo)
       at Microsoft.ComponentStudio.ComponentPlatformInterface.OfflineImageInfo.CreateCatalog()
       at Microsoft.ComponentStudio.ComponentPlatformInterface.CatalogCreatorImpl.CreateCatalog(OfflineImageInfo offlineImageInfo)
       at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
       at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)
    Exception rethrown at [0]:
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at Microsoft.ComponentStudio.ComponentPlatformInterface.ICatalogCreator.CreateCatalog(OfflineImageInfo offlineImageInfo)
       at Microsoft.ComponentStudio.CatalogGenerator.CreateCat(ProgressDialog pd, Object o)
    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
    • If you create a catalog with an earlier version of the ADK (e.g., 1809), the catalog fails to loaded with the following error information in the log:


    11:54 AM : Cannot open the Windows image Windows 10 Enterprise.
    11:54 AM :
    11:54 AM : System.InvalidOperationException: The catalog file for Windows image Windows 10 Enterprise is invalid.
       at Microsoft.ComponentStudio.ComponentPlatformInterface.Cpi.OpenOfflineImage(OfflineImageInfo imageInfo)
       at Microsoft.ComponentStudio.AnswerFileImageResolver.TryOpenOfflineImage(OfflineImageInfo imageInfo)



    Any one have luck with this?




    • Edited by simdoc Wednesday, May 15, 2019 5:05 PM
    Wednesday, May 15, 2019 5:03 PM

All replies

  • Hi,

    Thank you for posting in Microsoft TechNet Forum.

    As the article mentioned: x86 Windows System Image Manager can create catalogs for x86, x64, and Itanium-based Windows images; x64 Windows System Image Manager can create catalogs only for x64 Windows images; Itanium-based Windows System Image Manager can create catalogs only for Itanium-based Windows images.

    First, please kindly check the version of your SIM and Images. Make sure your account are the administrator and check if you have the full control of .wim file.

    Meanwhile, I found a post which may help, please refer to it:

    https://social.technet.microsoft.com/Forums/en-US/789d07e1-c430-4e83-a8f7-e6b501a7c9ac/cant-create-catalog-file-for-windows-10-enterprise-using-latest-adk-wsim?forum=win10itprosetup

    Best regards,

    Hurry


    Please remember to mark the reply as an answer if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, May 16, 2019 7:44 AM
  • I have the exact same problem with the exact same error. Tried it on multiple systems (W2016 and W10) and with freshly installed 1903 ADK. The error is consistent. The 1903 ADK fails to create a catalog for the Windows 10 1903 Enterprise install.wim file.

    Thursday, May 16, 2019 9:29 AM
  • With all due respect, I don't need basic help on these tools.  I have much experience with them and fully understand the implication of x86/x64/Itanium.  I gave the version with the title of the posting-10.1.18362.1.

    I can virtually guarantee there is a problem with the tools or the wim file in the DVD ISO image.  I don't have time to figure out which.

    Thursday, May 16, 2019 12:54 PM
  • To add on here, the latest SIM from ADK 1903 also doesn't open older catalog releases. There is something wrong with SIM in this latest release of the ADK.

    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Thursday, May 16, 2019 3:10 PM
  • Hi,

    Thank you for your feedback.

    Maybe it is a bug. Now the 1903 ADK can't create a catalog for the Windows 10 1903 Enterprise install.wim file.

    Please be patient and wait for the latest patch fixes.

    Best regards,

    Hurry


    Please remember to mark the reply as an answer if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, May 17, 2019 6:30 AM
  • That's something I've become accustomed to with Microsoft over the last several years:  "Please be patient and wait for the latest patch fixes."  Q/A seems to be lacking to say the least.


    • Edited by simdoc Friday, May 17, 2019 1:11 PM
    Friday, May 17, 2019 1:11 PM
  • Hi,

    I will accompany you until the problem is resolved successfully.

    Thank you for your cooperation.

    Best regards,

    Hurry


    Please remember to mark the reply as an answer if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Sunday, May 19, 2019 2:11 PM
  • Hi

    I am having the same issues in my environment I hope there is a fix coming soon. The 1903 ADK fails to create a catalog for the Windows 10 Pro 1809  install.wim file.

    10:29 AM : This application requires version 10.0.18362.1 of the Windows ADK.
    Install this version to correct the problem
    10:30 AM : 
    10:30 AM : Windows SIM was unable to generate a catalog. For troubleshooting assistance, see the topic: 'Windows System Image Manager Technical Reference' in the Windows ADK User's Guide.
    10:30 AM : 
    10:30 AM : System.ComponentModel.Win32Exception (0x80004005): The process cannot access the file because it is being used by another process

    Server stack trace: 
       at Microsoft.ComponentStudio.ComponentPlatformInterface.WimImageInfo.PreCreateCatalog()
       at Microsoft.ComponentStudio.ComponentPlatformInterface.OfflineImageInfo.CreateCatalog()
       at Microsoft.ComponentStudio.ComponentPlatformInterface.CatalogCreatorImpl.CreateCatalog(OfflineImageInfo offlineImageInfo)
       at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
       at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)

    Exception rethrown at [0]: 
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at Microsoft.ComponentStudio.ComponentPlatformInterface.ICatalogCreator.CreateCatalog(OfflineImageInfo offlineImageInfo)
       at Microsoft.ComponentStudio.CatalogGenerator.CreateCat(ProgressDialog pd, Object o)

    Monday, May 20, 2019 2:31 PM
  • If you run sim under windows 10 32-bit it works to cataloge, with both 32 and 64 bit windows 10 install.wim file.

    //Tomas


    Toslin

    Wednesday, May 22, 2019 11:29 AM
  • I had already noted that, but it does no good if you need x64 (as the majority of the world does today).
    Wednesday, May 22, 2019 12:30 PM
  • It is a temporary solution to be able to move on. The catalog files then work in x64 as usual.

    //tomas


    Toslin

    Wednesday, May 22, 2019 12:38 PM
  • "It is a temporary solution to be able to move on".  Good to know.  I didn't realize the x86 tools would process the x64 WIM and vice versa.

    Wednesday, May 22, 2019 2:35 PM
  • Hi

    I am having the same issues in my environment I hope there is a fix coming soon. The 1903 ADK fails to create a catalog for the Windows 10 Pro 1809  install.wim file.

    10:29 AM : This application requires version 10.0.18362.1 of the Windows ADK.
    Install this version to correct the problem
    10:30 AM : 
    10:30 AM : Windows SIM was unable to generate a catalog. For troubleshooting assistance, see the topic: 'Windows System Image Manager Technical Reference' in the Windows ADK User's Guide.
    10:30 AM : 
    10:30 AM : System.ComponentModel.Win32Exception (0x80004005): The process cannot access the file because it is being used by another process

    Server stack trace: 
       at Microsoft.ComponentStudio.ComponentPlatformInterface.WimImageInfo.PreCreateCatalog()
       at Microsoft.ComponentStudio.ComponentPlatformInterface.OfflineImageInfo.CreateCatalog()
       at Microsoft.ComponentStudio.ComponentPlatformInterface.CatalogCreatorImpl.CreateCatalog(OfflineImageInfo offlineImageInfo)
       at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
       at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)

    Exception rethrown at [0]: 
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at Microsoft.ComponentStudio.ComponentPlatformInterface.ICatalogCreator.CreateCatalog(OfflineImageInfo offlineImageInfo)
       at Microsoft.ComponentStudio.CatalogGenerator.CreateCat(ProgressDialog pd, Object o)

    Try using the 1809 ADK. I have always used the same ADK version for the same WIM version.

    Though here I am looking up these posts when I can not generate catalog files for a 1903 WIM when running 1903 ADK in 1903 OS (all x64).

    Thursday, May 23, 2019 1:30 AM
  • If you run sim under windows 10 32-bit it works to cataloge, with both 32 and 64 bit windows 10 install.wim file.

    //Tomas


    Toslin

    Gah. Guess I am going to download the 32 bit version and load it up in VBox and see what happens.
    Thursday, May 23, 2019 1:31 AM
  • Just for the note - same problem here. 
    Thursday, May 23, 2019 9:47 AM
  • Yes, same here with ADK 1903
    Thursday, May 23, 2019 1:47 PM
  • Has anyone confirmed that running SIM from ADK 1903 on a 32 bit version of windows works?
    • Edited by natelev Thursday, May 23, 2019 2:02 PM
    Thursday, May 23, 2019 2:01 PM
  • Yes it works !


    Toslin

    Thursday, May 23, 2019 2:05 PM
  • Since SIM has been working fine on 64-bit up to 1809, this note appears to be an excuse for not doing something correctly. I have told clients to go back to 1809 for LTSC-2019 development.

    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Thursday, May 23, 2019 5:14 PM
  • I have to agree...who runs a 32 bit O/S anymore??? Microsoft hosed something up
    Thursday, May 23, 2019 5:57 PM
  • I didn't understand how these answers were relevant, until I got that 64 bit versions of the program were broken and you can still use 32 bit machines to create 64 bit unattended.xml files. I set up a 32 bit Windows 10 VM to do this business and it worked.
    Thursday, May 23, 2019 8:38 PM
  • Another "I'm having this problem too".

    We are a Windows 10 64-bit only environment, so would prefer Microsoft actually fixed the problem!

    Friday, May 24, 2019 7:10 PM
  • I have reached out, and it sounds like a fix is being worked on. When it releases is another issue?

    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Sunday, May 26, 2019 3:25 AM
  • ADK 18362.1 DISM will also fail offline installation of latest SSU KB4500109 and LCU4505057 on Winre.wim

    This error message is the best:

    PS E:\WinROG> DISM /Image:E:\WinROG\mount\RE /Add-Package /PackagePath:"E:\WinROG\windows10.0-kb4497936-x64_4ac9328bb1376d2cadb09f56ba95ac9b08b88fba.msu"                                                                                    
    Deployment Image Servicing and Management tool
    Version: 10.0.18362.1
    
    
    Error: 50
    
    DISM does not support servicing a Windows Vista RTM or earlier operating system.
    If the operating system is supported check that SSShim.DLL is present.
    
    The DISM log file can be found at C:\WINDOWS\Logs\DISM\dism.log

    https://techcommunity.microsoft.com/t5/WinHEC-Online/ADK-18362-1-DISM-Fails-Offline-Install-for-kb4497936-kb4505057/td-p/569470

    The bulk of the problem is that MSFT don't actually Assess and Deploy... they just deploy, in their enclosed environment, and not in ecosystems that are encountered in the wild. Insiders... is a facade


    -NeoB



    • Edited by NeoBeum Tuesday, May 28, 2019 5:25 AM
    Tuesday, May 28, 2019 5:18 AM
  • I've been tearing my hair out about this for days now, glad it's been acknowledged and a fix is in the works! About to test creating a catalog file on an x86 Windows 10 1903 machine, will report back whether it works or not.

    Tuesday, May 28, 2019 9:37 AM
  • After configuring a 32-bit Windows 10 1903 VM and installing the Windows 10 ADK 1903 32-bit software i was able to create a Catalog file for Windows 10 1903 x64.
    • Edited by elltommo Monday, June 3, 2019 9:39 AM
    Tuesday, May 28, 2019 11:01 AM
  • This seems odd; even for Microsoft.

    I imagine there are some internal political reasons at play for what's going on here.

    There is an entire community of people who made their carer on Windows Deployment Server, MDT, ADK, etc.

    Automated deployment has HUGE advantages to those who know how to use them.

    And here we are, Microsoft delivers Windows Auto-Pilot and Windows Configuration Designer.

    Both are new, great on a brochure, and half-baked, imo.

    Missing critical features and flexibility of good ol' MDT.

    Now ADK requires you to create a 32bit VM just to use it??

    Sounds like MS want's us to move away from WDS, MDT and the like... but have they made a better mouse-trap?

    Or it might just simply be a bug. In which case you can safely discard this post.
    • Edited by DanTron78 Wednesday, May 29, 2019 11:03 AM
    Wednesday, May 29, 2019 11:00 AM
  • Hello,

    It's a known issue that is being investigated.  The workaround is use 32-bit Windows until a fix can be released.


    Thanks, Darrell Gorter [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, May 29, 2019 3:12 PM
  • Per MS recent update fixes catalog creation issue.  

    https://support.microsoft.com/en-us/help/4497935/windows-10-update-kb4497935

    Installing now.

    Doug


    Friday, May 31, 2019 2:02 PM
  • Per MS recent update fixes catalog creation issue.  

    https://support.microsoft.com/en-us/help/4497935/windows-10-update-kb4497935

    Installing now.

    Doug


    Nevermind.  Still can't create catalog file on x64.
    Friday, May 31, 2019 2:27 PM
  • Hi,

    I have also this Issue on X64 1903 Windows 10 Machine. Installing the Update did not help. Same error.

    Microsoft what's wrong ? Working with 32 Bit in 2019 ?!? Bad joke.... 

    Saturday, June 1, 2019 10:28 PM
  • Does that mean you are stuck with 32 bit Windows? Or did you manage to use that for a x64 machine?
    Monday, June 3, 2019 8:53 AM
  • I suppose my point is now redundant considering that KB4497935 doesn't fix the issue, but i see that that's an update for Windows 10. 

    We use MDT/WDS/ADK/WSIM on one of our Server 2012 R2 servers. I can't imagine we're alone in this case and i hope an update is in the works for this OS as well.....

    Monday, June 3, 2019 9:42 AM
  • I used a 32 bit windows 10 1903 machine to create a catalog file for an x64 Windows 10 1903 image. 
    Monday, June 3, 2019 9:44 AM
  • I am another user suffering this issue.
    Tuesday, June 4, 2019 9:40 AM
  • I used a 32 bit windows 10 1903 machine to create a catalog file for an x64 Windows 10 1903 image. 
    I did the same, but when I try to edit it on my 64-bit machine it comes with an error that the Catalog is invalid. Same as the error listed in the Original post. So if im to understand this right we will have to make the unattend.xml files on the 32-bit machine and also the catalogs and do nothing on my original 64-bit server?
    Tuesday, June 4, 2019 11:22 AM
  • win10 1903 32bit,sim10.0.18362.1,fail,why?
    Wednesday, June 5, 2019 8:09 AM
  • I got the same error as you when opening the unattend.xml on the 64bit server but it appeared to open up correctly and i was able to browse it's content using WSIM. We didn't need to edit it and save any changes. What happens when you do that? 
    Wednesday, June 5, 2019 11:08 AM
  • You are not alone, we too are using WSIM on a fully patched 2012 R2 box and cannot generate catalog files, nor can older ones be opened.
    Wednesday, June 5, 2019 1:00 PM

  • it's unclear to me what to do with the x32 bit PC. Do I configure it and capture the xml on the x32 PC, then use the xml as the answer file for my x64 bit machine when I sysprep?

    Since "Install and use Windows SIM from ADK 1809" is an option, I went that route and got what I needed to make my image. but would like to know the alternate process since I'm not seeing any "1,2,3" instructions here...


    • Edited by Big_Mark Wednesday, June 5, 2019 2:46 PM
    Wednesday, June 5, 2019 2:45 PM
  • Should we monitor this thread for updates and/or the release of a patch? If not, where do we check in for a status update?

    Thank you for Microsoft's quick attention and super-high priority into addressing this!

    Wednesday, June 5, 2019 7:23 PM
  • Well now it seems that with the new ADK installed on the server, that my old deployment tasks, that is not 1903 yet, is not working when trying to open the answer files. So I had a look into the answer file og 1903 and it seems a lot have changed in the layout. So if you upgrade your ADK, do not expect to edit older answer files on that server.
    Thursday, June 6, 2019 8:32 AM
  • Can I use 'ADK 1809' to prepare Unattended Windows 1903 in MDT?

    In my Test-LAB this config works fine - no error apears after edit. CLG file is generated.

    Sunday, June 9, 2019 3:09 PM
  • Having the same issue with trying to load the install.wim file for Windows 10 Education. This is incredibly frustrating and time consuming. Will try the 32-bit windows install for now...
    Monday, June 10, 2019 11:51 AM
  • Having same issue.  I wasted half a day downloading crap before finding this post.  Now i can waste another half day downloading a bunch of 32-bit crap.   Thanks MS.
    Monday, June 10, 2019 8:53 PM
  • As a workaround, you can just open WSIM on the server or your own workstation and browse to your TS for deployment.  You can find your TS folder in X:Deploymentshare\Control and just open the Unattend from here via WSIM.
    • Edited by Kyle-21 Tuesday, June 11, 2019 12:14 AM
    Tuesday, June 11, 2019 12:12 AM
  • Same issue here.  Not sure when MS will release a patch for it.  MS product quality has gone down so much.  And things that need patches, we have to wait months.

    Ishan

    Tuesday, June 11, 2019 7:55 PM
  • Use Insider Preview 18908.1000 Windows 10 x64 and Insider Preview 18908.1000 Windows 10 ADK on Windows 10 x64 1903. I was able to create a catalog.

    • Edited by Phoenix0519 Wednesday, June 12, 2019 7:20 PM
    Wednesday, June 12, 2019 7:18 PM
  • Been battling this issue myself. I don't have the luxury of a 32bit system just to stuff around with this.

    A great reminder of why I got out of the MS Consulting game. Endless banging your head against a brick wall.


    Can someone send me the catalog file for Windows 10 Enterprise LTSC?
    Sunday, June 16, 2019 4:14 AM
  • Seems like there is a fix for 64-bit version now. Get it here
    Monday, June 17, 2019 5:31 AM
  • Seems like there is a fix for 64-bit version now. Get it here

    This solution is working on MDT in my case when:

    - I first generate and edit Unattend.xml with ADK 1809 [.clg file is created].

    - Next Close MDT, Uninstall ADK1809 with Kits, Restart, Install ADK 1903 + Kits + this Fix, Restart

    - Edit again Unattend.xml in MDT - works - open without previous errors

    BUT if I delete .clg file and try to edit on Unattend.xml I've got again error.

    Performing the operation "generate" on target "Catalog".
    Starting: "C:\Program Files\Microsoft Deployment Toolkit\Bin\Microsoft.BDD.Catalog40.exe" "WIMFILE.wim" 1 > "...TEMP\Microsoft.BDD.Catalog.log" 2>&1
    No existing catalog file found.
    PROGRESS: 0: Starting.
    PROGRESS: 0: Creating mount folder: TEMP_FOLDER_t2plugde.nsg.
    PROGRESS: 5: Creating temp folder: Windows10x64_1903_temp_bewslssh.h0j.
    PROGRESS: 10: Mounting Windows image: WIMFILE.wim. This might take a few minutes.
    PROGRESS: 30: Mounted Windows image.
    PROGRESS: 33: Serializing Data.
    PROGRESS: 63: Cleaning up...
    PROGRESS: 63: Unmounting Windows image: WIMFILE.wim.
    PROGRESS: 66: Deleting mount folder.
    PROGRESS: 69: Cleaning up...
    ERROR: Unable to generate catalog on WIMFILE.wim: System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.ComponentStudio.ComponentPlatformImplementation, Version=10.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
    File name: 'Microsoft.ComponentStudio.ComponentPlatformImplementation, Version=10.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'
       at Microsoft.ComponentStudio.ComponentPlatformInterface.Cpi.CreateOfflineImageInstance(OfflineImageInfo imageInfo)
       at Microsoft.ComponentStudio.ComponentPlatformInterface.OfflineImageCatalog.Serialize(OfflineImageInfo imageInfo)
       at Microsoft.ComponentStudio.ComponentPlatformInterface.OfflineImageInfo.CreateCatalog()
       at Microsoft.BDD.Catalog.Program.DoCatalog()
    
    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
    
    
    Non-zero return code from catalog utility, rc = 2002
    


    Monday, June 17, 2019 4:11 PM
  • Microsoft posted a link to the Windows System Image Manager (WSIM) 1903 update on the ADK install page.  But the link is broken.

    https://docs.microsoft.com/en-us/windows-hardware/get-started/adk-install

    Monday, June 17, 2019 7:12 PM
  • Yeah, it just redirects back to:

    https://docs.microsoft.com/en-us/windows-hardware/get-started/adk-install


    The only true wisdom is in knowing you know nothing.

    Monday, June 17, 2019 7:51 PM
  • It's here:

    https://go.microsoft.com/fwlink/?linkid=2095334

    Don't use the supplied bat file - it explodes! Just copy the two updated exe files as per the Readme.



    • Edited by pvers Monday, June 17, 2019 10:20 PM
    Monday, June 17, 2019 10:15 PM
  • I'm hitting this issue using windows 10 1903 [ build 18362.175 ] x64 os installation and the adk and adk winpe addon 18362.1 installations.

    Since the current windows 10 1903 media creation tool generates an iso containing an install.esd instead of an install.wim i'm creating that file using the command i've been using ever since these esd vs wim started showing up in media drops "dism /export-image /SourceImageFile:d:\temp\w19x64\sources\install.esd /SourceIndex:6 /DestinationImageFile:d:\temp\install.wim /Compress:max /CheckIntegrity" .

    Creating a windows 10 1903 x86 os installation just enable windows system image manager to successfully take an install.wim and generate an associated .cfg file followed by validation of any unattended install configuration files changes is too painful. 

    Are we going to get a 1903 adk or windows system image manager update that works for these activities when used on windows 10 x64 os installations?

    • Edited by myusrn Monday, June 17, 2019 10:22 PM
    Monday, June 17, 2019 10:20 PM
  • It's here:

    https://go.microsoft.com/fwlink/?linkid=2095334

    Don't use the supplied bat file - it explodes! Just copy the two updated exe files as per the Readme.



    Can anyone confirm is this resolves the issue for them? Certainly, in my case it did nothing to fix the issue outlined in this thread.
    Tuesday, June 18, 2019 4:47 AM
  • I'm using Deployment Workbench and like I said before - if you generate .clg file [press "Edit Unattended.xml" button on TS properties] with ADK1809 then update your environment to ADK1903 with above fix - its will work. 

    If you just update from ADK1809 to ADK1903 without this fix you'll get an error after open Unattended.xml.

    I was tested this on my LAB.

    BTW apply FIX its just copy two files [ImageCat.exe & ImgMgr.exe] from this .zip file to ADK dir. Default location is:

    C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\WSIM


    • Proposed as answer by ReckyX Tuesday, June 18, 2019 7:47 AM
    Tuesday, June 18, 2019 6:17 AM
  • Yes it fixed it for me on a clean install of 1903 (ie no need to go via 1809).

    But don't use the supplied bat file - just copy the two updated files to replace the 1903 supplied files.


    • Edited by pvers Tuesday, June 18, 2019 2:52 PM
    Tuesday, June 18, 2019 2:51 PM
  • I replaced the files, didn't work, then reinstalled 1903 ADK and replaced files again.

    Still getting this: 

    ERROR: Unable to generate catalog on D:\Win10Build1903\Operating Systems\Win10EduBuild1903\install.wim: System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.ComponentStudio.ComponentPlatformImplementation, Version=10.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
    File name: 'Microsoft.ComponentStudio.ComponentPlatformImplementation, Version=10.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'
       at Microsoft.ComponentStudio.ComponentPlatformInterface.Cpi.CreateOfflineImageInstance(OfflineImageInfo imageInfo)
       at Microsoft.ComponentStudio.ComponentPlatformInterface.OfflineImageCatalog.Serialize(OfflineImageInfo imageInfo)
       at Microsoft.ComponentStudio.ComponentPlatformInterface.OfflineImageInfo.CreateCatalog()
       at Microsoft.BDD.Catalog.Program.DoCatalog()

    Any Ideas?

    The file "microsoft.componentstudio.ComponentPlatformImplementation.dll" has properties that show as version 10.0.1832.1 on the details tab.
    • Edited by TimCFOH Tuesday, June 18, 2019 4:23 PM
    Tuesday, June 18, 2019 4:18 PM
  • I'm using Deployment Workbench and like I said before - if you generate .clg file [press "Edit Unattended.xml" button on TS properties] with ADK1809 then update your environment to ADK1903 with above fix - its will work. 

    If you just update from ADK1809 to ADK1903 without this fix you'll get an error after open Unattended.xml.

    I was tested this on my LAB.

    BTW apply FIX its just copy two files [ImageCat.exe & ImgMgr.exe] from this .zip file to ADK dir. Default location is:

    C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\WSIM


    It worked with the original WIM but not with a Windows IBS Image... :-(

    Any ideas ?

    Tuesday, June 18, 2019 4:51 PM
  • I replaced the files, didn't work, then reinstalled 1903 ADK and replaced files again.

    Still getting this: 

    ERROR: Unable to generate catalog on D:\Win10Build1903\Operating Systems\Win10EduBuild1903\install.wim: System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.ComponentStudio.ComponentPlatformImplementation, Version=10.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
    File name: 'Microsoft.ComponentStudio.ComponentPlatformImplementation, Version=10.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'
       at Microsoft.ComponentStudio.ComponentPlatformInterface.Cpi.CreateOfflineImageInstance(OfflineImageInfo imageInfo)
       at Microsoft.ComponentStudio.ComponentPlatformInterface.OfflineImageCatalog.Serialize(OfflineImageInfo imageInfo)
       at Microsoft.ComponentStudio.ComponentPlatformInterface.OfflineImageInfo.CreateCatalog()
       at Microsoft.BDD.Catalog.Program.DoCatalog()

    Any Ideas?

    The file "microsoft.componentstudio.ComponentPlatformImplementation.dll" has properties that show as version 10.0.1832.1 on the details tab.
    Same. Uninstalled the 1903 ADK and reinstalled with the fix, still getting the System.IO.FileNotFoundException error. 
    Tuesday, June 18, 2019 6:03 PM
  • For what it is worth, on Server 2016 using WSIM 10.0.18362.144, and running the update via elevated cmd and the .bat file, I was able to create a catalog file. So far it is the only thing that worked for me. 
    Tuesday, June 18, 2019 6:59 PM
  • The WSIM fix works (Windows System Image Manager known issue)

    But the caveat is that that MDT integration is still broken. If you open WSIM itself and then open your answer file and the WIM, it will then build the catalog. I just did that and it worked. Once the catalog exists you can go back to MDT and edit unattend.xml as expected.

    Credit to Johan Arwidmark - https://twitter.com/jarwidmark/status/1139609397213224960


    Daniel Vega

    • Proposed as answer by Ryan1312 Wednesday, June 19, 2019 4:53 PM
    Tuesday, June 18, 2019 7:12 PM
  • The WSIM fix works (Windows System Image Manager known issue)

    But the caveat is that that MDT integration is still broken. If you open WSIM itself and then open your answer file and the WIM, it will then build the catalog. I just did that and it worked. Once the catalog exists you can go back to MDT and edit unattend.xml as expected.

    Credit to Johan Arwidmark - https://twitter.com/jarwidmark/status/1139609397213224960


    Daniel Vega

    Yep thats also my experience with this fix. MDT is not able to do it, but running WSIM alone will generate a catalog. Tried it on 3 different IBS files now, with success every time
    Wednesday, June 19, 2019 12:38 PM
  • The WSIM fix works


    Daniel Vega

    Thanks! We've been waiting for this!

    Wow, why didn't MS deem this thread worthy enough to answer/update?


    Wednesday, June 19, 2019 4:58 PM