none
imagex overwrites contents of wim image RRS feed

  • Question

  • Hello @all,

    I have a weird problem with imagex.

    I want to merge a Windows 7 Enterprise install.wim and a Windows 7 Ultimate install.wim. I use the following commands: "imagex /export D:\7ENT\sources\install.wim 1 D:\install.wim"
    "imagex /export D:\7ULT\sources\install.wim 1 D:\install.wim"

    After the second command the first volume (Enterprise) is replaced by Ultimate instead of Ultimate being added with index number 2. So no matter what I do, I have only one volume within the WIM file. This is driving me nuts as I know that it works from other projects.

    What am I doing wrong? I have tried with imagex from WAIK and ADK.

    Thanks in advance for your help!

    Best regards,

    Ben

    Tuesday, July 2, 2013 12:31 PM

All replies

  • I normally give the images names so my commands would look like this:

    imagex /export D:\7ENT\sources\install.wim 1 D:\install.wim "Windows 7 Enterprise"
    imagex /export D:\7ULT\sources\install.wim 1 D:\install.wim "Windows 7 Ultimate"


    Tuesday, July 2, 2013 12:48 PM
  • I haven't use the export command myself but your command looks different from what Keith does.

    http://deployment.xtremeconsulting.com/2010/12/16/combining-wim-files/

    Tuesday, July 2, 2013 1:04 PM
  • The full syntax is (from: http://technet.microsoft.com/en-us/library/cc749447(v=WS.10).aspx):

    imagex /export src_file src_number src_name dest_file dest_name {/boot | /check | /compress [type] | /ref [splitwim.swm]}
    What c_grz provided should work, since it uniquely identifies each exported WIM with a "dest_name". Without providing a different name, imagex assumes you want to overwrite the one already there.

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Tuesday, July 2, 2013 1:07 PM
    Answerer
  • Hi,

    sorry, I forgot to write that but my commands are exactly the same.

    Best regards,

    Ben

    Tuesday, July 2, 2013 1:32 PM
  • hmm. I think I need to get me a better Internet browser. I didn't see the full command provided by c_grz. Please ignore my reply but the link is still good for reference. ;)
    Tuesday, July 2, 2013 1:35 PM
  • Hi,

    I tried another time, just to make sure I did not forget something:

    "imagex /export D:\7ENT\sources\install.wim 1 D:\install.wim" "Windows 7 Enterprise"
    "imagex /export D:\7ULT\sources\install.wim 1 D:\install.wim" "Windows 7 Ultimate"

    When looking at the image with dism /get-wiminfo there is only one image "Windows 7 Ultimate". I don't get it...

    Seems as if imagex simply overwrites the contents.


    Ben

    Tuesday, July 2, 2013 1:45 PM