none
Cannot login to Sharepoint 2010 central admin

    Question

  • Hi Guys,

    I am relatively new to MOSS and have started investigating the product. I had MOSS 2010 fully funtioning in a test environment and had an issue with authentication. Each time a user accessed the site for the time, they would be prompted for a username and password. I then came across an article that indicated i should enable Kerberos authentication in Central Admin. I did this but once the configuration completed i could no longer access Central admin. The normal site sites are available and functioning. What could the issue be?

    thank you,

    Friday, September 03, 2010 10:24 AM

Answers

  • Hi Guys,

     

    After posting i thought of reverting permissions via IIS. i noticed auth methods under .Net providers in IIS and i changed thosse settings which corrected my problem.

     

    thank you

    • Marked as answer by Ilyaaz Monday, September 06, 2010 11:22 AM
    Monday, September 06, 2010 11:22 AM

All replies

  • Hi

     

    Did you check event log - it must have some info

    Is the app pool for CA site running?

     

    Regards

    Yogesh Pawar

    Friday, September 03, 2010 11:01 AM
  • First thing you should do is disable Kerberos authentication since you're not using it. Since you can't access Central Administration to do this, you need to do it via PowerShell. Below is the command you need to use:

    Get-SPWebApplication http://<servername>:<port> | Set-SPWebApplication -Zone "Default" -AuthenticationMethod "NTLM"
    

    NOTE: "http://<servername:<port>" represents the URL of your Central Administration Web Application.

    For the first part of your question about being prompted for credentials; you probably just need to add the URL of your site to the "Intranet" or "Trusted Sites" Zone in IE. By placing your site in one of those zones, IE will automatically attempt to login to the site with the username and password of the currently logged in Windows user.

    Hope this helps.


    Muhanad Omar, SharePoint MVP, @muhanado
    • Proposed as answer by Alpesh NAKAR Friday, September 03, 2010 10:40 PM
    Friday, September 03, 2010 8:01 PM
  • Hi Guys,

     

    After posting i thought of reverting permissions via IIS. i noticed auth methods under .Net providers in IIS and i changed thosse settings which corrected my problem.

     

    thank you

    • Marked as answer by Ilyaaz Monday, September 06, 2010 11:22 AM
    Monday, September 06, 2010 11:22 AM
  • thank you

    Wednesday, December 23, 2015 3:05 PM