locked
Access denied Error to Authenticated Users. RRS feed

  • Question

  • Dear Gurus,

    We are having Windows Office SharePoint Server 2007 Setup in my company; we are using Window Bases Authentication (Using Active Directory) for site access.

    But now I have start facing Strange Issue while accessing SharePoint Sites by their authenticated users.

    When users are accessing sites, Document Library or particular folder, they are getting ACCESS DENIED Error, despite having access rights on the site. Users like Reader, Contributors are having this problem. But at the same time Site Administrator are able to access the same sites.

    Thank you very much.

    Moderator Note: You were already told in an earlier post not to say that your question is ASAP. Yet here you are again saying the same thing. Keep doing this and I will delete your posts. The forums are NOT for urgent (asap; ASAP etc.) questions. If you are in a hurry Pay for Support by contacting MS Customer Support Services and do not post to the forums.

    I have also removed a post from you asking about the same issue in an existing thread. Either post a new thread OR add to an existing thread. Do not do both.

     

     

    • Edited by Mike Walsh FIN Thursday, March 31, 2011 6:10 AM Moderator Note added warning that future uses of ASAP and similar will lead to posts being deleted.
    Thursday, March 31, 2011 5:23 AM

Answers

  • Hi NimeshNaik,

    I think your problem is caused by missing permissions for the "Style Resource Readers" group. Normally, this group contains "nt authority\authenticated Users" and has  read access to the masterpage gallery and restriced read access to the style library. It is automatically created when activating the publishing feature.

    Check if that group exists and if yes make sure that all users who need to access the page are in members of the group (easiest way is using "NT AUTHORITY\authenticated users"). If it does not exist recreate the group and give it the permissions mentioned above. 


    • Marked as answer by Emir Liu Thursday, April 7, 2011 5:31 AM
    Thursday, March 31, 2011 8:41 AM

All replies

  • Hi,

    are totally blocked from the sharepoint site or can they visit the homepage?

    You try

    - resetting the password for a user with problems;

    - create a new user with the same 'authentication profile' as a user with problems and see if this user has also problems.

    You state that an ADMIN can visit the problem site(s)/Libraries etc so it must be a authentication/security issue. Maybe somebody changed the authentication or broke inheritence or something. Rather difficult to say.

    HTH!

     

    Thursday, March 31, 2011 5:46 AM
  • Users

    Hi Sander,

    I would like to add more in my issue.

    In most cases Users are able to open the documents library but when they click on any particular folder inside the library, access denied error message appears.

    We are having lots of users so recreating them is unfortunately not possbile.

    I would like to add one more Observation with example below:

    1. Suppose User test1 (Contributor) tried to access folder name DATAFOLDER on site //mydomain/mysite/datasite, and he got ACCESS DENIED Error Message.
    2. Now, the Site Collection Administrator  tried to access same folder DATAFOLDER on site //mydomain/mysite/datasite, and He IS SUCCESSFULLY ACCESS IT.
    3. After that, User test1 (Contributor) tried to acccess the folder DATAFOLDER again and this time He IS SUCCESSFULLY ACCESS IT. (AFTER SITE COLLECTION ADMINISTRATOR access SITE SUCCESSFULLY), This same case worked for different site collection on which users were got error.

    Kindly give us some more Idea to solve this issue.

    Thank you very much.

     

     

     

     

    Thursday, March 31, 2011 6:30 AM
  • Hi NimeshNaik,

    I think your problem is caused by missing permissions for the "Style Resource Readers" group. Normally, this group contains "nt authority\authenticated Users" and has  read access to the masterpage gallery and restriced read access to the style library. It is automatically created when activating the publishing feature.

    Check if that group exists and if yes make sure that all users who need to access the page are in members of the group (easiest way is using "NT AUTHORITY\authenticated users"). If it does not exist recreate the group and give it the permissions mentioned above. 


    • Marked as answer by Emir Liu Thursday, April 7, 2011 5:31 AM
    Thursday, March 31, 2011 8:41 AM