none
Error using MDT2013 and ADK 10 deploying windows 10 Build 1511 RRS feed

  • Question

  • I have downloaded the most recent build of Windows 10 from the MSVL site and am curious if anyone else is having issues with it. I thought my TS had gotten messed up, but after I reverted back to the previous build, my gremlins went away. Now, in all my testing, I didn't save any of the logs, but they were not that helpful to begin with.

    The first issue is that Build 1511 shows up as Windows 10 Pro Technical Preview in the OS description when I go to import it. That's fine - it shows up correctly in the OS, but that's just a red flag.

    My second issue was that my TS was failing with a red screen and the innocuous -2147467259 error. Further investigation found that my TS was trying to write to a non-existent log file after reading the SMSTS.ini file. Is that a ConfigMgr thing? I've never heard of such a file using straight MDT and ADK.

    Anyway, reverting back to my previous OS image worked. I'll have to wait for my reference image to get the 1511 update, but that's better than chasing ghosts.

    Mahalo,

    -DaG

    Saturday, December 26, 2015 2:38 PM

All replies

  • hi

    The "Windows 10 Pro Technical Preview in the OS description" is a bug - it is the right media, but MS has created the ISO with the wrong label.

    What MDT version are you using?

    Have you tried to create a new test Task Sequence with the 1511 OS build??

    Kind regards

    Per Larsen

    Twitter: @PerLarsen1975 | Blog: osddeployment.wordpress.com
    If this post is helpful please vote it as Helpful or click Mark for answer.

    Saturday, December 26, 2015 10:07 PM
  • Post your logs. BDD.log and smsts.log.

    Logs are very important. https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Mention any customizations you have made.

    Saturday, December 26, 2015 10:34 PM
    Moderator
  • I think I may have found the problem with my odd errors. I have a TS step that is supposed to copy files from %ScriptRoot% and the value is blank.

    I wrote a quick VBscript to output some environment variables:

            wscript.echo "OSDisk: " & oEnvironment.Item("OSDisk")
            wscript.echo "ScriptRoot: " & oEnvironment.Item("ScriptRoot")
            wscript.echo "DeployRoot: " & oEnvironment.Item("DeployRoot")

    I thought it was the %OSDISK% it was failing on, but oddly enough, ScriptRoot is blank.

    Has that gone away and I've been living under a rock for a few years? Why would that happen?

    I'm going to try %DeployRoot%\Script for now and see if that works...

    Sunday, December 27, 2015 12:23 PM
  • Nope - that wasn't it. It seems to fail if I try to run command lines - of any kind - cmd /c <<command>> - ever since I upgraded to 2013 update 1 it's broken and just not working. very frustrating...

    Sunday, December 27, 2015 8:07 PM
  • Start in doesn't work in TS so just use a fully qualified path in the command line.

    Logs are very important. https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Mention any customizations you have made.

    Monday, December 28, 2015 3:04 AM
    Moderator