locked
how to remove the space on the top and bottom of text in table cells RRS feed

  • Question

  • Hi,

    I was wondering if anyone might be able to help me here. I have just got an ipad here and like to transfer some documents created using Word application to the iPad so that I could edit them while I'm away from the office.

    However, when I tried to open a word document in pages on iPad, it stripped off features that it does not support such as bullet numbering points in a table, no garamond font and all that. Now, the problems I am having is when I want to open it back using word application. I lost all the bits and pieces.

    I could probably get away with writing a macro to change the font name to Garamond in word. However, I need help with table.

    In every cell of the table, I notice that there is a couple of things that are different

    1. there is a bit of space on the top and the bottom of the text. Usually, table created in word, there is no space on the top and the bottom

    2. text in the cell appears to be too close to the left of the border line

    I tried to go through the table properties in word to make some adjustment to the cell properties but nothing got changed at all.

    Any help would be greatly appreciated.

    Thank you

     

     

     

     

    Thursday, February 2, 2012 5:17 AM

Answers

  • I think it can be a combination of theese two problems

    1. The styles has changed.

    If you mark the text in the table and do ctrl+q and ctrl+space. Does it change anyting?

    If nothing is changed see what style is used on the text. Go to that style (probably the normal style) and change the font to Garamond and control what settings has been changed for paragraph for that style. If you need more help on have to set up your styles have a look here http://office.microsoft.com/en-us/word-help/style-basics-in-word-HA010230882.aspx 

    2 Cell margin has changed - but you say you tried this but lets have another go 

    If you use the setting on the Table Tools Layout tab, that sets the default cell margins for all cells in the table. BUT, you can specify each cell to not have the same settings as the default. Check first that you have set the default cell margins to a proper value. you find the settings on the Layout tab for the table tools. Click on the button cell margins. set the margins to a space you feel is ok. If this is set ok you must check so all cells use the default settings.

    Mark the table
    Right click on the table and click on table properties.
    Click on the Cell tab in the dialog
    Click on the options dialog and check the box "same as whole table"

    You can also check if the row "specify height" checkbox is checked, (Row tab in tabletools dialog) uncheck this

    Hope this can help

    /Paulina

     

    Thursday, February 2, 2012 12:17 PM

All replies

  • I think it can be a combination of theese two problems

    1. The styles has changed.

    If you mark the text in the table and do ctrl+q and ctrl+space. Does it change anyting?

    If nothing is changed see what style is used on the text. Go to that style (probably the normal style) and change the font to Garamond and control what settings has been changed for paragraph for that style. If you need more help on have to set up your styles have a look here http://office.microsoft.com/en-us/word-help/style-basics-in-word-HA010230882.aspx 

    2 Cell margin has changed - but you say you tried this but lets have another go 

    If you use the setting on the Table Tools Layout tab, that sets the default cell margins for all cells in the table. BUT, you can specify each cell to not have the same settings as the default. Check first that you have set the default cell margins to a proper value. you find the settings on the Layout tab for the table tools. Click on the button cell margins. set the margins to a space you feel is ok. If this is set ok you must check so all cells use the default settings.

    Mark the table
    Right click on the table and click on table properties.
    Click on the Cell tab in the dialog
    Click on the options dialog and check the box "same as whole table"

    You can also check if the row "specify height" checkbox is checked, (Row tab in tabletools dialog) uncheck this

    Hope this can help

    /Paulina

     

    Thursday, February 2, 2012 12:17 PM
  • Thank you Paulina for your reply.

    Yes, your suggestion works if I go into the table properties and do the modifications there to make it look like I wanted it to.

    However, I was trying to make the same changes using macros VBA and got stuck when trying to set alignment for table to the left by -0.18 inch.

    So the following settings is what I really want to apply to any tables in the document.

    Table -> Preferred width: 6.5" in inches, Alignment Left: -0.18", Textwrapping: None

    Row -> Size: None, Options: Allow row to break across pages

    Column -> Size: No Preferred width

    Cell -> Size: None, Vertical alignment: Top, Option: same as the whole table & wrap text


    So in Macros VBA, I got the following:

        With ActiveDocument.Tables(1)
            .PreferredWidthType = wdPreferredWidthAuto
            .PreferredWidth = 6.5
            .Rows.AllowBreakAcrossPages
            .Cell.VerticalAlignment = wdCellAlignVerticalTop
            .Cell.WordWrap
         End With

    I was wondering if I could get some help with the following VBA questions:

    1. I was trying to set preferredwidthtype to inches but there is no options for inches. So I just set it to auto.

    2. How do I set the alignment for the whole table to the left by -0.18 inches?

    3. Regarding the Cell in table, how do I set it to "Same as the whole table"?

    Any help would be greatly appreciated.

    Thank you








    Monday, February 13, 2012 5:08 AM