locked
Explorer.exe flickering after RDC RRS feed

  • Question

  • I'm having a desktop computer A with windows 8.1 and when I connect to it from some other computer B with windows 8 through Remote Desktop Connection, because of the screen resolution change, the entire desktop (explorer.exe) flickers desperately and is extremely slow.

    • What I do typically is to kill explorer.exe (which is still slow due to the flickering, because TaskManager responds slowly) and then restart explorer.exe. Everything back to normal then.
    • If I wait long enough (perhaps 5min) it may go back to normal but I'm not sure.
    • The same problem shows up even if I log into A locally (while having RDC logged in previously from B), because a resolution change is still needed in this case.
    • The same problem was there when I had A in windows 8 rather than windows 8.1.

    Any idea what is going on?

    Friday, June 20, 2014 9:28 PM

Answers

  • Hi,

    Have you tried to change the Remote Desktop Connection properties before you connect to the RDP? change the settings under "Display" and "Experience" tab.

    Sometimes, the RDP flickering is related with some RemoteFX which is used to enhance the display quality, [Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment] you can turn off RemoteFX related policy as a test.

     


    Yolanda Zhu
    TechNet Community Support

    • Marked as answer by EMMmmmmmm Thursday, July 3, 2014 9:22 AM
    Monday, June 23, 2014 5:16 AM

All replies

  • Hi,

    Have you tried to change the Remote Desktop Connection properties before you connect to the RDP? change the settings under "Display" and "Experience" tab.

    Sometimes, the RDP flickering is related with some RemoteFX which is used to enhance the display quality, [Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment] you can turn off RemoteFX related policy as a test.

     


    Yolanda Zhu
    TechNet Community Support

    • Marked as answer by EMMmmmmmm Thursday, July 3, 2014 9:22 AM
    Monday, June 23, 2014 5:16 AM
  • Thanks Yolanda

    I turned off all RemoteFX related policies right after hearing back from you on the 23rd, and spent a few days testing on it. (I don't have the two computers at the same place so can do this test roughly only once per day...) So far, things seem to have been much improved! I may still see flickering but only of the magnitude of seconds, rather than hundreds of seconds. Thanks! I'll come back if the problem reappears.

    Zeyuan

    Saturday, June 28, 2014 8:28 PM