none
Group policy screen saver timeout different of remote desktop sessions

    Question

  • I have set an enforced screen saver timeout across the network using group policy. Specifically I have set 3 items under a single policy, namely:

    User configuration > Administrative Templates > Control Panel > Personalization

    Enable screen saver  - Enabled

    Password protect the screen saver - Enabled

    Screen saver timeout - 1200 seconds

    This works fine on the workstations and on logon to the remote desktop servers - these items are displayed correctly in Windows 10 on the workstations and on the users logins to the Windows 2012 R2 RDS server. On Windows 10 the timeout works correctly (at 20 minutes) but on the RDS login to the 2012 server, the timeout happens at approx 4 minutes, despite the display saying 20 minutes.

    Obviously, this is driving our user community scatty. Can anyone explain what's happening?

    Wednesday, February 08, 2017 3:40 PM

All replies

  • Hi,
    As far as I know, the timeout time for screen saver could be set ScreenSaveTimeOut string value item in the following registry:
    HKEY_USERS\.DEFAULT\Control Panel\Desktop
    You could have try using group policy preference to directly configure this registry item for RDP sessions, please refer to tfrederick74656’s answer in the following thread for more details regarding how to configure it:
    http://serverfault.com/questions/373695/gpo-to-disable-screensaver-only-when-connected-via-rdp
    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.
    Best regards,
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, February 09, 2017 6:52 AM
    Moderator