locked
Exchange Server 2016 - SDPOndemand cannot delete email from mailserver RRS feed

  • Question

  • Hello everyone,

    I'm troubleshooting this specific issue for a few days on end, without much succes. The issues started with the installation of the latest CU15 a couple of days ago. We use ManageEngine SDPOndemand as our helpdesktool which fetches e-mails from our on-premise Exchange 2016. The settings used in SDPOndemand and have worked for a few years, until the recent installation of Exchange CU15 last week, are seen below.

    The issue we now face, is that some e-mails are flowing perfectly in SDPOndemand, but others are not. The effect is that SDPOndemand by design pulls the emails in SDP, and then deletes them on the mailserver (so the mailbox stays empty) - if SDPOndemand cannot delete the mail, it stops mail fetching - which is not good.

    I've noticed that it works when there is no attachment in the e-mail. If there is an attachment in it, no go. SDP cannot delete the email and stops. 

    I do not see any related errors in any of the many event logs on our Exchange 2016 (on-prem) server. So i do not have anything to go any further on... there simply isn't anything there in the logs... 

    Does anyone have any suggestions on how to troubleshoot this further please?

    Thanks in advance




    Monday, March 9, 2020 10:10 PM

All replies

  • Hi,

    Do you mean you use SDPOndemand to get emails sent with IMAP account and delete them on the sender side?

    If so, you can set the Email Type to IMAP(Port 993), since it's recommended to use port 993 for incoming server (IMAP) when we configure IMAP account with Outlook. For your reference: POP and IMAP account settings.

    Additionally, if there are no issues about the mail flow after disabling SDPOndemand, you should contact the vendor for this issue, and make sure this tool can work well with the latest version of Exchange servers. 

    Regards,

    Lydia Zhou


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, March 10, 2020 2:35 AM
  • Just checking in to see if above information was helpful. If you have any questions or need further help on this issue, please feel free to post back. 

    Regards, 

    Lydia Zhou


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Friday, March 13, 2020 11:17 AM