none
Event 1033, MSExchangeActiveSync Warning

All replies

  • The same situation after every reboot

    Sunday, January 12, 2014 9:34 AM
  • We are having the same issue. 


    Brian


    All my life I wanted to be somebody. I guess I should have been more specific. -- The Covert Comic

    Wednesday, January 15, 2014 3:35 PM
  • We are also seeing this issue, and reboots/recycles have no affect.  We are also seeing random ActiveSync problems.

    I cannot believe how incredibly buggy 2013 is.  I knew it was going to be bad, but I couldn't imagine it would be this bad. 

    Wednesday, January 15, 2014 6:01 PM
  • Same issue here, after every reboot.
    • Proposed as answer by Muhammed Wasim Tuesday, April 22, 2014 7:54 PM
    Thursday, February 13, 2014 8:45 AM
  • Same issue here, after every reboot.
    Went to C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\Sync and renamed the web.config file to old.
    - Renamed web.config.bak to web.config
    - Performed IISRESET
    - Now the events were not coming up.
    Tuesday, April 22, 2014 7:55 PM
  • We are seeing the same issue in Exchange 2013 SP1 and Windows Server 2012 R2.

    "The setting SupportedIPMTypes in the Web.Config file was missing.  Using default value of System.Collections.Generic.List`1[System.String]."

    What should we do here? I like to keep my event log clean and i've tried the suggested IISRESET/bouncing the server but it does not help.

    This is a fresh EXCH2013SP1/WIN2K12R2 install.. how do these bugs slip through into a RTM'ed product when they present themselves right at the begging?!

    Friday, July 18, 2014 4:23 PM
  • How it slips through is MS has all of their senior resources dedicated to Office 365.  On premise Exchange is an afterthought at best.  There's a host of false positive error messages in CU5, that have existed since RTM.  SOme cause issues, some don't, but they all clog up the event viewer with garbage. 
    Friday, July 18, 2014 4:26 PM
  • I did not have this error when I installed the server starting at SP1.  I have since installed CU7 and this error started at every reboot.
    Saturday, December 20, 2014 2:21 AM
  • Same here! We have a fresh LAB-Installation and also same behavior in productive Environment. It happens just the same in both Installations! This is after CU7!

    Also we get Event-ID 1309, ASP.NET 4.0.30319.0

    Exception information:
    Exception type: AirSyncPermanentException
    Exception message: DeviceIdMissingOrInvalid:'bei Microsoft.Exchange.AirSync.AirSyncRequest.BuildDeviceIdentity()
       bei Microsoft.Exchange.AirSync.AirSyncRequest.Microsoft.Exchange.AirSync.IAirSyncRequest.get_DeviceIdentity()
       bei Microsoft.Exchange.AirSyncHandler.Handler.AddRequestToCache(Guid requestId)
       bei Microsoft.Exchange.AirSyncHandler.Handler.EndProcessRequest(IAsyncResult result)
       bei System.Web.HttpApplication.CallHandlerExecutionStep.OnAsyncHandlerCompletion(IAsyncResult ar)

    And:

    Event-ID 1033, MSExchange ActiveSync

    "The setting SupportedIPMTypes in the Web.Config file was missing. Using default value of System.Collections.Generic,List`1[System.String].

    Event-ID 1100, MSExchange ActiveSync

    Event-ID 4999, MSExchange Common

    E12, c-RTL-AMD64, 15.00.0995.032, w3wp#MSExchangeSyncAppPool, M.Exchange.AirSync, M.E.A.AirSyncRequest.BuildDeviceIdentity, M.E.AirSync.AirSyncPermanentException, 7088, 15.00.0995.032.

    Monday, March 16, 2015 1:08 PM
  • Add me in, clean install Exchange 2013 CU 8 on Windows Server 2012 R2.

    Log Name:      Application
    Source:        MSExchange ActiveSync
    Date:          4-5-2015 20:09:29
    Event ID:      1033
    Task Category: Configuration
    Level:         Warning
    Keywords:      Classic
    User:          N/A
    Computer:      SV-EXC-01.domein.nl
    Description:
    The setting SupportedIPMTypes in the Web.Config file was missing.  Using default value of System.Collections.Generic.List`1[System.String].
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchange ActiveSync" />
        <EventID Qualifiers="32772">1033</EventID>
        <Level>3</Level>
        <Task>2</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2015-05-04T18:09:29.000000000Z" />
        <EventRecordID>15299</EventRecordID>
        <Channel>Application</Channel>
        <Computer>SV-EXC-01.domein.nl</Computer>
        <Security />
      </System>
      <EventData>
        <Data>SupportedIPMTypes</Data>
        <Data>System.Collections.Generic.List`1[System.String]</Data>
      </EventData>
    </Event>


    Hello!

    Monday, May 4, 2015 6:18 PM
  • I'm noticing the "DeviceIdMissingOrInvalid" errors as well. Did you ever resolve the issue?

    Patrick Hoban
    http://patrickhoban.wordpress.com

    Wednesday, May 20, 2015 2:14 AM
  • Same for me, but on Windows 2012 R2 with Exchange 2016 CU1.
    Friday, May 20, 2016 1:24 PM
  • same issues.  Windows 2012 with Exchange 2013.

    chanwingkai

    Thursday, August 25, 2016 1:02 AM
  • By the way, same issue on Exchange 2016 CU2. We started to migrate from Exchange 2010 to 2016. We also see some random ActiveSync issues (mostly disconnects) on Exchange 2016. Over night they got solved without any action from the admin side. So every morning ActiveSync started to work for the users. A little bit frustrating ...

    Update:

    Found the following document https://technet.microsoft.com/en-us/library/ff359673(v=exchg.140).aspx which said:

    "On the General tab, under Application settings, configure the setting specified in the event description to the default value."

    Did anybody tried that?

    • Edited by Bastian_W Friday, November 4, 2016 10:18 AM possible solution added
    • Proposed as answer by Bastian_W Friday, November 4, 2016 10:18 AM
    Sunday, September 25, 2016 4:26 PM
  • @BastianWebster

    Can you make a new thread at Exchange 2016. This is very old.

    Sunday, September 25, 2016 6:53 PM
  • @PK Sarangi

    I could yes, but why? To have another thread with "hey we have the same error?". I leaved a response here  as most companies will migrate to 2013 instead of 2016 (as its to new for most of them) and will run into the same issues. Additional: As the error exists in 2016 as well, I didn´t expect anybody would response to the new thread (which you asked to create) with something else as "me to and it hasn´t fixed since 2013"...

    P.S. Please do not reply as this would be offtopic thanks ;-)

    Sunday, September 25, 2016 8:48 PM
  • Same issue in Exchange 2016 CU4

    Saturday, January 28, 2017 7:57 PM
  • Same problem in Exchange 2013 CU15 (after reboot)
    Monday, January 30, 2017 10:51 AM
  • Getting these errors on Exchange 2013 CU19

    and

    Exchange 2016 CU8

    Thursday, February 1, 2018 7:57 AM