none
DM dynamic Workflow - Error on Submit for Approval RRS feed

  • Question

  • I am getting error on submission for approval stage in the workflows. The error states "Object reference not set to an instance of an object." These workflows have been running smoothly for 2 years and all of a sudden started throwing these errors. Any idea what's causing the issue?

    ULS logs are populated with this error:

    WinWF Internal   Error, terminating workflow Id# 20e95996-e3fd-4936-8926-9aaafeb3bcfd
    System.NullReferenceException: Object  reference not set to an instance of an object.     at   Microsoft.Office.Workflow.Actions.OfficeTask.ProcessTaskError(Object sender,   EventArgs e)     at   System.Workflow.ComponentModel.ActivityExecutorDelegateInfo`1.ActivityExecutorDelegateOperation.Run(IWorkflowCoreRuntime   workflowCoreRuntime)     at   System.Workflow.Runtime.Scheduler.Run()

     

    Environment: PS 2010, SP 2010 PWA

    I think this is related to picking correct users from selected project user groups. how does it pick users when we only select the groups? and what if a select a user group and some users too from the 'Show Users' list, which not necessarily belong to the same selected group.


    Wednesday, May 14, 2014 9:53 AM

All replies

  • Hi Eaman,

    Check the following:

    • A user belonging to the approval group (ie portfolio manager) might be deactivated or not having a valid account.
    • The workflow task list might have been modified, creating  the issue when the workflow needs to add or modify a task.
    • Check also that no changes have been made to the custom fields used by the workflow.

    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Wednesday, May 14, 2014 12:37 PM
    Moderator
  • Hi Guillaume

    Really appreciate your help. I have revisited the areas you mentioned but found no relevant changes. However, I have worked with following settings recently:

    • I ran & scheduled active directory enterprise resource pool synchronization. Rechecking the user status, no relevant user was found inactive. So I don't think inactive or invalid accounts is the reason behind.
    • I have added a new workflow controlled custom field to a PDP. Not sure how this might cause the error.
    • Regarding the workflow task list, there are no modifications that I remember. any idea from where can I view the history for this?

    Still clueless about it..

    Monday, May 19, 2014 11:09 AM