locked
Cloud DP install Broke Primary site DP RRS feed

  • Question

  • While setting up a Cloud DP, the cert that was uploaded had the same name as our Primary Site server. This somehow marked the DP on the primary site as a Azure cloud storage DP. This as you can image broke everything. I've removed the cloud DP, but our Primary site Still thinks it is a Cloud DP and tries to send packages to it but fails. I've tried to do a Site Reset, that did not help, I've tried to Site SQL restore, that didn't resolve the issue. Should I uninstall the Site and do a Site restore? I'm not sure if that will help or make the situation worse. I feel there probably is some registrty setting that can be altered and it will be back to normal. Or a way to force an uninstall of the Primary site DP, and a reinstall. 

    Under Sites And Server Roles. it DP shows up as a Role, but cannot be removed.

    Under Distribution points it shows up as an On-site DP

    Under Monitoring> System Status > Site Status the Primary site does not show a DP, other servers do show that they have a DP configured. 

    Start uploading package with ID RAD00003 to the cloud distribution point ["Display=\\SCCM.domain.com\"]MSWNET:["SMS_SITE=RAD"]\\SCCM.domain.com\ SMS_PACKAGE_TRANSFER_MANAGER 3/16/2014 3:15:51 AM 7512 (0x1D58)
    Copying package RAD00003 to the package share location \\?\E:\SMSPKGSIG\RAD00003 on the server SCCM.domain.com SMS_PACKAGE_TRANSFER_MANAGER 3/16/2014 3:15:51 AM 7512 (0x1D58)
    Found Proxy Information. Use Proxy : False Proxy Address : , Proxy Port : 80, Anonymous Access : True, User Name : SMS_PACKAGE_TRANSFER_MANAGER 3/16/2014 3:15:52 AM 7512 (0x1D58)
    Clearing the proxy as no proxy address has been set SMS_PACKAGE_TRANSFER_MANAGER 3/16/2014 3:15:52 AM 7512 (0x1D58)
    Deleting old files from Package RAD00003 for Cloud DP SCCM.domain.com SMS_PACKAGE_TRANSFER_MANAGER 3/16/2014 3:15:52 AM 7512 (0x1D58)
    ERROR: Failed to retrieve the Azure storage account. SMS_PACKAGE_TRANSFER_MANAGER 3/16/2014 3:15:52 AM 7512 (0x1D58)
    Verifying storage access... SMS_PACKAGE_TRANSFER_MANAGER 3/16/2014 3:15:52 AM 7512 (0x1D58)
    Uploading package RAD00003 for Cloud DP SCCM.domain.com (user defined cloud storage account) SMS_PACKAGE_TRANSFER_MANAGER 3/16/2014 3:15:52 AM 7512 (0x1D58)
    ERROR: Failed to retrieve the Azure storage account. SMS_PACKAGE_TRANSFER_MANAGER 3/16/2014 3:15:52 AM 7512 (0x1D58)
    Package contents will be encrypted. Algorithm used is System.Security.Cryptography.AesCryptoServiceProvider SMS_PACKAGE_TRANSFER_MANAGER 3/16/2014 3:15:52 AM 7512 (0x1D58)
    Algorithm KeySize (in Bits) = 256, BlockSize (in Bits) = 128 SMS_PACKAGE_TRANSFER_MANAGER 3/16/2014 3:15:52 AM 7512 (0x1D58)
    Verifying storage access... SMS_PACKAGE_TRANSFER_MANAGER 3/16/2014 3:15:52 AM 7512 (0x1D58)
    WARNING: Caught exception System.NullReferenceException - Object reference not set to an instance of an object. SMS_PACKAGE_TRANSFER_MANAGER 3/16/2014 3:15:52 AM 7512 (0x1D58)
    Call stack:    at Microsoft.ConfigurationManager.AzureRoles.ContentManager.ContentRouter.IsStorageAccessible()~~   at Microsoft.ConfigurationManager.AzureRoles.ContentManager.ContentManager.CheckServiceStatus(ContentRouter contentRouter)~~   at Microsoft.ConfigurationManager.AzureRoles.ContentManager.ContentManager.UploadContent(String packageId, String contentId, String contentSource, String contentInfoPath, Boolean uploadFiles, EncryptionParams encryptionParams, ContentRouter contentRouter, String& contentInfoFile)~~   at Microsoft.ConfigurationManager.AzureRoles.ContentManager.ContentManager.UploadPackageToCloudWithContentInfo(String packageId, String contentSource, String contentInfoPath, String cloudDP, String encryptionKey, String algName, Int32 keySize, Int32 blockSize, String& contentInfoFile) SMS_PACKAGE_TRANSFER_MANAGER 3/16/2014 3:15:52 AM 7512 (0x1D58)
    STATMSG: ID=9300 SEV=E LEV=M SOURCE="SMS Server" COMP="SMS_CLOUD_CONTENT_MANAGER" SYS=SCCM.domain.com SITE=RAD PID=4716 TID=7512 GMTDATE=Sun Mar 16 07:15:52.583 2014 ISTR0="Object reference not set to an instance of an object." ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=2 AID0=400 AVAL0="RAD00003" AID1=404 AVAL1="["Display=\\SCCM.domain.com\"]MSWNET:["SMS_SITE=RAD"]\\SCCM.domain.com\" SMS_PACKAGE_TRANSFER_MANAGER 3/16/2014 3:15:52 AM 7512 (0x1D58)
    WARNING: Warning - returning null/empty download address from content upload RAD00003 SMS_PACKAGE_TRANSFER_MANAGER 3/16/2014 3:15:52 AM 7512 (0x1D58)
    STATMSG: ID=9310 SEV=W LEV=M SOURCE="SMS Server" COMP="SMS_CLOUD_CONTENT_MANAGER" SYS=SCCM.domain.com SITE=RAD PID=4716 TID=7512 GMTDATE=Sun Mar 16 07:15:52.583 2014 ISTR0="RAD00003" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=2 AID0=400 AVAL0="RAD00003" AID1=404 AVAL1="["Display=\\SCCM.domain.com\"]MSWNET:["SMS_SITE=RAD"]\\SCCM.domain.com\" SMS_PACKAGE_TRANSFER_MANAGER 3/16/2014 3:15:52 AM 7512 (0x1D58)
    UploadPackageToCloud() failed. Error = 0x80004003 SMS_PACKAGE_TRANSFER_MANAGER 3/16/2014 3:15:52 AM 7512 (0x1D58)
    Failed to distribution content to the cloud DP SMS_PACKAGE_TRANSFER_MANAGER 3/16/2014 3:15:52 AM 7512 (0x1D58)
     Sending failed. Failure count = 1, Restart time = 3/16/2014 3:45:52 AM Eastern Daylight Time SMS_PACKAGE_TRANSFER_MANAGER 3/16/2014 3:15:52 AM 7512 (0x1D58)


    , Kristofer Olafsson

    Sunday, March 16, 2014 7:57 AM

Answers

  • I'd call Microsoft support (CSS) before reinstalling or restoring the site. I *think* that it should be easy to fix that (modifying the database or WMI).

    Torsten Meringer | http://www.mssccmfaq.de

    Sunday, March 16, 2014 8:48 AM

All replies

  • I'd call Microsoft support (CSS) before reinstalling or restoring the site. I *think* that it should be easy to fix that (modifying the database or WMI).

    Torsten Meringer | http://www.mssccmfaq.de

    Sunday, March 16, 2014 8:48 AM
  • I'd call Microsoft support (CSS) before reinstalling or restoring the site. I *think* that it should be easy to fix that (modifying the database or WMI).

    Torsten Meringer | http://www.mssccmfaq.de

    Just got finished with my support Case. We believe we tracked down the issue and my Primary site DP is working now. I still have some tests do to. So it appears that a few entries in the SC_SysResUse still had the NALResType of Azure instead of "Windows NT Server" We discovered this by looking at how the spDeleteCloudDP  and sp_DeleteDP  Stored procedures worked and what they referenced.

    We deleted the primary Distribution point from the sql tables. Then we went into the console, Interesting thing is the primary site server disappeared completely from the console, scary. Then Added Site Server put my primary site server name, selected my roles and it reinstalled and started working again.


    , Kristofer Olafsson

    • Proposed as answer by TorstenMMVP Wednesday, March 19, 2014 8:31 AM
    Tuesday, March 18, 2014 8:54 PM
  • I've had the same incident, i'd call microsoft to perform this database adjustment?
    Tuesday, April 29, 2014 8:27 AM
  • Yes, you should call CSS as modifying the database manually is not supported (unless CSS tells you to do so).

    Torsten Meringer | http://www.mssccmfaq.de

    Tuesday, April 29, 2014 8:32 AM
  • I agree with Torsten Meringer. There are several other tables that need to be verified too, in my case they were ok, but they could have had issues too. 

    , Kristofer Olafsson

    Tuesday, April 29, 2014 2:43 PM