locked
SfB Client fail to Sign-in Over DA - Malformed SIP URI RRS feed

  • Question

  • Hi,

    SfB Client 2016 fail to sign-in over DA. It just spins for sign-in to connect to Lync 2010 servers but nothing happens..

    - At the same time Lync 2010 client connects fine.

    - If the DA is disabled, SfB client connects but it takes little bit longer as compared to Lync 2010 client. 

    For SfB client failure, Logs are showing as Malformed SIP URI as it is coming in as IPv6 format. 

    SIP/2.0 400 Malformed SIP URI
    From: <sip:[2001:0:8a68:e317:38bb:374:ae22:7d11]:56825>
    To:      <sip:[2002:8a58:e417:8001::afd:215]:5061>

    ms-diagnostics: 1018;reason="Parsing failure";source="LyncFE.mydomain.int"

    There are multiple Lync pools (including Edge pool) and the problem is happening with just one of Lync pool. If the user is moved to another Lync pool, SfB works fine. IPv6 is enabled on all servers. If it is due to IPv6 then SfB client should not sing-in with all pools

    Any suggestion?

    Cheers,

    H.

    Thursday, February 18, 2016 9:58 PM

Answers

  • Same DA boxed worked fine with 4 out 5 Lync pools (each having separate Edge Servers) therefore the issue was limited to one the Edge pool instead.

    The issue turned out due to incorrect internal DNS entry. One of the DC were decommissioned but the entries were not updated on both Edge and the Firewall. 

    • Proposed as answer by Eric_YangK Sunday, February 28, 2016 11:37 AM
    • Marked as answer by Eric_YangK Monday, February 29, 2016 2:10 PM
    Sunday, February 28, 2016 9:52 AM

All replies

  • Id recommend excluding the Lync/Skype4B infrastructure from Direct Access as your excluding the Edge server from doing what its supposed to do.

    Lync/Skype4B is secure be design, as it uses M-TLS there is no need to re-encrypt/tunnel the traffic via DA. This will also add a whole mess of media issues for Voice and conferencing if you dont pass the media via the edge server. (jitter, media path issues, Media bypass failures etc)

    If your signin is slow via the Edge, ensure that you have your SRV and autodiscover records on the edge configured correctly.

    Some other threads and articles for reference

    http://www.ironnetworks.com/blog/application-compatibility-issues-microsoft-directaccess

    https://social.technet.microsoft.com/Forums/lync/en-US/e22205b4-30b4-4329-ad81-7b77bd501045/lync-2013-over-direct-access-dont-work?forum=lyncconferencing


    Was my post helpful? Help me help you by voting or making the post as an answer. If you're in Melbourne, Australia I regularly present at the Skype4B users group, Feel free to catch up.

    • Proposed as answer by James Arber Friday, February 19, 2016 12:13 AM
    • Unproposed as answer by James Arber Friday, February 19, 2016 12:13 AM
    Friday, February 19, 2016 12:13 AM
  • Hi Hemat Kumar,

     

    Agree with James Arber.

    In addition, please note that IPv6 is not supported on Lync Server 2010.

    https://technet.microsoft.com/en-us/library/jj204624.aspx

     

    In your case, it seems that the Direct Access client sends the request to the Lync Server, but the NAT64 service on the Direct Access Server does not NAT it to IPv4 format, it forwards the connection to the Lync Server directly.

    I would suggest you double-check the settings on the Direct Access Server.

     

    Best regards,

    Eric


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    • Edited by Eric_YangK Friday, February 19, 2016 7:32 AM
    Friday, February 19, 2016 7:29 AM
  • Same DA boxed worked fine with 4 out 5 Lync pools (each having separate Edge Servers) therefore the issue was limited to one the Edge pool instead.

    The issue turned out due to incorrect internal DNS entry. One of the DC were decommissioned but the entries were not updated on both Edge and the Firewall. 

    • Proposed as answer by Eric_YangK Sunday, February 28, 2016 11:37 AM
    • Marked as answer by Eric_YangK Monday, February 29, 2016 2:10 PM
    Sunday, February 28, 2016 9:52 AM