MDT Windows Update Error: Event 41002 sent: ZTI ERROR - Unhandled error returned by ZTIWindowsUpdate RRS feed

  • Question

  • Hello! I have some new Lenovo T440s and T540p laptops I'm imaging and I keep seeing mixed results on them. A few complete all steps with no errors, but some keep failing at the windows update post-application step. 

    After taking some logs, I see this error in the ZTIWindowsUpdate log but cannot figure out why.

    Any thoughts??

    Event 41002 sent: ZTI ERROR - Unhandled error returned by ZTIWindowsUpdate: Object doesn't support this property or method (438)

    Monday, March 17, 2014 1:48 PM


All replies

  • Do you have a WSUS server, or are you using Windows Update?

    See if this fixes your issue:

    Keith Garner -

    Monday, March 17, 2014 7:25 PM
  • I have the exact same error while using MDT to deploy updates. If I run the ZTIWindowsUpdate script outside of MDT, it works (downloads and installs the updates). If I run within MDT, only downloading completes and the installation never runs, just kicks out the error you referenced.



    • Proposed as answer by BobJ- Wednesday, June 4, 2014 5:43 PM
    • Unproposed as answer by BobJ- Wednesday, June 4, 2014 5:43 PM
    Wednesday, June 4, 2014 2:07 PM
  • All-

    I found the following under another post and forum, but forgot where I found it. Anyhow, this resolved my issue with my WSUS updates not installing within the MDT Windows 7 deployments. The download process always worked, but the actual installation always errored out with the ZTIWindowsUpdate.wsf file. In short, line 403 (and below) was changed to read the following:

    oLogging.CreateEntry "    Failed to download:  " & UpdatesToDownload.Item(item).Identity.UpdateID & _

    "  result(" & UpdateResult.GetProgress.GetUpdateResult(item).ResultCode & ") : " & UpdatesToDownload.Item(item).Title, MSIT_LogType

    In addition to this, I created a task before the Pre-Installation runs in MDT and before the Post-Installation to ensure the time is sync'd up using the run command of net time \\yourdomaincontroller /set /yes

    I hope someone might benefit from the above and again, this came from other post and appears to work just fine.


    Wednesday, June 4, 2014 5:52 PM