none
DNS Issue RRS feed

  • Question

  • Hi

    When our client machines are turned on after being off for a few days or a newly imaged machine gets an IP address, I can see the client in the DHCP console but the machine doesn't show in DNS. It takes a few reboots or quite some time to show in the DNS console. is there something i can do to speed this up or is this normal behavior?

    Cheers

    Shane

    Friday, April 29, 2016 8:06 AM

All replies

  • Hi; you can set the machine to update it's own host record in DNS instead of letting the DHCP server do it for them, this is a common problem scenario.  You can configure this in Group Policy, or on an individual machine basis in the machine's network adapter TCP/IP DNS settings:


    Best Regards, Todd Heron | Active Directory Consultant


    • Edited by Todd Heron Saturday, April 30, 2016 8:07 PM Image missing
    • Proposed as answer by Hello_2018 Tuesday, May 3, 2016 3:03 AM
    Saturday, April 30, 2016 8:06 PM
  • Hi Shane,

    >>is there something i can do to speed this up or is this normal behavior?

    You could also enabled the option on DHCP server.

    Or, you could set the DNS related refresh interval:

    Best regards,


    Andy_Pan

    Tuesday, May 3, 2016 3:08 AM
  • Thanks for all your ideas so far.

    DHCP is already set to enable dynamic updates. Can i set clients via GPO to update its host record as well as DHCP?

    Tuesday, May 3, 2016 9:16 AM
  • Hi Shane,

    >>DHCP is already set to enable dynamic updates. Can i set clients via GPO to update its host record as well as DHCP?

    Please help to check the following registry settings:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<var class="sbody-var">interface</var>

    Refer to link below:

    https://support.microsoft.com/en-us/kb/816592

    Also, related GPO settings:

    Best regards,


    Andy_Pan


    • Edited by Hello_2018 Wednesday, May 4, 2016 10:03 AM
    Wednesday, May 4, 2016 10:02 AM