locked
New mail icon on Public Folder RRS feed

  • Question

  • This is strange but I have a few users who do not get the new mail icon on a Public Folder.  I'm not sure what the exact term is, but if a new message arrives inside the folder, the icon for the folder does not turn bold and display the number of unread messages in the typical blue text.  I hope I'm explaining this correctly.

    For one user it appears to work.  I tried recreating profiles, but that didn't fix the issue.  Any help would be greatly appreciated.

    Thanks.

    Glen

    Monday, August 6, 2012 5:41 PM

Answers

  • This appears to be working now.  The 'Maintain per-user read and unread info..' was checked.

    I removed and re-added the user as an owner to the folder and she says things are working now.  Not sure if that would do it or not, but it is working so I appreciate all the input and help.

    Thank you.

    • Marked as answer by wendy_liu Thursday, August 16, 2012 2:21 AM
    Monday, August 13, 2012 7:58 PM

All replies

  • Do the users have the correct default public folder set for their mail databases?
    Monday, August 6, 2012 6:40 PM
  • Not sure.  I'm not an Exchange admin by trade.  I'm just trying to help out.  Could you give me a hint as to how to check that or what they should be by default?

    Thank you.

    Monday, August 6, 2012 7:37 PM
  • The public folder database is listed under the properties of each mailbox database, under the organization configuration in the exchange console, in the client settings tab.  Compare the problematic users to the ones working properly and see if there is a different public folder database listed for the mailbox databases that they're on.  Depending on how your environment is set up, a certain public folder server could connect better to the mailbox server.

    Monday, August 6, 2012 11:59 PM
  • Hi Glen,

    You may add the public folder to Favorites as a workaround.


    Wendy Liu

    TechNet Community Support


    • Edited by wendy_liu Tuesday, August 7, 2012 7:37 AM
    Tuesday, August 7, 2012 7:36 AM
  • Thank you for the replies everyone.  The public folder is already added as a Favorite I believe.  I'd have to check that again but would that make the indicator show up? 

    Email delivery is working OK.  The messages show up but you don't know you have a new message in that folder unless you manually go look because, again - the name of the folder doesn't turn bold and the number doesn't show next to the folder name.

    I'm just confused as to why, if the message shows up OK and the user gets the message, it doesn't folder doesn't indicate a new message.  It would seem the permissions must be OK since the user is seeing the message or isn't that the case?  It just seems like whatever the mechanism is to 'tell' the folder "hey, an unread message is in here" isn't working.

    Thank you all again.

    Wednesday, August 8, 2012 1:20 AM
  • Glen,

    Do you know if you recently set up any additional public folder servers and/or started replicating the public folders to another database? Are you running exchange 2010? You may need to update public folder content. That can be done simply by right clicking on the folder if you don't have a lot, or use a command such as:

    Get-PublicFolder -identity '\Folder Name' -recurse -resultsize unlimited | Update-PublicFolder -server SourceServerName

    • Proposed as answer by BrianAuH2O Thursday, August 9, 2012 11:28 AM
    Wednesday, August 8, 2012 11:41 AM
  • Hi ,

    Please test in OWA and verify if there is the same issue.

    And please also check if the “Maintain per-user read and unread information for this folder” option is checked on Exchange Server.

    Open “Exchange Management Console”—ToolBox—Public Folder Management Console –right click the Public Folder and then click properties.


    Wendy Liu

    TechNet Community Support

    Monday, August 13, 2012 7:34 AM
  • This appears to be working now.  The 'Maintain per-user read and unread info..' was checked.

    I removed and re-added the user as an owner to the folder and she says things are working now.  Not sure if that would do it or not, but it is working so I appreciate all the input and help.

    Thank you.

    • Marked as answer by wendy_liu Thursday, August 16, 2012 2:21 AM
    Monday, August 13, 2012 7:58 PM
  • Great, very glad to hear this.

    Wendy Liu

    TechNet Community Support

    Thursday, August 16, 2012 2:24 AM