none
Creating GPO to copy shorcut to all users desktops

    Question

  • I thought I had it setup correctly but the workstation event log keeps showing the path is invalid and there is a yellow exclamation point in the GPO manager ( see below). What did I do wrong? does it need quotes? and can I use a the mapped drive letter or does it need full path?

    Thursday, December 01, 2016 9:39 PM

Answers

  • Hi,
    Please have a try to delete the double quotation marks from the target path and see if it works. Regarding the target path, it should be a local path, UNC path, or drive letter to which the shortcut will lead. Full path could be also a test for troubleshooting. However, in my opinion, I would not suggest to use a mapped driver as the path.
    And you could try to use Shell Object target type and see if the same error happen again.
    Best regards,
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Marked as answer by pstoric Friday, December 02, 2016 2:31 PM
    Friday, December 02, 2016 6:34 AM
    Moderator

All replies

  • Hi,
    Please have a try to delete the double quotation marks from the target path and see if it works. Regarding the target path, it should be a local path, UNC path, or drive letter to which the shortcut will lead. Full path could be also a test for troubleshooting. However, in my opinion, I would not suggest to use a mapped driver as the path.
    And you could try to use Shell Object target type and see if the same error happen again.
    Best regards,
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Marked as answer by pstoric Friday, December 02, 2016 2:31 PM
    Friday, December 02, 2016 6:34 AM
    Moderator
  • > I thought I had it setup correctly but the workstation event log keeps showing the path is invalid and there is a yellow exclamation point
     
    The yellow exclamation triangle simply means "Action: Update". And be aware that you cannot (!) create shortcuts to UNC paths. If you need this, you must use the "URL" target type.
     
    Friday, December 02, 2016 9:22 AM
  • Thanks, I'll try that shortly and get back to you.
    Friday, December 02, 2016 1:59 PM
  • When I select Shell object it doesn't let me type in a full path, it make me browse to the file but same result in the workstation but I was able to figure it out after a bit of troubleshooting.

    I had to change the "Location" to the "All users desktop" setting, use the type as "File System Object", and for target I used the full UNC path. Working now. How come "Desktop" alone as the location won't work? Is that because the workstation is on a domain?

    One last question, if that shortcut exists already, the GPO will not do anything correct? I don't want it to create a duplicate.

    Here's what worked:


    Friday, December 02, 2016 2:30 PM
  • Hi,
    You could check the setting “"apply once and do not reapply” in the common tab of GPP.
    Preference items are applied when Group Policy refreshes. By default, the results of preference items are rewritten each time Group Policy refreshes. This ensures that the results of the preference items are consistent with what the administrator designated in the Group Policy object.
    If the Apply once and do not reapply option is selected, it changes this behavior, so the preference extension applies the results of the preference item to the user or computer only once.
    Best regards,
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, December 05, 2016 1:51 AM
    Moderator