none
DPM 2010 to DPM 2012R2 configuration transfer failure RRS feed

  • Question

  • Hello,

    I’m doing a side by side upgrade from DPM 2010 to DPM 2012R2 and I’m trying to transfer my configuration with Ruud Baar's PS scripts DPMsaveConfig and DPMcreateConfig.

    On the new DPM 2012R2 box, when I run DPMcreateConfig it fails.  Here is the end of the log:

    “[14:07:30]      Allocating  DPM -Calculate = True for [C:\]...

    [14:07:42] Committing protectiongroup [Client Group 1]

    [14:07:54] Processing group [Client Group 1] finished

    [14:07:55] TRAP: DPMcreateConfig

    Exception calling "GetProtectionGroups" with "0" argument(s): "Object

    reference not set to an instance of an object."

    At C:\DPMcreateConfig.ps1:147 char:2

    +     $pg = $srv.GetProtectionGroups() | ?{$_.FriendlyName -eq $xgrp.GroupName}

    +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

        + CategoryInfo          : NotSpecified: (:) [], MethodInvocationException

        + FullyQualifiedErrorId : NullReferenceException

     

    Set-protectiongroup : Connection to the DPM service has been lost. (ID: 917)

     

    Review the application event log for information about a possible service

    shutdown. Verify that the following services are not disabled:

                DPM

                DPM Replication Agent

                SQLAgent$MSSQLSERVER2

                MSSQL$MSSQLSERVER2

                Virtual Disk Service

                Volume Shadow Copy

    At C:\DPMcreateConfig.ps1:358 char:2

    +     Set-protectiongroup $2ndmpg

    +     ~~~~~~~~~~~~~~~~~~~~~~~~~~~

        + CategoryInfo          : NotSpecified: (:) [Set-DPMProtectionGroup], DlsE

       xception

        + FullyQualifiedErrorId : UICantConnectToEngine,Microsoft.Internal.Enterpr

       iseStorage.Dls.UI.Cmdlet.ProtectionCmdLets.CommitProtectionGroup “

    Any help would be appreciated.

    Thanks,

    Ivan


    Ivan

    Friday, March 14, 2014 9:26 PM

Answers

All replies

  • Have you tried it with this updated version of the script?

    https://gallery.technet.microsoft.com/DPM-save-create-Config-4579ee92


    My Blog | www.buchatech.com | www.systemcenterportal.com
    If you found this post helpful, please give it a "Helpful" vote. If it answered your question, remember to mark it as an "Answer". This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    Saturday, January 3, 2015 5:26 AM
    Moderator
  • Hi Buchatech,

    Nope, I haven't tried the updated script.  I completed the migration manually 9 months ago.

    Thanks, 

    Ivan


    Ivan

    Monday, January 5, 2015 6:04 PM
  • Hi Buchatech,

    Nope, I haven't tried the updated script.  I completed the migration manually 9 months ago.

    Thanks, 

    Ivan


    Ivan


    Ok. I knew this was an old thread. I thought I would respond anyway to make sure you figured it out. I do know that the updated script does not error out on SCDPM 2012 R2. 

    My Blog | www.buchatech.com | www.systemcenterportal.com
    If you found this post helpful, please give it a "Helpful" vote. If it answered your question, remember to mark it as an "Answer". This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!


    Monday, January 5, 2015 7:54 PM
    Moderator