locked
Possible solution for several SteadyState issues RRS feed

  • General discussion

  • If Windows SteadyState 2.5 is raising a service timeout error (7011) in Event Viewer, not displaying the continue-or-save-changes dialog box to administrators at logoff, or hanging for all users at logoff and finally displaying an "Ending Program" prompt that can be resolved by terminating Bubble.exe, this may be a solution.  I have discovered that not only is SteadyState 2.5 dependent on the Remote Procedure Call (rpcss) and Windows Management Instrumentation (winmgmt) services, but it also seems to require Terminal Services (termservice).

     

    Terminal Services was not required for the use of SteadyState 2.0 and my test system had Terminal Services disabled, so when I installed SteadyState 2.5, I noticed the various issues I previously listed.  I read that one of the SteadyState service's tasks was to enable/disable user accounts for various purposes and thought perhaps it was using Terminal Services to track logged-in users and events.  With that in mind, as an administrator user, I enabled (Disabled -> Automatic) and started the termservice service from services.msc and, without even a logoff, SteadyState came to life and displayed the disk protection bubble from the system notification area that you would usually expect to see at logon.

     

    I then attempted to restart and was properly prompted for the first time to continue without saving or save changes.  To maintain the termservice setting change, I elected to save changes and restart.  Since then, behavior has been as expected, error 7011 no longer appears in Event Viewer, and all seems well with SteadyState.

     

    In particular, this solution may apply to the following posts:

    http://forums.microsoft.com/WindowsToolsandUtilities/ShowPost.aspx?PostID=4161841&SiteID=69

    http://forums.microsoft.com/WindowsToolsandUtilities/ShowPost.aspx?PostID=4252452&SiteID=69

     

    As a suggestion to the development team, it may be helpful to adapt the SteadyState installer to check the state of the termservice service and ensure it is enabled, along with rpcss and winmgmt, as a prerequisite for installation.  Perhaps offer to enable and start the services as automatic as part of the installation and gracefully fail if the user chooses for some reason to maintain their current service setup. 

     

    I understand that it is unlikely that many people have disabled their termservice service, as I'm almost positive it ships by default as automatic/started, so the resources needed to change the installer for this would probably be better spent elsewhere, but maybe a little note in the readme might help someone with a similar issue in the future.

     

    Thank you for your time!
    Monday, January 12, 2009 5:05 AM

All replies

  •  

    Hi, thank you for the potential solution regarding the error in event log. I believe this is useful for all Windows SteadyState users. Also, thank you for the feedback to the development team, if you have any other suggestion in the future, please feel free to let us know.

    Tuesday, January 13, 2009 6:55 AM
  • EUREKA!! YOU FOUND IT!! I routinely disable services that are not needed by my basic WinXP Pro systems, which is exactly what I did when setting up and configuring the proto-type machine for a roll out of basic systems in an environment where SteadyState was essential. I did all the configuration first, then loaded SS. As soon as we tried to log off, shutdown or restart (in any user profile), we had a 60-120 second delay that ended with the "Program Not Responding SteadyState" and then "end now." I have spent more than SIX HOURS trying different workarounds (disabling bubble.exe, setting Disk protection to don't notify administrator, etc.), but NOTHING WORKED. I enabled terminal services (automatic) and VOILA - Shutdown without incident in less than 25 seconds!!! YOU ARE A SAVIOR!! YAHOO, YOSHI, SIANARA!! THANK YOU!! BOOST THIS TO A STICKY ON STEADYSTATE SHUTDOWN ISSUES! THANKS AGAIN FOR SHARING. :)
    Monday, May 18, 2009 9:07 PM