none
DPM 2012 R2 CU 4 - issue w/ system state backup completing on non domain servers with T2embed.dll RRS feed

  • Question

  • I am really new to DPM and just took over a system that has servers being backed up that are not part of the domain. The volumes backup fine and system state will not complete. In looking at the protection group server the WindowsImageBackup folder is created and the backup starts however it will fail and DPM server will say Replica is inconsistent.  Back on the protected server in the backup event log, it fails w/ error code 2155347997.  In the backup error log file in C:\windows\logs\windowsserverbackup.  It says "Error in backup of C:\windows\system32\t2embed.dll during read.  Error [0x80070005] Access is denied.

    We have about 4 other servers that are not domain joined and they are getting similar errors w/ t2embed.dll in that system32 directory or in the WinSXS folder.   All servers are 2008 SP2 or 2008 R2 SP1.

    Thank you in advance for you help

    Thursday, February 12, 2015 11:01 PM

All replies

  • Hi,

    DPM has no control over errors that Windows server backup receives, but check permissions and Remove the DENY permission for EVERYONE on the below files:

    C:\Windows\system32\t2embed.dll
    C:\Windows\winsxs\amd64_microsoft-windows-font-embedding_31bf3856ad364e35_6.1.7601.17514_none_13e628b635935244\t2embed.dll
    C:\Windows\winsxs\x86_microsoft-windows-font-embedding_31bf3856ad364e35_6.1.7601.17514_none_b7c78d327d35e10e\t2embed.dll


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, February 20, 2015 10:17 PM
    Moderator
  • Not sure if I can tag onto this thread.  I am having the exact same issue but with 2008 R2 domain controllers.  Am I looking at the same solution??

    Thursday, August 13, 2015 7:28 PM
  • Hi,

    Yes, if you find the DENY everyone permission on those files, then remove that DENY and that should fix the issue.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, August 17, 2015 10:12 PM
    Moderator
  • I have remove the Everyone DENY permissions from all instances of the t2embed.dll file.  This cleared the issue in the WinSxS directory and System32 but continue to see the problem with the file in SysWOW64.  Have pretty much opened up all the privileges on the file with no success.  I am tempted to exclude the file from the backup but only want to do that as a last resort.  Any other suggestions?

    Thursday, August 20, 2015 1:44 AM