none
DPM Agent giving Error 0x8099090E RRS feed

  • Question

  • Hi,

    I am using Windows Server 2008 R2 for DPM 2010 Server and PS(Protected Server). On the DPM Console, one of the server's status is not OK. with error as below. The PS is not a workgroup PS. The status of the PS seems to change from OK to Error for several times a day. Please help:

    ---------------------------------------------------------------------------

    Protection agent version: 3.0.7696.0


    Error: Data Protection Manager Error ID: 316

    The protection agent operation on PS(Protected Server) failed because the service did not respond.


    Detailed error code: Internal error code: 0x8099090E


    Recommended action: If you recently installed a protection agent on PS(Protected Server), the computer may be restarting. Wait a few minutes after 

    restarting the computer for the protection agent to become available. Otherwise, troubleshoot the problem as follows:


    1) Check the recent records from the DPMRA source in the Application Event Log on PS(Protected Server) to find out why the agent failed to respond.

    2) Verify that the DPM server is remotely accessible from PS(Protected Server)

    3) If a firewall is enabled on the DPM server, verify that it is not blocking requests from EPS(Protected Server).

    4) If EDMS-STRG.IDFR.DIR is a workgroup computer configured to use NETBIOS, ensure that the NETBIOS name of the DPM server is accessible from EDMS-STRG.IDFR.DIR. Otherwise verify that the DNS name is remotely acessible. 

    5) If PS(Protected Server) is a workgroup server, ensure that the DPM server has an IPSEC exception to allow communication from workgroup servers.

    6) If PS(Protected Server) is a workgroup server the password for the DPM user accounts could have been changed or may have expired. To resolve this error, run SetDpmServer with the -UpdatePassword flag on the protected computer and Update-NonDomainServerInfo.ps1 on the DPM server.

    7) Restart the DPM Protection Agent service on PS(Protected Server). If the service fails to start, reinstall the DPM protection agent.

    =============================================================

    • Moved by MarcReynolds Friday, January 14, 2011 1:12 PM (From:Data Protection Manager)
    Friday, January 14, 2011 3:40 AM

All replies

  • This happens due to some falkyness in the DCOM channel, can you please follow the kb http://support.microsoft.com/kb/259011 and troubleshoot DCOM when the status is in error state.
    -- Thanks Chandraneel Chakka[MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    • Proposed as answer by Bortik [MSFT] Thursday, February 10, 2011 7:16 AM
    Monday, January 17, 2011 8:14 AM
  •  
    This issue can come if your DCOM channel is not working properly or your Firewall Exceptions are not added correctly at the PS side.

     

    1) Can you ping the DPM Server from the PS ?

    2) Did you do the Agent installation Manually? If yes, then configure Firewall in your PS.

    For firewall configuration requirements, see Installing Protection Agents behind a Firewall (http://go.microsoft.com/fwlink/?LinkId=101313).


    Thanks, Bortik - [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights
    Thursday, February 10, 2011 7:37 AM
  • Hi, not sure if this helps but I found this due to local user account had password set to expire for the DPM Agent. Also need to change this for the corrosponding local account on the DPM Server itself.

    Thanks

    • Proposed as answer by ctilden Monday, April 15, 2013 8:13 PM
    Monday, September 24, 2012 10:43 PM