none
USB deployment - USB controller drivers got uninstalled and deployment ended with 'Reinsert media (..)' error RRS feed

  • Question

  • Our offline USB deployment works fine on 3 of 4 HWs, but the 4th (Latitude E6420) one gave errors.

    The error is 'Media not found' with message "Reinsert media (...)..", we tried to click 'Ok' to go through but there are too many, so we had to power off to stop the deployment. When the system power back and we found the entries in USB group in Device Manager are all yellowed (removed/uninstalled). So the media USB is not accessible.

    We are using USB offline deployment and we don't have capture image (i.e. directly install factory .wim with deployment TS). We suspect that either 'Inject Drivers' task or 'Install OS' task caused the USB uninstall, but we need more test and log info to confirm. If anyone knows for sure, or knows a quick/better way to verify, please let us know.

    Question are: why did that happen? Is it normal for deployment tasks to uninstall the USB controller drivers? How can we avoid that? Why it didn't happen in other 3 HWs (7402/7414/XPS 15 9530)?

    If this can't be prevented, how to fix it? We can manually 'reinstall' them and restart to resume the deployment, but that's not acceptable by customers. Can we add a task to install (i.e. add the drivers in MDT and install) or reinstall (scripts/commands to automate what we did manually) in the deployment TS? And where should the task(s) be?

    Here are the steps to 'reinstall' -

    • Device manager
    • USB tree
    • Double click the yellowed entries
    • Choose "Browse my computer for driver software"
    • Choose "Let me pick from a list ..."
    • Choose the driver entry
    • Next
    • Close

    The two entries on the system are -

    • Intel(R) 6 Series/C200 Series Chipset Family USB Enhanced Host controller -1C2D (Microsoft)
    • Standard Universal PCI to USB Host Controller Drivers

    Thursday, February 8, 2018 3:40 AM

All replies

  • Anyone knows how to check USB controller status during deployment (with F8)?

    Thursday, February 8, 2018 3:54 AM
  • Some updates, we now confine that the USB controller was 'uninstalled' (or stopped) at the beginning of 'Install OS' task.

    We are seeking ways to reinstall it immediately after the OS installation, the first couple trials/tasks didn't work because they were not quick enough - there were 'LiteTouch.wsf not found' (because USB port not working thus x: not available now) thrown before the tasks were executed.

    Is there a way to tell OS install task to not touch the USB Controller? The starting USB controllers worked fine when the deployment started, we would like to keep it unchanged if possible.

    Please note that we are only running everything in Deployment TS, and we do want to lay new drivers for each HW according the models via 'Inject drivers' (task before 'Install OS').

    Thanks in advance for any inputs!

    Friday, February 9, 2018 12:09 AM
  • Not entirely sure, but in the unattend you can specify Persist Drivers. I saw that my video drivers were getting stripped out and I checked Persist Drivers and I never lost any after that. Not sure if this is what you are experiencing.
    Friday, February 9, 2018 4:25 PM
  • Thanks for the reply!

    The complication in our case are -

    1. We still want to apply the other drivers, the only ones we want to avoid are USB controller drivers
    2. We only want this happen on this specific HW (model), but all others should have driver inject as normal.

    So I wonder if it can be done via unattend. But I will give it a try later ...

     

    Monday, February 12, 2018 5:29 PM
  • I'm guessing you apply drivers based on model, as with a DriverGroup or Driver Path. On the one for this model, can't you just remove the USB driver from the CAB and apply all the others?

    If I wanted to retain one driver but replace the rest, I would persist drivers, remove the USB controller driver from my CAB and let all the others install, based on the WMI of this model.

    Monday, February 12, 2018 8:04 PM