2012R2 Media Server - add content on a file share


  • Hi there,

    I'm trying first steps with a 2012R2 based Windows Media Server.

    I have installed the Essentials Media Pack and was able to generally successfull activate the DLNA function.

    Now my problem is that the huge Music collection is located on a different Server but the new 2012R2-box.

    Not a Problem... I thought... I tried to add the shared Folder form the other Server but am unable to add anything not from the 2012R2 box locally.

    Is this by design, or do I do something wrong?

    How am I able to add a share from a second (or more) Servers to the Media-Server?



    Regards Stefan

    Thursday, July 10, 2014 10:08 PM

All replies

  • I have been having the same problem and have tried linking those folders to the share but the media streaming service just parses the directories wrong and never seems to see the correct media in them. I wish there was documentation on what actually goes on while the various services are parsing media files. You would think it would be a straight forward read the directorys/get the file types and parse them as whatever (stream as needed) . in my situation I have pictures with nothing but JPG's , movies with only mp4 and music with mp3 but the streaming service just sees the folders and does not see any of the files ( possible depth problem?) for instance C:\ServerFolders\Music.lnk <--> \\sharePC\Music\Band\Tracks.mp3 does not show any files in the media server but videos and Pictures at least show the folders but not the files so something screwy is going on with DFS, how the service builds its media list or possibly permissions. A little documentation would go a long long way to make this work. The simple solution for me would be to add essentials on my nas but .....for some reason R2 will not install even though 2012 has been on there forever ( doesn't meet hardware requirements). Or it just occurred to me perhaps it is trying to use WMP on some hidden account's media database and we know how messed up wmp can make of a simple file structure.

    So if anyone can explain how to get past this Severe limitation, Not being able to stream form a NAS or share, Please let us know I have read post after post of people having the same problem getting streaming to work even locally let alone using foreign media.

    Tuesday, September 09, 2014 1:48 AM