locked
Aero mouse pointer scheme causing issues with RDP 6.0 and 6.1 from Windows 2003 servers RRS feed

  • Question

  • When using RDP client 6.0 or 6.1 on a Windows 2003 Standard Edition server (OS Version: 5.2.3790 Service Pack 2 Build 3790) to remote desktop to a Microsoft Windows 7 Enterprise workstation (OS Version: 6.1.7600 Build 7600) we experience noticeable lag when moving the mouse cursor around the remote desktop session. The only way to stop the mouse cursor lag is to change the mouse pointer scheme on the Windows 7 workstations to anything other than an Aero scheme, or use no scheme at all. An alternative workaround is to change the Theme to Windows Classic, which disables all Aero features (including the mouse pointer scheme). I’ve tried all the different variations of options available in RDP 6.0 and 6.1 but can’t get it to work well with a Windows 7 workstation with Aero based mouse pointer scheme enabled.

    The odd thing is that a Windows 2003 Standard Edition server with RDP client 5.2 installed has no lag issues with the Aero Mouse pointer scheme being enabled.

    Versions of RDP used:
    mstsc: 5.2.3790.3959
    mstsc: 6.0.6000.16459
    mstsc: 6.0.6001.18000

    Ideally, we’d like to keep all Aero features enabled and remote desktop from Windows 2003 server using at least RDP client 6.0.

    Thursday, April 14, 2011 2:25 AM

Answers

  • Hi,

     

    From Windows 7 side, I suggest updating your network adapter driver from the manufacture's site and running the following commands with the Administrator privileges.

     

    netsh interface tcp set global rss=disabled

    netsh interface tcp set global autotuninglevel=disabled

    netsh int ip set global taskoffload=disabled

     

    If the issue persists, I suggest contacting Windows Server Forum to get more specialized support.

     

    Win Server Forum

    http://social.technet.microsoft.com/Forums/en-US/category/windowsserver

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Vivian Xing Monday, April 25, 2011 8:16 AM
    Tuesday, April 19, 2011 9:50 AM

All replies

  • Hi,

     

    From Windows 7 side, I suggest updating your network adapter driver from the manufacture's site and running the following commands with the Administrator privileges.

     

    netsh interface tcp set global rss=disabled

    netsh interface tcp set global autotuninglevel=disabled

    netsh int ip set global taskoffload=disabled

     

    If the issue persists, I suggest contacting Windows Server Forum to get more specialized support.

     

    Win Server Forum

    http://social.technet.microsoft.com/Forums/en-US/category/windowsserver

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Vivian Xing Monday, April 25, 2011 8:16 AM
    Tuesday, April 19, 2011 9:50 AM
  • HI Niki

     

    Thank you very much for your help with this one, unfortunately we still appear to be having the issue. I will contact the other forum as suggested.

     

    Thanks again.

     

    G

    Wednesday, May 4, 2011 2:27 AM