none
Offline Servicing - Failed to Mount Image

    Question

  • I'm able to deploy an OS perfectly with OSD task sequences with the image I'm using.  However when I attempt to inject the updates using the "Schedule Updates" method, I get the following error.  Failed to mount the image on the system.

    I opened SCCM console from the primary site itself just in case, I also retried with elevating permissions on the console.

    OfflineServicingMgr.log

    Total number of individual updates to be installed is 150. SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:35:56 PM 7076 (0x1BA4)
    STATMSG: ID=7903 SEV=I LEV=M SOURCE="SMS Server" COMP="SMS_OFFLINE_SERVICING_MANAGER" SYS=SCCMPSQA.playpen.local SITE=DEV PID=1892 TID=7076 GMTDATE=Mon Jul 30 17:35:56.171 2012 ISTR0="DEV0000E" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0 SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:35:56 PM 7076 (0x1BA4)
    Copy image DEV0000E (size 2679 MB):' SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:35:56 PM 7076 (0x1BA4)
    copying file '\\sccmdpqa1.playpen.local\OperatingSystems\Win2k8R2_with_SP1\sources\install.wim' to 'D:\ConfigMgr_OfflineImageServicing\DEV0000E\install.wim' ... SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:35:56 PM 7076 (0x1BA4)
    Copying(25% complete)... SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:36:33 PM 7076 (0x1BA4)
    Copying(50% complete)... SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:37:08 PM 7076 (0x1BA4)
    Copying(75% complete)... SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:37:41 PM 7076 (0x1BA4)
    Copying(100% complete)... SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:13 PM 7076 (0x1BA4)
    STATMSG: ID=7905 SEV=I LEV=M SOURCE="SMS Server" COMP="SMS_OFFLINE_SERVICING_MANAGER" SYS=SCCMPSQA.playpen.local SITE=DEV PID=1892 TID=7076 GMTDATE=Mon Jul 30 17:38:13.915 2012 ISTR0="DEV0000E" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0 SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:13 PM 7076 (0x1BA4)
    [Schedule ID 16777219] Started processing image package with ID DEV0000E SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:14 PM 7076 (0x1BA4)
    STATMSG: ID=7906 SEV=I LEV=M SOURCE="SMS Server" COMP="SMS_OFFLINE_SERVICING_MANAGER" SYS=SCCMPSQA.playpen.local SITE=DEV PID=1892 TID=7076 GMTDATE=Mon Jul 30 17:38:14.087 2012 ISTR0="DEV0000E" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0 SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:14 PM 7076 (0x1BA4)
    Image package file with ID DEV0000E contains 8 image(s) SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:14 PM 7076 (0x1BA4)
    Processing image at index 1 SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:14 PM 7076 (0x1BA4)
    Mounting image at index 1. Image file='D:\ConfigMgr_OfflineImageServicing\DEV0000E\install.wim', MountDirectory='D:\ConfigMgr_OfflineImageServicing\DEV0000E\ImageMountDir', ImageFileType='WIM', Mode='ReadWrite' SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:14 PM 7076 (0x1BA4)
    Unable to mount image file SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:14 PM 7076 (0x1BA4)
    WIM::MountWIMImage returned code 0x80070005 SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:14 PM 7076 (0x1BA4)
    Failed to mount image SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:14 PM 7076 (0x1BA4)
    MountImage returned code 0x80070005 SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:14 PM 7076 (0x1BA4)
    Image Mount failed with error 5 SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:14 PM 7076 (0x1BA4)
    STATMSG: ID=7912 SEV=E LEV=M SOURCE="SMS Server" COMP="SMS_OFFLINE_SERVICING_MANAGER" SYS=SCCMPSQA.playpen.local SITE=DEV PID=1892 TID=7076 GMTDATE=Mon Jul 30 17:38:14.256 2012 ISTR0="DEV0000E" ISTR1="1" ISTR2="D:\ConfigMgr_OfflineImageServicing\DEV0000E\ImageMountDir" ISTR3="5" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0 SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:14 PM 7076 (0x1BA4)
    Completed processing image package DEV0000E. Status = Failed SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:14 PM 7076 (0x1BA4)
    Updated history for image package DEV0000E in the database SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:14 PM 7076 (0x1BA4)
    Schedule processing failed SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:14 PM 7076 (0x1BA4)
    Processing completed for Schedule with ID 16777219 (Schedule Name = ) SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:14 PM 7076 (0x1BA4)
    STATMSG: ID=7910 SEV=E LEV=M SOURCE="SMS Server" COMP="SMS_OFFLINE_SERVICING_MANAGER" SYS=SCCMPSQA.playpen.local SITE=DEV PID=1892 TID=7076 GMTDATE=Mon Jul 30 17:38:14.348 2012 ISTR0="16777219" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0 SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:14 PM 7076 (0x1BA4)
    Schedule processing thread stopped SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:14 PM 7076 (0x1BA4)
    Checking if there are schedule(s) which need to be run at this time. SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:14 PM 2260 (0x08D4)
    This Schedule with ID 16777217 does not have a next run time SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:15 PM 2260 (0x08D4)
    This Schedule with ID 16777218 does not have a next run time SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:15 PM 2260 (0x08D4)
    This Schedule with ID 16777219 does not have a next run time SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:15 PM 2260 (0x08D4)
    No more schedules are found to be run at this time or in the future. Will sleep till a new schedule is created. SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:15 PM 2260 (0x08D4)
    No schedule exists which needs to be run anytime in future. SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:15 PM 2260 (0x08D4)
    Offline Servicing Manager thread is exiting. SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:15 PM 2260 (0x08D4)

    Monday, July 30, 2012 5:41 PM

All replies

  • I also turned off the AV (System Center 2012 Endpoint Protection) on the off chance it was that as I saw that mentioned in a forum post somewhere else on TechNet.
    Monday, July 30, 2012 6:49 PM
  • Image package file with ID DEV0000E contains 8 image(s)SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:14 PM7076 (0x1BA4)
    Unable to mount image file SMS_OFFLINE_SERVICING_MANAGER7/30/2012 12:38:14 PM 7076 (0x1BA4)
    WIM::MountWIMImage returned code 0x80070005 SMS_OFFLINE_SERVICING_MANAGER 7/30/2012 12:38:14 PM7076 (0x1BA4)
    Failed to mount image SMS_OFFLINE_SERVICING_MANAGER7/30/2012 12:38:14 PM 7076 (0x1BA4)
    MountImage returned code 0x80070005 SMS_OFFLINE_SERVICING_MANAGER7/30/2012 12:38:14 PM 7076 (0x1BA4)
    Image Mount failed with error 5 SMS_OFFLINE_SERVICING_MANAGER7/30/2012 12:38:14 PM 7076 (0x1BA4)

    Hi,

    returned code 0x80070005 = access denied.
    If I can see it correctly you have imported the install.wim from the installation media, I haven't tried that actually.
    What permission do the Primary Site server account have to the source media?

    It must have at least Modify permissions, is that granted already?

    Regards,

    Jörgen


    -- My System Center blog ccmexec.com -- Twitter @ccmexec

    Monday, July 30, 2012 7:55 PM
  • The imported WIM works great actually, it's just the injection of the updates that is giving me the pain.  I verified SCCMPSQA (Primary Site Account) in in the administrator groups on all of the site systems.  

    Confirmed that the install.wim on the source has full control given to Administrators.

    It is appearing that the copy from the source to the D drive is fine, but permissions are weird once it's copied over.  I did notice that when I try to check the ConfigMgr_OfflineImageServicing folder on the D drive of SCCMPSQA that I have to allow myself rights to view it.  Perhaps when that temporary folder is created, it is created with the wrong permissions?


    Monday, July 30, 2012 8:14 PM
  • Not sure if it's of any help to this issue, but I'm not unable to download software updates where I was able to before just this morning.  I haven't modified permissions on anything since then... Quite confusing.

    Trying to connect to the root\SMS namespace on the SCCMPSQA.playpen.local machine.	Software Updates Patch Downloader	7/30/2012 3:31:39 PM	4896 (0x1320)
    Connected to \\SCCMPSQA.playpen.local\root\SMS	Software Updates Patch Downloader	7/30/2012 3:31:39 PM	4896 (0x1320)
    Trying to connect to the \\SCCMPSQA.playpen.local\root\sms\site_DEV namespace on the SCCMPSQA.playpen.local machine.	Software Updates Patch Downloader	7/30/2012 3:31:39 PM	4896 (0x1320)
    Connected to \\SCCMPSQA.playpen.local\root\sms\site_DEV	Software Updates Patch Downloader	7/30/2012 3:31:39 PM	4896 (0x1320)
    Download destination = \\sccmpsqa\UpdateServicesPackages\Windows7\94797c79-3b60-48a7-888a-9bdf7e983f99.1\Windows6.1-KB958690-x86-Beta.cab .	Software Updates Patch Downloader	7/30/2012 3:31:39 PM	4896 (0x1320)
    Contentsource = http://download.windowsupdate.com/msdownload/update/software/secu/2009/03/windows6.1-kb958690-x86-beta_38a5b79da8f5ed57905aa99ad74e3d8cf92d0ea6.cab .	Software Updates Patch Downloader	7/30/2012 3:31:39 PM	4896 (0x1320)
    Downloading content for ContentID = 16777484,  FileName = Windows6.1-KB958690-x86-Beta.cab.	Software Updates Patch Downloader	7/30/2012 3:31:39 PM	4896 (0x1320)
    Failed to create directory \\sccmpsqa\UpdateServicesPackages\Windows7\94797c79-3b60-48a7-888a-9bdf7e983f99.1\, error 5	Software Updates Patch Downloader	7/30/2012 3:31:39 PM	4524 (0x11AC)
    ERROR: DownloadContentFiles() failed with hr=0x80070005	Software Updates Patch Downloader	7/30/2012 3:31:40 PM	4896 (0x1320)
    

    Monday, July 30, 2012 8:55 PM
  • I just had to create a new deployment pack location and the software update went through, doesn't appear to be related.  Still unable to inject updates.
    Monday, July 30, 2012 9:05 PM
  • Hi,

    The process didn't work for me, error 112 at mounting image after copy.  I noticed that copy was on c drive and not enough disk space.  So, I ncreased disk and it is working fine. 

    But , how change path?

    Thanks in advance.

    Best regards,

    Saturday, September 29, 2012 11:38 AM
  • Give another try de-selecting KB976932 which is Windows 7 Service Pack 1 update while scheduling image offline servicing. It worked for me after CM2012 SP1 application with ADK.


    Barry Mohamed

    Friday, April 5, 2013 2:18 PM
  • Hi,

    The process didn't work for me, error 112 at mounting image after copy.  I noticed that copy was on c drive and not enough disk space.  So, I ncreased disk and it is working fine. 

    But , how change path?

    Thanks in advance.

    Best regards,

    The SCCM console doesn't have that feature, but you can move the temp folder to a different drive with http://technet.microsoft.com/en-us/sysinternals/bb896768.aspx
    Friday, April 5, 2013 2:26 PM
  • I just encountered the exact same issue (Image mount failed with Error 5). In my case, it turns out that the .WIM file I had copied from the extracted .ISO had the "Read Only" attribute set. After removing the read-only attribute, the process completed successfully.

    To Manu BE: To change the drive where the image is copied to during offline servicing, see this blog post: Customizing Offline Servicing of Operating System Images



    Tuesday, April 1, 2014 12:10 AM
  • Thank you for this I spent a few hours on permissions before I noticed this.
    Wednesday, April 30, 2014 5:28 PM
  • Thank you Ryan,
    This is what solved the problem for me.

    Saturday, July 5, 2014 11:47 AM
  • Nice!  Super helpful. Thanks Ryan!   :)
    • Edited by Jeradw Monday, May 11, 2015 2:18 PM
    Monday, May 11, 2015 2:18 PM
  • What is the "primary site server account"? I am having this same issue and looking to give the account that access, but im not sure which account that is.
    Tuesday, April 2, 2019 2:04 PM