locked
Authentication Popup while Accessing office documents RRS feed

  • Question

  • We are facing one issue with the internet facing MOSS site. It has anonymous authentication for root site collection and rest site collections are with their own security model. We have some document libraries in site collection having security integrated with AD. When any logged in user clicks on any of the office document from library, user gets authentication popup. He has to provide credentials again to open that library even though he is logged in to portal.

     

    Is there any way to avoid this pop up?

     

    We have tried with below options

     

    --putting site in to Trusted sites zone

    --Specifying Authentication provider in central administration site in application settings

    --Setting IIS request filtering in web.config

    --Installing hot fix which is for Designer only


    Ram
    Friday, April 1, 2011 5:39 PM

Answers

  • Try doing this, 

    1. disable client integration for that particular zone. 
    2. remove the word Options in the web.config

     

    Thanks

    V


    V
    • Marked as answer by David HM Friday, April 15, 2011 3:13 AM
    Wednesday, April 13, 2011 9:38 PM

All replies

  • Hi Ram,

    Please try to add the site to Trusted Sites and Local Intranet in IE > Internet Options > Security tab.

    Best regards,
    Emir

    Monday, April 4, 2011 8:31 AM
  • hi Emir,

    Let me add another twist here, the Intranet site is on a different domain, where i login from my desktop to another domain (i am on a different domain).

    On IE6, when i try to access the Intranet Site which is on a different server farm (on a different domain), it asks me the authentication popup once, i provide the credentials.

    But still it persists, asking me continously the credentials (i.e. authentication popup). Is this the behaviour on IE6, i have already added the Intranet site to the trusted sites.

    One more things, if i try to add the site to the Local Intranet , it says, the site is already appearing in Trusted sites, do you want me to move to the site to Local Intranet. Upon 'Yes', it removes the site from Trusted sites and adds it to Local Intranet.

    Irrespective of where the site is Trusted Sites or Local Intranet, the Authentication popup does not go away on IE6.

    I do not have this issue on IE8.

    Please let me know if there is any sure shot resolution to the issue, i have googled enough on the net.

    Help in this regards will be highly appreciated.

    Ram

     

     

     

     


    Ram
    Tuesday, April 5, 2011 7:17 AM
  • Try doing this, 

    1. disable client integration for that particular zone. 
    2. remove the word Options in the web.config

     

    Thanks

    V


    V
    • Marked as answer by David HM Friday, April 15, 2011 3:13 AM
    Wednesday, April 13, 2011 9:38 PM