none
Connection status unknown, DPS and missing permissions for Trustedinstaller RRS feed

  • Question

  • Connection status unknown, DPS and missing permissions for Trustedinstaller

    Hi, I am having the problem that my computer can't connect to the internet.

    A bit strange, because when I open the dialog to connect to the network I am told that the computer already is connected at full speed.

    But the network icon in the tray warns 'Connection status unknown. The dependency service or group failed to start.'

    And when I open the wizard for connecting to internet there is a message "wizard cannot continue" plus the following tecknical details (this is a French version):

    "GUID du composant : {7071ECA3-663B-4BC1-A1FA-B97F3B917C55}
    Fichier du composant : [C:\Windows\system32\connect.dll]
    Erreur : (0x800706BA) <message d'erreur introuvable>.

    Infos supplémentaires :
    Failed to detect Internet connectivity"

    This frustrating experience originated months ago. I was busy at the time trying out several different antivirus programs, one after the other. I uninstalled the present antivirus after having tried it for a month, then went on to install the next one, just to see if that was the ultimate antivirus that I really would like to buy and use. Then, when I installed the next antivirus, I was told that it wasn't necessary for me to uninstall the old antivirus first. The installation program of the new antivirus would take care of that.  Then I proceeded to install Kaspersky antivirus, and after that I tried Bitdefender, under the presumption that the installation program would take care of the uninstallation of the old antivirus.

    I don't know if this actually produced some kind of conflict, or if  it's only my imagination, but it was somewhere at this point that the problem started. Perhaps something happened in the registry?

    1. Unfortunately I didn't have any restore points of any use, probably because I hadn't reserved enough space on my system.

    2. I tried the command
    ping www.google.com
    at cmd.exe as administrator, but no, there was no contact with internet.

    3. I tried the command ipconfig and got two IP addresses correctly as an answer, other media were disconnected.

    4. I also tried the commands
    netsh winsock reset catalog
    netsh int ipv4 reset reset.log
    netsh int ipv6 reset reset.log
    and was told after that to restart the computer, but it didn't help.

    5. Of course the first thing I did to try and get out on the internet was to try Diagnose and Repair, but it still to this day the whole time says 'Network Diagnostics cannot run because the Diagnostics Policy Service is not running'  I then get the option to open the Service Control Manager to manually start the Diagnostics Policy Service. But when I try to do that it remains stuck and the DPS won't start.

    6. In my investigations on the internet I came across some interesting information in Microsoft Answers referring to
    http://support.microsoft.com/kb/943996
    It turns out, in this article, that ...
    "For the "Diagnostic Policy Service" service, the issue may occur when the account Trustedinstaller is missing the permissions for the key below:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DPS\Parameters

    The permission needed is: Full Control, Read."

    When comparing with my Win7 machine it turned out that indeed those two permissions are checked in this registry key.  

    Opening the registry editor in the Vista system confirmed that Trustedinstaller (in French CREATEUR PROPRIETAIRE) was missing the two permissions. I checked the two boxes, but here I ran into a problem: when I clicked 'Apply' the checks disappeared. Can anybody please tell me what is the problem here? And is this the solution to the whole connectivity issue?

    So, when the Diagnostic Policy Service is up and running, will it also open access once again to the internet?

    My  computer is a Packard Bell EasyNote BU with MS Windows Vista Home Premium 32-bit SP2.

    The forum queries about this issue are a couple of years old. Does this mean that the problem has been solved without my noticing it?

    Without access from the computer to internet it is difficult to diagnose and repair the computer, to solve the problem.
    Thursday, May 3, 2012 8:16 PM