none
Add second Virtual Server in SMTP Connector

    Question

  • hi everone,

    we need to create another SMTP virtual server to relay mails to internet, we create this and add that SMTP virtual server in Smart host but it gives me unable to relay error error code 5.7.1 is there any other configuaration is required for SMTP Virtual server


    regards

    jeevan singh
    Thursday, November 05, 2009 10:59 AM

All replies

  • Make sure that you use a different port number on 2nd virtual server as first one is already using port 25.
    Raj
    Thursday, November 05, 2009 11:04 AM
  • i am able to create the second VS with different IP and nat public ip on that, but when i add this on connector , then when we send mail to through this connector it gives me relay error.

    Thursday, November 05, 2009 11:12 AM
  • How to create SMTP virtual server http://www.computerperformance.co.uk/exchange2003/exchange2003_virtual_servers.htm

    Also see this for the relay  http://social.technet.microsoft.com/Forums/en-US/exchangesvradmin/thread/1789a917-6e4a-4a1a-9291-38ad5abdcf41

    I am sure on the 2nd SMTP virtual server , you have given a different port number (other then 25 which is there on the 1st virtual server.)
    Raj
    Thursday, November 05, 2009 11:20 AM
  • if we give another port say 28 or 30 ,then other domain will received our mails or not , they will not blocked us because of port number changed
    Thursday, November 05, 2009 11:58 AM
  • They will, its just that you need to configure your FW and smart host (if any) to recieve the emails from this IP address on port 28 or 30.
    Raj
    Thursday, November 05, 2009 11:59 AM
  • Hi,

    You can also configure one more IP address on the network adapter (same or use another network adapter) and use that IP address to create new SMTP VS in case you don't want to change the default port.

    Thanks.


    Vishal Ramnani | MCITP - Exchange 2007 | MCSE Messaging | MCTS - Win 2008 Config
    Thursday, November 05, 2009 12:05 PM
  • hi,

    i already did  the same thing as vishal said , but when i add this SMTP VS for internet mail delievery it gives me relay access denied error, then now i turn on allow mail to be relay to the domain in smtp connector   in SMTP connector , now its works but we cant enabled this because now my this server is open relay , we need to restrict this

    please let me know how we can resolve this without turn on this option

    regards

    jeevan
    Thursday, November 05, 2009 12:35 PM
  • If you want to create any additional SMTP virtual servers, you can use the New SMTP Virtual Server Wizard.

    You can use the Exchange System Manager to configure the following settings for SMTP virtual servers:

    Change the default setting of the TCP port.
    Change the default setting of the SSL port.
    Configure incoming connections and outgoing connections.
    Configure IP address restrictions.
    Configure domain name restrictions.
    Configure authentication settings for incoming connections and outgoing connections.
    Configure TLS encryption.
    Configure the message size limit.
    Configure a limit for the number of recipients.
    Configure a limit for the number of messages allowed for each connection.
    Configure filtering.
    Grant/deny submit permissions for users/groups.
    Change the SMTP queue location.
    Configure relaying.
    Configure message delivery based on retry intervals and message hop count.
    Configure the server as a smart host or configure the server to forward outgoing e-mail to a smart host.
    Enable reverse DNS lookup and define a reverse DNS list.
    Specify the location where copies of non-delivery report (NDR) messages should be stored

    http://www.tech-faq.com/configuring-and-maintaining-exchange-server-2003-virtual-servers.shtml

    Vinod |CCNA|MCSE 2003 +Messaging|MCTS|ITIL V3|
    Thursday, November 05, 2009 12:36 PM
  • hi,

    i think i found the problem , i create the DNS entry name with the New IP address and i changed the FQDN in second SMTP VS on delievery-->advanced tab, after the name changed it gives me the relay error. if i give the FQDN for the Exchange machine it works



    can we change this ,because in message header name should be changed because i already create the PTR record entry according to this FQDN

    regards

    jeevan
    Thursday, November 05, 2009 12:50 PM
  • You should be able to change the FQDN
    Vinod |CCNA|MCSE 2003 +Messaging|MCTS|ITIL V3|
    Thursday, November 05, 2009 1:31 PM
  • I would say on first SMTP VS put the ip address of the second SMTP VS under relay settings and try.

    and Keep the FQDN of second SMTP VS as default
    Vinod |CCNA|MCSE 2003 +Messaging|MCTS|ITIL V3|
    Thursday, November 05, 2009 2:39 PM
  • if i am not changed the FQDN of SMTP VS it goes,

    Friday, November 06, 2009 4:29 AM
  • Is it working now according to your requirement?
    Raj
    Friday, November 06, 2009 6:50 AM
  • my problem is that i am not able to change the FQDN of the SMTP VS , when i send mail using this VS it gives me same message header as it first VS
    Friday, November 06, 2009 7:12 AM
  • Please describe the detailed exchange topology, how’s the exchange server deployed?

    Please enable diagnostic logging related to MSExchangeTransport on the problematic exchange server and post the log info

     


    James Luo
    TechNet Subscriber Support (http://technet.microsoft.com/en-us/subscriptions/ms788697.aspx)
    If you have any feedback on our support, please contact tngfb@microsoft.com
    Friday, November 06, 2009 7:28 AM