locked
SharePoint 2013 Publishing Infrastructure Feature Error on Migrated Site (One or more field types are not installed properly. Go to the list settings page to delete these fields. ) RRS feed

  • Question

  • whenever I tried to activate SharePoint Publishing infrastructure feature in any migrated site collection from SP 2010 to SP 2013. It shows me error -"One or more field types are not installed properly. Go to the list settings page to delete these fields". which is due to failure of activation of Publishing resources feature.

    I check the logs and below Messsage corresponding to Correlation ID which relates my feature:

    Failed to get field TaxCatchAll of list Webpartkatalog.

    Instantiating module "CMSWebParts": Failed to set the metainfo on file at URL "TableOfContents.webpart", stopping.

    One or more field types are not installed properly. Go to the list settings page to delete these fields.

    AND ExceptionMsg:

    SPRequest.EnableModuleFromXml: UserPrincipalName=i:0).w|s-1-5-21-2050033333-681274564-2079600828-1325472, AppPrincipalName= ,bstrSetupDirectory=C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\Template ,bstrFeatureDirectory=Features\PublishingResources ,bstrUrl=http://XXXXX/sites/350024 ,bstrXML=<Module Name="CMSWebParts" List="113" Url="_catalogs/wp" Path="dwp" RootWebOnly="TRUE" xmlns="ttp://schemas.microsoft.com/sharepoint/">  <File Url="ContentQuery.webpart" Type="GhostableInLibrary"><Property Name="ContentTypeName" Value="$Resources:cmscore,contenttype_articlepage_name;"></Property><Pro ,fForceUnghost=False ,pModuleContext=<null>


    The element of type 'Module' for feature 'PublishingResources' (id: aebc918d-b20f-4a11-a1db-9ed84d79c87e) threw an exception during activation: One or more field types are not installed properly. Go to the list settings page to delete these fields.

     

    Exception was thrown while ensuring dependencies met for feature 'PublishingSite' (id: f6924d36-2fa8-4f0b-b16d-06b7250180fa): Microsoft.SharePoint.SPException: One or more field types are not installed properly. Go to the list settings page to delete these fields. ---> System.Runtime.InteropServices.COMException: One or more field types are not installed properly. Go to the list settings page to delete these fields.   
     at Microsoft.SharePoint.Library.SPRequestInternalClass.EnableModuleFromXml(String bstrSetupDirectory, String bstrFeatureDirectory, String bstrUrl, String bstrXML, Boolean fForceUnghost, ISPEnableModuleCallback pModuleContext)   
     at Microsoft.SharePoint.Library.SPRequest.EnableModuleFromXml(String bstrSetupDirectory, String bstrFeatureDirectory, String bstrUrl, String bstrXML, Boolean fForceUnghost, ISPEnableModuleCallback pModuleContext)     -
     -- End of inner exception stack trace ---   
     at Microsoft.SharePoint.Administration.SPElementDefinitionCollection.ProvisionModules(SPFeaturePropertyCollection props, SPSite site, SPWeb web, SPFeatureActivateFlags activateFlags, Boolean fForce)   
     at Microsoft.SharePoint.Administration.SPElementDefinitionCollection.ProvisionElements(SPFeaturePropertyCollection props, SPWebApplication webapp, SPSite site, SPWeb web, SPFeatureActivateFlags activateFlags, Boolean fForce)   
     at Microsoft.SharePoint.SPFeature.Activate(SPSite siteParent, SPWeb webParent, SPFeaturePropertyCollection props, SPFeatureActivateFlags activateFlags, Boolean fForce)   
     at Microsoft.SharePoint.SPFeatureCollection.AddInternal(SPFeatureDefinition featdef, Version version, SPFeaturePropertyCollection properties, SPFeatureActivateFlags activateFlags, Boolean force, Boolean fMarkOnly)   
     at Microsoft.SharePoint.SPFeatureCollection.CheckSameScopeDependency(SPFeatureDefinition featdefDependant, SPFeatureDependency featdep, SPFeatureDefinition featdefDependency, Boolean fActivateHidden, Boolean fUpgrade, Boolean fForce, Boolean fMarkOnly)   
     at Microsoft.SharePoint.SPFeatureCollection.CheckFeatureDependency(SPFeatureDefinition featdefDependant, SPFeatureDependency featdep, Boolean fActivateHidden, Boolean fUpgrade, Boolean fForce, Boolean fMarkOnly, FailureReason& errType)   
     at Microsoft.SharePoint.SPFeatureCollection.CheckFeatureDependencies(SPFeatureDefinition featdef, Boolean fActivateHidden, Boolean fUpgrade, Boolean fForce, Boolean fThrowError, Boolean fMarkOnly, List`1& missingFeatures)

     

    1 important thing is this feature gets activated after trying 3 -4 times.

    I also tried "relationships list" list deletion solution but that list does not exist on all sites (Url:  /sites//Relationships%20List/AllItems.aspx)

    Can anyone tell me root cause for the same or faces the same issue. Your solution for the same is appreciated...

    Thanks!!!

    Thursday, June 4, 2015 11:53 AM