locked
Shared folders dissapear after navagating to them.... RRS feed

  • Question

  •    Here is a very VERY odd problem..  I have several shared folders setup on a 2008R1 Server and Both of our Win7 machines seem to lose files and folders after we navigate to them. Seems this issue has been with me since the vista days but those folders only store media files and for the longest time were primarily accessed by a media device and everything worked perfectly. Since that device died I have been using my 360 as a media center extender and that's when I noticed the issue happened ALL THE TIME. Regardless if I navigate to it with the server name or the IP address the results are the same, the dir listing is fine until i go into a folder.. when I back out that folder disappears completely. On occasion the whole dir structure is blank. If i type in a folder name that is missing it will still get to it but there is no way to navigate to is (consequently my 360 complains that there are no files to watch...). This is on a wired network via a d-link DIR-655 router using IPv4. These problem do not present on an xp machine or any Linux derivative on the network... only on the win7 machines and vista machines I tried so the problem is likely with win7 / vista and not the server. No error messages are presant and nothing shows up in the event logs. If I F5 10-30 times the folder returns.

    Things I have tried:

        Disabling AV
        Disabling Firewall
        Connecting via a different switch
        Verified all drivers are correct
        Tried mounting the shared folder as a drive
        DNS nslookup tests all show good
        Replaced networking cables
        added the shared folders to the directory
        added the "Everyone" security group to both NTFS and Shared permissions
        begged the server and offered cake/upgrades
       

    PLEASE HELP!!!!

    Thursday, January 14, 2010 2:02 AM

All replies

  • This issue occurs if Windows Explorer tries to obtain detailed information about the file that you are opening. This operation may take a long time over a slow connection.

    First, please make sure your router is compatible with your Windows 7, and you can test in a new account. In addition, you can try the steps:

    1. disable the autotuning function, Please run the following commands as administrator,

    Netsh interface tcp set global rss=disabled
    Netsh interface tcp show global 

    Note: If you want to make these two settings again to the default setting, you can run the following command,     
                    
    Netsh interface tcp set global rss=enabled

    2. Turn off RDC (Remote Differential Compression) Feature.
    3. Remove IPv6 from network properties if it’s not required.
    4. Clear DNS Cache. You can run command prompt as administrator, Type: ipconfig /flushdns
    5. Disable Wireless Network and any additional (including Virtual adapters) network adapters.
    6. Modifying Link Speed & Duplex Value in Network adapter Properties.

    I hope this can help you.


    John

     

    Friday, January 15, 2010 1:34 AM
  • I will try these things didn't think a pure GB network would be slow :P

    Results - Negative results on all suggestions. Behavior still exists
    Friday, January 15, 2010 3:13 AM
  • According your description, I understand you are not able to see the folder on the 2008R1 Server after you browse them via the Windows explorer, while you can open the folder via command  \\server\folder, in addition, you can see these folders after you refresh the windows explorer.  If I misunderstand your issue, please clarify your issue more clearly.

    If you have any question about my suggestions, please free to let me know.


    John
    Friday, January 15, 2010 6:58 AM
  • John,
        Your description is accurate, however i will add that F5 or "refresh" does not always work. Sometimes I must do it 10-30 time sometimes i will simply give up on it and check back later. I also do not see the behavior while navigating on the server (going to the shared location)
    Friday, January 15, 2010 7:33 AM
  • Given situation, please try my suggestion one by one, and let me know the result.

    Good luck!


    John
    Friday, January 15, 2010 10:11 AM
  • Given situation, please try my suggestion one by one, and let me know the result.

    Good luck!


    John
    John, as mentioned above I did try all of your suggestions, with a negative result.
    Friday, January 15, 2010 6:05 PM
  • Something I forgot to mention the shared folders where this happens contain folders which are all mounted partitions.... I noticed today that a single file at the root of the dir is always present, it's the subfolders that vanish so must be something to do with the fact that the folders are mounted drives....

    Any thoughts on that angle?
    Monday, January 18, 2010 9:01 AM
  • Hi,

    What do you refer to the mounted partitions, Linux style mount or mount NTFS partition as folder? Do you still have the same performance issue when you try to access a share folder without this type of mounted partitions? I think it’s worth a try.

    If the issue persists, I suggest you make this share folder available offline (right click this share folder and select “Always available offline”), that will be helpful to boost the access performance.

    What's your opinion?

    Wednesday, January 20, 2010 5:35 AM
  • As i said it is all windows machines on the network including the server which is server 2008 R1 . So they are NTFS partitions mounted into folders which has worked for non vista/win7 clients for years (across several server os versions.


    And also as said above no I do not see the behavior with standard shared folders, but switching back is not feasible due to the size of data involved.

    I will am unsure of marking these as always available offline as there are 4TB of data stored on them and I do NOT ever want the systems to attempt to cache that much data.
    Friday, January 22, 2010 8:05 PM
  • Hi,

    Since there is no similar issue for standard shared folders, I assume the root cause of the issue is more related to NTFS mounted folders (or the new OS access/authentication mechanism).

    I would like to know how many mounted share folder do you have. If you have other share folder other than the one with 4TB data, do you have the same performance issue when try to access that folder?

    I have a mounted share folder with about 1GB data on my network (Windows server 2003 R2), there is no performance issue when I try to access it from XP or Windows 7 PCs. Personally, I think you can consider use mklink to build a symbolic link instead of mount  folder as a test. Do you still have the same issue now?
    http://technet.microsoft.com/en-us/library/cc753194%28WS.10%29.aspx

     

    Monday, January 25, 2010 2:10 AM
  • Gordon I should elaborate on my situation.
    Here is the layout of the offending share:

    Movies (real folder and is the root of the share)
        Action (Mounted Folder, this is an example and there are about 14 folders like this one here)
              (Contained in each folder are 10-800GB of data)

    The error is not WITHIN the mounted folders, the issue is in the root share. Once I get into the folder all files / folders show up every time. It's just the list of folders with mounted partitions. So on your test you would have to make a share containing a few folders each mounted to a separate partition.

    To answer your specific questions:
     One shared folder has 14 folders, the other has 33. Both show this issue at the same rate.

    The two root  folders are actually splitting the 4TB pretty evenly.

    I will attempt the symbolic link later today.

    This all seems "hooky" as this same setup has worked for YEARS with an XBOX and then even with a windows machine with XBMC running on it. It's only when accessing THROUGH windows explorer that the issue pops up. 
       
     
    Monday, January 25, 2010 8:14 PM
  • Hi,

    I cannot perform this test since there are two partitions in my Server 2003. What’s the result of mklink, any error or performance issue now?

    Meanwhile, as you may know, Windows 7 has some features which may slow the Network performance and you can consider turn off them as a test if mklink still not work:
    1. Auto-tuning
    Click Start
    Input cmd, Right-click Command Prompt, and then click Run as Administrator.
    If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
    At the command prompt, type the following command, and then press ENTER:
    netsh interface tcp set global autotuninglevel=disabled
    This command disables the Receive Window Auto-Tuning feature.

    2. Remote Differential Compression (RDC)
    -------------------
    Start>>Control Panel>>Programs and Features
    Click on ‘Turn windows features on or off’ on the left side of the screen
    Unchecked ‘Remote Differential Compression’

    Pls restart the computer and test the issue again.

    PS: John has mentioned the two feature in his post, but I’m not sure if you have complete those steps yet.

    Tuesday, January 26, 2010 5:00 AM
  • Hi all,

    we are experiencing the same problem - setup differs as all the machines are running win7, including the data server, all connected by wired 1GB network. The folder in question is our data storage unit (15 drives). each disk is mounted as a folder within the 'data store' folder

    -Y Drive
    ------disk 1
    ------disk 2
    ------disk 3

    etc etc

    the 'Y drive' is shared and all machines see it fine, the issue is if I navigate to say 'disk 2' and then navigate back to the y drive, disk 2 will no longer show up. It is still accessible via command y drive/disk 2.   after a while the missing folder will show again.

    I'll add that in the expanded tree view on the left hand window pane the folders stay there, it's just in the main folder view that it all disappears.

    one other thing I'll add is when I first set it up, the mounted drives were in a folder with a different name and only one machine had the issue of disappearing folders. I remounted the drives as folders in a different main folder and now all the machines connected lose the folders.

    Accessing data from the mounted drives is fine, you just need to be able to navigate to them.

    I'm working thro the above suggestions but so far no change, any suggestions would be really helpful and very much appreciated.

    Also, anyone no of a way to visually show that a folder is shared (you know, like windows used to have)

    cheers
    Jeff
    Friday, February 5, 2010 8:13 PM
  • Hi Cold Realms,

    don't know if you have found any solution yet - The only thing I have found so far that has 'fixed' ours is to uncheck 'hide protected operating system files'

    not a great solution - don't really like the workers having access to the sys files - but at the moment that is the only thing that shows the mounted folders.

    Would love to hear if you have had any luck,

    cheers
    Jeff
    Sunday, February 7, 2010 8:03 PM
  • Same issue here.  Has anyone figured out how to fix this without unchecking "Hide protected operating system files"?

     

    -pete

    Friday, July 30, 2010 4:49 PM