Windows Image Restore gives Error code: 0x80070057, using a Dell RD1000 Removable drive RRS feed

  • Question

  • I have purchased an original Dell PowerEdge II Server, with a pre-installed legal copy of Windows Small Business Server 2011 Essentials. In my case this server contains a Dell RD1000 removable drive for backup purposes. It is known that the standard Windows Server Backup utility, does not support removable drives as valid backup target in combination with a scheduled backup ("backup at once" (manual backup) works fine and the standard Windows "bare metal" restore too). As a workaround I shared my Dell RD1000 drive to use it in combination with a scheduled backup. So far so good. But when I do a "bare metal" restore (using the original Windows SBS 2011 Setup DVD), the image on the RD1000 is found, but after restoring the partition table (destroying the original Windows installation) the actual restore fails with the error message: The system image restore failed. Error details: the parameter is incorrect (0x80070057). This is all happening on the same original and unchanged server.

    But now this... If I copy the backup data from the RD1000 disk to an USB harddisk, and restore from there using the same procedure, the restore works fine! I even tried to copy the backup data to a shared folder in my network and restore from there. Guess what, that works fine too. (Both methods are working with of without the (unused) RD1000 drive installed or not, by the way, so the number of drives during restore does not matter in my case).

    In a sense I have a solution for my problem, but I desperately want it to work straight from my RD1000 drive, since it contains a perfectly usable backup. Any suggestion or solution will be much obliged.

    Kind regards, "RD1000"


    • Edited by RD1000 Friday, May 4, 2012 9:29 PM Small correction
    Friday, May 4, 2012 4:14 PM

All replies

  • This forum is for SBS 2011 Essentials and your question seems to be about SBS 2011 Standard? If so you might ask in the forum for that.


    Friday, May 4, 2012 8:13 PM
  • It is indeed about Small Business Server 2011 Essentials. Thanks for asking.



    Friday, May 4, 2012 9:26 PM
  • Compukirk read that you were using the "Windows SBS 2011 Setup DVD" for your restore.

    Think it could be an indicator of what you're experiencing?:

    Sunday, May 6, 2012 1:31 AM
  • I have ejected the Setup DVD once. That was offering no solution. Ejecting my RD1000 removable drive is no option, because it contains the drive image backup. Thanks for thinking along though...


    Monday, May 7, 2012 4:45 PM
  • Do you know if the enumerated drives are different between when you did the backup and when you are trying to restore?  This was the key to the fix in the article.  If sharing your RD1000 to the server created another drive, then perhaps plugging in a USB drive or two in the right order to mimic the drive list at time of backup would work.  (Grasping at straws, really.)  I'd really hate to think that this would make a backup all but useless, though.

    Tuesday, May 8, 2012 12:32 AM
  • Hi Travis,

    Plugging in an USB drive (one and later two) is exactly what I have tried. I noticed that my RD1000 drive was assigned the drive pointer C at first, during restore. While it was drive E during the backup. So I plugged in one USB stick which causes the assigning of the drive pointer D to my RD1000, during the restore phase. Then I plugged in a second one. Causing the assignment op drive pointer E (like the backup situation) to the RD1000. I was pretty sure that this would do the trick! Hopefully I waited, but unfortunately... the same error.

    But now this: why do the number of enumerated drives not care, when I do a restore from a USB drive or a share? No matter what the number of drives, it always works fine. But the problem is (as I stated in my original question) I have to copy the whole contents first from my RD1000 to one of both mentioned media. Strange, don’t you think…

    Thanks very much for thinking along. Any other suggestions are welcome.


    • Edited by RD1000 Wednesday, May 9, 2012 6:50 PM
    Wednesday, May 9, 2012 6:49 PM
  • The only technical difference I can think of that might exist is how Windows sees the two disks - fixed vs removable.  Why that would come into play with a backup restoration, I don't know.  But you're physically moving that backup off that RD1000 to a USB drive and being successful so it has to be how the system is seeing the RD1000. 

    I'm guessing your RD1000 has a SATA connection.  Do you have an adapter to convert SATA to USB?  If so, present the RD1000 to the system as an external USB drive and see what happens.

    • Marked as answer by Sean Zhu -Moderator Monday, May 14, 2012 6:02 AM
    • Unmarked as answer by RD1000 Wednesday, May 30, 2012 8:14 AM
    Thursday, May 10, 2012 1:38 AM
  • Mmm, nice suggestion. I'll let you know.


    Tuesday, May 15, 2012 10:17 PM
  • fwiw, windows server backup does not like more than one (1) usb drives connected. that's my experience.
    • Proposed as answer by rino19ny Sunday, May 20, 2012 7:20 AM
    Sunday, May 20, 2012 7:19 AM
  • I can confirm, using an external Dell RD1000 drive (USB) provides only the same error. Looks like it sees the external RD1000 the same way as it sees it internally. A removable drive.
    Wednesday, March 20, 2019 9:08 PM